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CHAPTER 1

Welcome to Agent!
Congratulations for choosing Agent, your Internet personal communications tool.  With
Agent, you get the best of two worlds in one neat package: an efficient email program and an
online/offline newsreader.  With these two functions fully integrated in one package, you’ll
never need to switch between different programs when you want to check your email or read
news discussions on the Usenet.

Agent provides you with more functionality than you ever dreamed possible.  For example,
you can:

• Fight email and Usenet “spam” with kill and watch filters

• Organize all your news and email messages in folders

• Send and receive file attachments in a variety of formats

• Customize anything, from the toolbars to the window layout

Best of all, Agent is easy to use.  You don't have to be a "techie", so relax!  Have fun.

In Chapter 1, you'll learn about the following:

1 Agent Features

1 About Email and Newsgroups

1 How to Get Help

1 About This User Guide
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Agent Features
• Painless Installation and Setup - Installing Agent is a breeze.  Agent's

installation wizard guides you through the setup process in just a few
minutes.  It couldn't be easier.

• Support for Windows 95 and Windows NT - 32-bit Agent supports
long file names, as well as dial-up networking (Windows 95) and Remote
Access Services (Windows NT).

• Full Email Functionality - You can send and receive email messages,
and you can create an address book for your most frequently used email
addresses.  You can even tell Agent to use a MAPI system to send mail,
if you like.

• Support for MIME - Agent supports the widely accepted message
transferal protocol called MIME, allowing you the greatest flexibility in
sending messages and attachments.

• File attachments - With Agent, you can send and receive a wide variety
of attachment types in email and Usenet messages.  Agent will
automatically join large multi-part attachments to reduce clutter.

• Online/Offline Capability - Being able to work online or offline allows
you to balance economic considerations versus the desire for
convenience.  If economy is a prime consideration, using the offline
mode minimizes your online time by connecting to the server only long
enough to retrieve new headers.  You can then read the messages
offline, at your leisure.  If convenience is more important, the online
mode retains Agent's server connection, so that you never have to wait
to reestablish the connection during an Agent session.

• Easy Browsing - Agent makes it easy to quickly sample a newsgroup.
For example, to find out what alt.usenet.kooks is about, you can
sample the group's most recent messages, then either subscribe to that
group to get more messages, or leave it behind and move on to other
groups.

• Configurable Multi-Pane Windows - Agent’s window environment is
divided into three panes:  Groups, Message List, and Message.  You
may configure these panes to suit your own preferences.

• Threading and Navigation - Agent uses multi-level threading, indenting
responses to messages under the initial message, so you can follow a
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discussion without searching for the responses.  Agent provides a
number of shortcuts for navigating efficiently through all your messages.

• Ignore and Watch Commands - Usenet receives so many messages
that it can be a major task to find the ones that interest you.  To
minimize the clutter, Agent has Ignore and Watch options, which allow
you to skip or retrieve messages in specified threads.

• Usenet Filters - To further reduce the clutter in newsgroups, Agent
supports Usenet filters (also known as Kill and Watch lists).  You may kill
or watch messages with a specified subject, author, or message length.

• Crosspost Management - Agent allows you to filter out messages that
have been posted to multiple newsgroups, so that you don't end up
reading the same message more than once.

• Folders - Organize information your way.  Create folders for any topic
you want, then simply drag selected messages with the mouse and drop
them into the desired folder.  Also, inbound email can be automatically
filed into specified folders.

• Sorting - Agent makes it easy to quickly find specific messages by
allowing you to sort messages in groups and folders.

• Launching URLs - All URLs in messages (i.e., web addresses and
email addresses) appear as interactive links that can be launched by
simply double-clicking them.

• Purging and Compacting Databases - Agent allows you to manage
your disk space by designing a purging strategy (e.g., keeping messages
only for as long as they're available on your server).  After purging, you
can compact your database to reclaim previously used disk space.

• Spell Checker - Whenever you compose a message, you can check for
spelling errors using Agent's built-in spell checker.  You can choose from
a number of language-specific dictionaries.

• Customizable Toolbars - By choosing from over 150 toolbar
commands, you can customize Agent's toolbars so they contain the
functions you use most.

• Languages - Agent supports a variety of character sets for different
languages, including some with special accented characters like French,
or with a unique set of characters like Russian.  These character sets
allow you to view the messages correctly for the given language.
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About Email and Newsgroups
Agent is an integrated email program and newsreader.  If you're unfamiliar
about these functions, here's a brief explanation.

Email
The word "email" is the common techno-term for electronic mail.  Email, in
the past few years, has become an integral communication tool that rivals
the telephone in many workplaces and homes.  Companies with computer
networks often use some sort of email program that allows employees to
communicate ideas and discuss topics with one or more coworkers.  At
home, people are beginning to access the Internet in greater numbers and to
use email to communicate with friends and loved ones.

Agent has made sending and receiving email a snap.  You can compose and
send email to individuals, or to lists of people.  When receiving email, you
can tell Agent to automatically file messages from certain people or about
certain subjects in designated folders. You can even create an Address Book
in which to keep your most frequently used email addresses.

Email addresses all share a common structure:  the user ID component, the
"@" character and the server "domain" (e.g., .com for commercial firms, or
.edu for educational institutions).  Here are two examples:
jdoe@acmeinc.com (an address at a company) and msmith@csu.edu (an
address at a university).

Newsgroups

Newsgroups are electronic forums covering a wide spectrum of subjects.  In
these forums, people can share ideas and information.  You can read what
other people think about a particular topic and you can join right in the
discussion yourself, if you wish.

If you've never seen a list of newsgroups before, you may very well be
overwhelmed as you begin perusing the names in the groups list.  Many of
the newsgroups are not named with any thought to clarity.  The cryptic
abbreviations and acronyms used are bound to puzzle the novice.

For example, can you tell what abg.uucp.waffle, fidonet.openbeta,
linux.act.hams, or sfnet.csc.tiedotukset are about?  You're not alone if
this looks like gibberish to you.  However, the Usenet uses specific naming
conventions to help make things a bit more clear.  The following table
describes some of the more common Usenet naming conventions.
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Naming Convention Topic Area

comp
Computer-related subjects, such as the group
comp.infosystems.

misc
Miscellaneous topics -- jobs, items for sale, anything
that doesn’t conveniently fit into another group, such
as the group misc.invest.canada.

news
Information about newsgroups themselves, including
information about finding and using newsgroups,
such as news.groups.reviews.

rec
Recreational topics -- hobbies, sports, movies, and
the arts, such as the group rec.humor.

sci
Scientific topics -- discussions about a vast variety of
scientific research, such as the group
sci.space.shuttle.

soc

A wide range of social issues, such as discussions
about different types of societies and subcultures, as
well as sociopolitical subjects, such as the group
soc.culture.berber.

talk
Debate about politics, religion, and anything else
that’s controversial, such as the group
talk.politics.china.

alt
Alternative subjects, ranging from the serious (computers
and psychology) to the bizarre and unconventional (occult
and alternative lifestyles).

Here's just a sample of what you will find in the world of newsgroups:

Group Name Topic Area

alt.comedy.british Discussions on British comedy, from Monty Python
to the Black Adder.

nashville.general Anything and everything about Nashville, from music
to blooming dogwood trees.

soc.culture.esperanto Communicate in this once future world language with
other aficionados.
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How to Get Help
If you have questions about Agent and you can't find the answer in this
manual, you have many other options for getting your questions answered.
This section describes each of the following options and exactly how to
access them:

• Online Help

• Internet Service Provider

• World Wide Web

• Newsgroups

• Support Question

Online Help - Agent provides extensive Online Help, which provides
information on all aspects of Agent operation.  So, if you can't find
something, here's what to do.

To access Agent’s Online Help:

• For a particular topic - Select Help from Agent's menu bar to open the
Help Contents page.  From the Contents page, you may access help
topics either by selecting How to or Search for Help on.

• For a dialog box - If you are viewing a dialog box and need help
understanding what to do, press the Help button on the dialog box and
specific help for that dialog will be displayed.

To access the Release Notes:

From the Help menu in Agent, select Release Notes.  You will see a listing
of the most recent enhancements and changes that have been made to
Agent.

Internet Service Provider - If you have any difficulties accessing the
Internet, please contact your Internet service provider (ISP).

World Wide Web - For information about the latest Agent release and
answers to the most frequently asked questions, refer to Forté’s Web site at
http://www.forteinc.com.



Welcome to Agent

7

Newsgroups - Ask and answer Agent questions with fellow Agent users
in these newsgroups:

• alt.usenet.offline-reader.forte-agent

• comp.os.ms-windows.apps.winsock.news

While these newsgroups are not "official" Agent support platforms, Forté
personnel monitor these groups and frequently answer questions and give
advice.

Support Question - You can quickly contact Agent's Support team with
questions, by selecting "Support Question" from the Post menu.  On the pre-
addressed Composition window that displays, just type your question and
send it to us.  We're eager to help.  Make sure you have the correct return
address when you send a question.  Otherwise we won't be able to send you
an answer.

About This User Guide
To better follow the contents of this User Guide, you'll want to note the
following conventions used to clarify different types of information.  This
section also describes the various chapters that make up this User Guide,
allowing you to see at a glance how this guide is organized.

Conventions

courier type for words or characters you type.  Typed entries
are always shown in lowercase letters, unless they
must be typed in uppercase to work properly.

“Quotes” for new terms and single keyboard characters.

Bold Type for newsgroup names and URL addresses.

Italic Type for fields on dialog boxes, toolbar icons, and
buttons.

Menu→Dialog→Tab for the sequence of mouse clicks necessary to
display a dialog box

for tips, reminders, or cautions.
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In addition to the above conventions, you'll also see alternative ways for
invoking Agent's menu options, such as the example below:

Toolbar button:

Menu option: Message→Watch Thread

Keyboard shortcut: W

Note:  The browsers and dialog boxes shown in this User's Guide are from
the Windows 95 version of Agent, unless noted.

Organization

Chapter 1,  Welcome to Agent, presents a brief overview of Agent’s many
features, discusses the guide and tells you how to get help when you have
questions about Agent.

Chapter 2, Getting Started, steps you through the installation of Agent.
During this initial session, you will retrieve all available newsgroups from
your service provider, sample message headers from groups, and subscribe
to those groups that interest you.  This chapter also describes checking for
email for the first time.

Chapter 3,  Agent Fundamentals, introduces you to several key concepts
about the way Agent is designed to work, how information is displayed in
Agent's three-pane window environment, how to navigate efficiently through
these panes, how you can define specific properties for newsgroups, and
how to work in online or offline mode.

Chapter 4, All About Messages, shows you how to organize messages in
folders, how to retrieve and view only the messages you want to track, and
how to "purge" (or remove) messages after a certain period of time.

Chapter 5, Composing and Sending Messages, includes information on
how to compose a message, how to create a signature, how to include
attachments, how to specify preferences for composing and sending
messages, and how to tell Agent to use MAPI to send messages.

Chapter 6, Using Attachments, describes how to attach files (e.g., GIF
image files) to messages you compose.  You'll also see how easy it is to
view or save attachments in messages that you receive.
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Chapter 7, Agent and Other Applications, describes how to launch URLs
from Agent in your web browser, how to make Agent your web browser's
primary newsgroup and mail service, and how to import and export newsrc
files.

Chapter 8, Customizing Agent, describes how to customize Agent's
toolbars, Folders menu, window layout, and the appearance of message
headers and the text in message bodies.
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CHAPTER 2

Getting Started
This chapter helps you to get up and running with Agent.  You will install Agent, retrieve the
list of all the available newsgroups, subscribe to groups that interest you, retrieve message
headers, and check for email.  Installing Agent is effortless with Agent's Installation Wizard.
In minutes, you'll be retrieving thousands of newsgroups and can begin to be a fully active
participant in news discussions and Internet communications.

Here's how the chapter is organized:

1 Installing Agent

1 Retrieving a Complete List of Groups

1 Agent's Three-pane Layout

1 Your First Session With Agent

1 Retrieving Email for the First Time

Installing Agent
There are two versions of Agent available:  16-bit and 32-bit.

The 16-bit version is commonly used on PCs that are running Windows 3.1
or greater as the operating environment.

The 32-bit version is designed to run on newer, more powerful PCs that use
a Windows 95 or Windows NT operating environment.  (Agent will not run
using Win32S with Windows 3.1.)  Agent's 32-bit version supports:

• Multitasking, allowing you to do several tasks at the same time.

• Long file names (more than eight characters).

• Dial-Up Networking (Windows 95) and Remote Access Services
(Windows NT).
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PC Requirements

Before you install Agent, you should make sure that your PC meets the
following requirements:

• IBM PC or compatible (minimum 386SX processor or higher).

• A minimum of 4 MB RAM (although we recommend 16 MB RAM for
Windows 95 users and 8 MB RAM for Windows 3.x users).

• A minimum of 8 MB of free disk space for installation.

16-Bit Agent Requirements

• Windows 3.1 or greater, or Windows NT 3.5 or greater.

• A TCP/IP driver that supports Winsock 1.1 applications.

• Access to an NNTP news server.

• Access to an SMTP mail server for sending email.

• Access to a POP or SMTP mail server for receiving email.

32-Bit Agent Requirements

• Windows 95 or Windows NT 3.5 or greater.

• 32-bit TCP/IP protocol support with a 32-bit Winsock.

• Access to an NNTP news server.

• Access to an SMTP mail server for posting email.

• Access to a POP or SMTP mail server for receiving email.

Installation Methods

You can install Agent in one of two ways:

• electronically by downloading the program from the Internet

• by purchasing a shrink-wrapped version, where the program is on
diskettes or a CD ROM.
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To install Agent electronically:

1. If you don't already have a copy of Agent, you need to download Agent's
installation EXE file into any directory.  You can access the EXE file
from Forté's web site at http://www.forteinc.com/store/getagent.htm.

2. Run the EXE file to activate the installation "wizard".

In Windows 95 - select Run from the Start menu, enter the path of the
EXE file in the Open entry box, and press OK.

Windows 3.x - select Run from the File menu, enter the path of the
EXE file in the Command Line entry box, and press OK.

The installation wizard that appears will guide you through the setup
process.  Simply follow the clearly documented instructions on the
screen.  At any time, you can cancel the process or backtrack through
previous screens to change any of your entries or selected options.

To install Agent using a shrink-wrapped copy:

1. Insert the CD ROM or diskettes containing the program in the
appropriate drive (typically d: drive for CD ROMs and a: drive for
diskettes).

2. Run the SETUP.EXE file to activate the installation "wizard".

In Windows 95 - select Run from the Start menu, enter the path of the
SETUP.EXE file (e.g., d:\setup.exe) in the Open field, and press OK.

Windows 3.x - select Run from the File menu, enter the path of the
SETUP.EXE file (e.g., a:\setup.exe) in the Command Line entry box,
and press OK.

The installation wizard that appears will guide you through the setup
process.  Simply follow the instructions on the screen. At any time, you
can cancel the process or navigate back through the series of screens to
change any of your previous entries or selected options.

Registering Agent
Before you can use Agent, you must initialize the program by entering a
unique registration number and the names of your mail and news servers.
Additionally, if your news server requires a user name or password to log in
or if you're using either a Dial-Up Networking (DUN) or Remote Access
Services (RAS) dialer, you must configure Agent for these features as well.
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To register Agent:

1. Run Agent.

Windows 95 - Click the Start button, select Programs, then select the
Agent flyout menu and click the Agent icon.

Windows 3.x - In Program Manager, open the Agent program group
and double-click the Agent icon.

2. Read the Licensing Agreement (in downloaded versions only). Click
the Agree button to proceed.

3. Register your copy of Agent.  You are required register your software
before you can operate Agent.

For electronically downloaded copies of Agent, copy the registration key
sent to you via email after purchasing Agent and paste it into Agent's
registration dialog box (see the example below).  Then press OK.

For shrink-wrapped copies of Agent, enter your name, the name of your
organization (optional), and the serial number (found on the shrink-
wrapped package), shown as follows.  Then press OK.
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After registering your copy of Agent, the Agent Setup dialog box appears.

Note:  If you've installed a new version over an existing version, the Agent
Setup dialog box will not appear.  When upgrading from Free Agent, you're
automatically upgraded, your current setup information is preserved, and the
dialog box does not appear.
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If you've already been using another Internet software program, simply press
Use Information From Another Program and Agent will automatically fill in
the information for you.  If you don’t use one of the programs listed, or if you
encounter problems when getting the information from another program,
you’ll need to enter the information manually as described below.  If you’re
not sure about any of the details, please contact your Internet service
provider for assistance.

1. News (NNTP) Server - the name of your news server or its IP address.

2. Mail (SMTP) Server - the name of your email server or its IP address.

3. Email Address - your full email address

4. Full Name - (Optional) your full name.  This name will be included with
your email address in the messages you send.  It's helpful to include your
full name if your email address doesn't contain your name.  Also, some
newsreaders display full names, if available, rather than email
addresses.

5. Time Zone - (16-bit Agent only) Select the time zone in which you are
located.  Agent uses the time zone to convert the dates of messages to
your own local time.

6. Automatically adjust for Daylight Saving Time - (16-bit Agent only.
32-bit Agent gets the time settings from Windows.)  Check this box if
you live where Daylight Saving Time is observed between April and
October.  During these months, Agent automatically compensates for
the time difference.

Retrieving a Complete List of Groups
As soon as you've finished entering the required information on the Agent
Setup dialog box and have pressed OK, a confirmation box pops up asking
whether you want to go online to retrieve all the available "newsgroups".

To
configure
for
receiving
email,
see p. 23
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• If you don't require authorization to log into your news server,
press Yes and Agent will get a list of all newsgroups available from your
service provider.  Since there are thousands of groups available on the
Internet, this may take several minutes.

• If your news server requires authorization to log in, you must supply
the appropriate authorization information. Note that most newservers
don't require authorization.  If you're not sure, please check with your
Internet service provider.  To set up authorization, press No on the
above dialog and follow these instructions:

To define news server authorization:

Select Options→User and System Profile→User.  On this tab, complete
the following settings as instructed below.

1. Server requires authorization login - Check this box if your news
server requires a special name and/or password for logging in.
When checked, Agent will automatically supply your user name
when requested by the news server.

2. User Name - Enter the user name required by your news server
when logging in.

3. Remember Password between sessions - Check this box if your
news server requires a special password for logging in and you want
Agent to automatically enter the password for you.  If you don't
check this box, you'll need to enter your password each time you log
in to your news server.

4. Password - Enter the password required by your news server for
logging in.  For security, your password appears in asterisks (*).

Now that you've set up news server authorization, select Online→Get
New Groups to get the list of all newsgroups.
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_____________________________________________________________

OO At any time, you can cancel the retrieval process by clicking the Stop
Sign icon  on the toolbar.  To get a complete list of groups at a later
time, you must select Online→Refresh Groups List.  Agent lists the
newsgroup names in the All Groups pane, as shown below.  Note:
When you first retrieve groups, all groups are marked with the New
Group icon .  The next time you get new groups, this icon will be
removed from existing groups, appearing only by the groups most
recently retrieved.

_____________________________________________________________

Agent's Three Pane Layout
When Agent begins retrieving the complete list of groups for your server,
you'll get your first glimpse of Agent's Main Browser window.
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By default, this window is divided into three panes .  Each pane has a
distinct function.  The upper left pane shows the list of groups, the upper
right pane shows the list of all messages in a selected group, and the bottom
pane shows the body, or text, of a highlighted message.  You can zoom into
any of the three panes simply by clicking the cursor in the desired pane
(giving that pane the focus) and hitting the "z" key.

For a full description of all the components of Agent's Main Browser window,
see "Agent's User Interface" in the next chapter.

Your First Session With Agent
Now that all the groups have been retrieved, you're ready to explore and
work with Agent.  To help you get started, we've presented some simple
steps for you to follow.

Find Groups that Interest You

The first thing you need to do is to survey the long list of groups you've
retrieved and find the groups that interest you.  You can either scroll through
the list and select groups at random, or you can use the Find function to find
specific text.  When you find a group you want to follow, you can subscribe
to it.  This allows you to quickly return to that group each time you open
Agent.

To use the Find function:

1. Select Edit→Find (or use the accelerator Ctrl+F) and the Find dialog box
will display.

2. Enter the text that is part of the group name that you want to find.  For
example, to find the group alt.usenet.offline-reader.forte-agent, you
might enter "agent".  Press Find First to jump to the first occurrence of
that text in the list.  If the first occurrence is not the group you want,
press Find Next (or use the F3 key) to find further occurrences of the
text.
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Sample Message Headers from a Group

Even though a group's name may sound interesting, it would help to read a
few messages in that group to see what the group is really like.  Agent allows
you to sample messages from that group (rather than retrieving all the
group's messages) to get a taste of the type of topics discussed.

To sample a group's message headers:

1. Double-click the name of the group in which you're interested. Because
it is an "empty" group, Agent will display the View Empty Group dialog
box.

The following table describes the three basic functions you can perform
using the View Empty Group dialog box.

Choose this option... ...to have Agent do this.

Sample Message Headers /
Number to sample

Retrieve the specified number of most recent
headers in a group.

Get All Message Headers
Retrieve all of the headers currently available
for a group.  This can number in the
thousands in some groups.

Subscribe to Group Add this group to the subscription list.
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2. In this initial session, enter the number of messages you want to sample
in the field Number to sample.  You can leave this field set to the
default, which is 50.  Press the Sample Message Headers button.  Agent
will retrieve the specified number of most recent headers in selected
group and will display the headers in the Message List pane (shown
below).

Retrieve and Read Message Bodies

In the Message List pane, scan the sampled message headers (i.e.,
subjects) and select (highlight) the headers with subjects that interest you.

To select multiple headers:

• For successive headers - Click the first header and drag the mouse
down the list of successive headers, or click the first header you want,
then hold down the Shift key and select the last message.

• For non-contiguous headers - Click the first header and then hold the
Ctrl button while you click on the other desired headers.
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To retrieve selected message bodies:

Select Online→Get Selected Message Bodies or press Enter.  If you only
selected one header, you can also double-click it to retrieve the body, which
appears in the Message pane for you to read.

When Agent retrieves multiple bodies, it displays the body for the first
selected header.  To view each successive body, use the option
Navigate→Skip to Next Unread Message Body (or the accelerator "B").

Subscribe to Groups that Interest You

After sampling some messages, if you want to follow the group on a regular
basis, you can subscribe to the group.  Subscribing does not cost you
anything and no one else knows about it.  It's all internal to your copy of
Agent and is simply a convenient way to organize your groups so you can
easily see the groups you use frequently.

To subscribe to the group, either press  on the toolbar, select
Group→Subscribe, or type Ctrl+S.

In subsequent Agent sessions, either press  on the toolbar or select
Online→Get New Headers in Subscribed Groups to retrieve all headers in
subscribed groups.
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To view only your subscribed groups, click the title bar of the Groups pane
until you see Subscribed Groups, or select Group→Show Groups and
Folders→Subscribed Groups and Folders.

Retrieving Email for the First Time
When installing Agent, you entered a profile of the SMTP mail server used
for sending email.  Now you need to set up Agent to retrieve mail.

To set up Agent to receive email:

Select Options→Inbound Email to open the New Folder dialog.

The New Folder dialog box tells you that in order for Agent to receive email,
you must create an Inbox folder.  (You can name this something other than
"Inbox", if you like.)  When you press OK, the Inbox (or other name) folder is
created and the Inbound Email dialog box displays.

See the Agent
Setup dialog
box on page
15.
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On the System Profile tab, complete the settings for the type of server you
are using to receive email.  If you're not sure of these settings, check with
your ISP.

1. Receive email with POP - Select this option if you receive mail with a
POP server.  Most users receive email using POP.

2. POP server - Enter the name of your POP server or its IP address.
Often this is the same name as the SMTP server.

3. Login with a username and password - Select this option if you
require both a username and password to log in to your server.

4. Use APOP if supported by the server - Check this box to require
Agent to use APOP (Authenticated Post Office Protocol, which may be
required by some  POP servers) when logging in to the server.  Agent
will use APOP if the server indicates in its greeting message that it
supports APOP.  Otherwise, Agent will use the traditional POP login.

5. Username - Enter the name used to log in to the mail server in order to
receive new messages.  E.g., gbrown.

6. Remember password between sessions - Check this box and type
your password in step 5 to have Agent automatically enter your
password when checking for new mail.  When this box is left unchecked,
Agent prompts you for your password the first time it checks for new
mail during each session with Agent.
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7. Password - Enter your email account's password if you want Agent to
automatically log onto your mail server when checking for new mail.
Note:  For security, your password appears in asterisks (*).

8. Login with Secure Password Authentication - This option is available
only to 32-bit users.  If you are using a 16-bit system, this setting is
grayed.  Select this option if the Secure Password Authentication
protocol (or SPA) is required to log in to the server.  Note:  When you
select this option, SPA will prompt you for credentials.  That is why the
Username and Password are grayed.

9. Receive email with SMTP - Select this option if your incoming email is
delivered via SMTP.

1. Load Winsock on startup - Check this box if you want to connect to
your service provider immediately upon loading Agent.  This allows
Agent to receive new mail whenever it is running and online, even if you
are using another Internet program.  When left unchecked, Agent
receives email only when it is online doing something else, such as
communicating with your news server or sending messages.

To manually check for email:

Once you've entered your System Profile information, you can
immediately check for email by selecting Online→Check for Email (or
using the keyboard shortcut Ctrl+E).  Agent goes online and logs on to
your POP server, checking for mail and retrieving any messages in your
mailbox.

To have Agent automatically check for email:

Click Options→Inbound Email→Checking Mail and check the first option
"Automatically check for email every...".  Then enter how often you want
Agent to check for mail.  When this box is checked, Agent will
automatically check for mail each time you start Agent, then will check
at the specified interval after that.

For more
on this,
see p. 47.

For more
details
about this
tab, see
page 63.
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CHAPTER 3

Agent Fundamentals
The previous chapter led you step-by-step through the installation process, including retrieval
of the complete list of newsgroups available on your news server.  Once this has been done,
you will most likely never need to do that again.  Now you're ready to start using all of the
features of Agent.  Before you jump in, you should become familiar with some of the key
concepts underlying the way Agent works.

1 Agent's User Interface

1 Navigating in Agent

1 Group Properties

1 Multi-Tasking

1 Working Online vs. Offline

Agent's User Interface

Three Pane Main Browser Window

Most of the time, you'll be working in Agent's Main Browser window which,
by default, is divided into the three panes (shown as follows).  This section
describes all of the components of the three-pane window design in detail.
You will learn what kind of information is contained in these three panes and,
also, the meaning of all the different icons that you'll encounter as you begin
to use Agent.
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Here's a description of each component:

Menu Bar - The menu bar is where all of Agent's option menus are listed.
To access a menu, click on the menu name or else press Alt and the letter in
the menu name which is underlined (e.g., for the File menu, press Alt+F).

Toolbar - The toolbar buttons below the menu bar provide quick access to
some of the most common commands in Agent.  You can customize this
toolbar so that it contain the commands you use most.  To see what each
button means, move the cursor onto the button and a brief description will
appear.

Note:  If a button is unavailable for use at a particular time, it will be dim.

Pane Title Bar - The title bar above each pane provides you with
information about the contents of that pane (e.g., which groups are shown in
the Groups pane and what the current view is in the Message List pane)

Groups/Folders Pane - This pane lists newsgroups and folders.  By
repeatedly clicking the pane's title bar (or by choosing the appropriate option
from the Group→Show Groups and Folders), you can view all groups and
folders, only subscribed groups and folders, only new groups, or only folders.

See
"Toolbars" on
page 177.

Menu Bar

Toolbar

Groups/
Folders Pane

Message
Pane

Status Bar

Context MenuMessage List Pane Scroll Bar

Menu Bar

Pane in
Focus

Pane Title
Bar
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Message List Pane - This pane is where the message headers in the
selected group or folder are displayed.  For each header, the subject,
date/time, and author of the message are displayed.

A message with responses is called a "thread" and can be collapsed to save
space, or expanded to view all the responses.  When a thread is expanded,
all responses are indented below the message and only the author is
displayed, since the subject is the same as the original message.

In the example shown on page 28, the Message List pane is the pane
currently in focus, indicated by the small solid triangle in the upper left
corner of the pane's title bar.  Even though you can see all three panes at
the same time, only one pane can have the focus at a time.

Note that the information in the Message List pane is arranged in columns.
In the example shown on page 28, the far left column, Thread is underlined,
indicating the pane is sorted by thread.  You can sort by author, date, size,
subject, or thread by opening the Group→Sort Messages by flyout menu, or
simply by clicking on the title bar of the column you want to sort.  Clicking
the title bar for the first column on the left switches you between the Thread
and Size sorts.
_____________________________________________________________

OO If you zoom the pane (type "z"), you'll see more of the columns.
These columns can easily be resized by dragging the column
boundaries with your mouse.  Note, however, that the first column on
the left (Thread in the example) cannot be made narrower.

_____________________________________________________________

When message headers are first retrieved, they are, of course, unread.
Agent indicates this by showing unread messages using the color red.
When a message is read, it’s header becomes black.  By default, each time
you retrieve new headers in a group, Agent marks the existing messages as
read, so the new messages will stand out.  You can control this behavior
using the Group→Properties→Mark Read tab.  (See p. 39 for more details.)
You can also use Group→Mark Selected Groups Read or Group→Mark
Selected Groups Unread to change the read/unread status of all messages
in a group, or Message→Mark Read or Message→Mark Unread to change
the status of individual messages.

Message Pane - The bottom pane is where the text, or "body" of the
message for the selected message header is displayed.

Scroll Bar - You will find vertical scroll bars on the right side of the each
pane that allow you to scroll through the information in the panes (i.e.,
groups and folders, message headers, and body text).  In addition, the

See
"Expanding
and
Collapsing
Threads" on
page 37.
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Message pane has a horizontal scroll bar that allows you to scroll
horizontally to view body text that may be out of view.

Status Bar - The status bar below the Message pane displays information
about Agent's current state, such as whether Agent is online or offline.

Context Menu - Agent supports context-sensitive menus, which means that
if you click RightMouse when the cursor is in one of Agent's panes, a menu
of the most frequently used commands for that pane will appear.

Icons and Indicators

On the Agent Main Browser window shown previously, you'll see a number
of icons and indicators.  For a description of each, see the following table.
This table is a general reference.  Some of these terms are explained
elsewhere in the User Guide.  (The numbers and text in the following tables
refer to what you see in the example picture of Agent on page 28.)

Groups/Folders Pane Icons

Icon Definition

5 / 23737
Groups Counter - (located on the Groups/Folders pane title bar)
The number of groups displayed in the pane, followed by the total
number of groups in the Groups list.

144
Unread Counter - (preceding each group name) The number of
messages in the group you have not read.

Mark for Retrieval - One or more messages in the group are
marked for retrieval.

Subscribed Group - (preceding subscribed groups)  To switch
between subscribing and unsubscribing, press the Subscribe
toolbar button, select the Subscribe option on the Group menu, or
type Ctrl+S.

New Group - (preceding new groups)  To get all groups added to
your news server since the last time you retrieved groups, select
Get New Groups from the Online menu.
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Message List Pane Icons

Icon Definition

View - (located in the Message List pane title bar) The currently
selected view.  Click the binoculars to select another view.

Retrieving - The body of the message is currently being retrieved.

Expand Thread -Click this icon to show the message’s responses.

Collapse Thread - Click this icon to hide the message’s responses.

[+2]
Number of Responses - For a collapsed thread, this is the number of
responses to the message.

21 Number of Lines - The number of lines in the message.

Usenet

Email

Message Body - The body of the message has been retrieved.  When
these icons are white, they indicate bodies of retrieved messages with
plain text.  Yellow indicates that the messages have attachments.  Green
indicates that all attachments have been saved for the messages.

Message Body Not Available - The message has been deleted from
your news server and is no longer available for retrieval.

Watch Thread - Agent will automatically retrieve the bodies of new
responses to the message when retrieving new message headers.

Ignore Thread - New responses to the message will be marked read
automatically.

Mark for Retrieval - The body of the message will be retrieved the next
time you select Retrieved Marked Messages from the Online menu.

Keep Message - The message you have selected to keep cannot be
deleted, either manually or by Agent's automatic purging function.

Message Pane Title Bar Indicators

Indicator Definition

Message Status Indicators - The Message Pane title bar
shows the status of a message header (e.g., the message has
been retrieved, or the message is being watched).  Also shown
are the message's subject and author, as well as the date and



Chapter 3

32

time the message was created.

Status Bar Indicators

Indicator Definition

Connecting to server. Task Description - Lets you know what task Agent is
currently performing.

Offline Offline or Online Status - Let's you know if your current
status is offline or online.

Tasks: 1 Task Status - The task currently underway.

Indicator Definition

6 / 8 Unread Status - The number of unread messages
currently viewed in the message list pane and the total
number of messages (read and unread) in the view.

SCRL Scroll Lock Key Status - For each pane in Agent,
there is a separate Scroll Lock status.  By repeatedly
selecting the Scroll Lock key, you can enable and
disable the scroll lock for each individual pane.  When
the scroll lock state is enabled, you will see SCRL on
the status bar.

OVR

(In the picture on p. 28,
this and the previous
two items are hidden by
the context menu.)

Overwrite Text Status - When editing a message in
the composition window, you can type over characters
by switching from "insert mode" to "overwrite mode".
To do this, place your cursor at the point where you
want to begin overwriting text, then press the Insert
key until you see OVR on the far right side of the
status bar.  Now you are ready to type over the text.
To return to the insert mode, press the Insert key
again.  OVR will disappear from the status bar and you
will no longer type over existing characters when you
enter new text..

Other Agent Windows

You can open more than one three-pane Browser window.  Agent also has
other windows (described elsewhere in this User Guide) to allow you to
perform other tasks (e.g., the Address Book and Usenet Filters window).  To
open these windows, use the Window menu.  By default, Agent will open
only one of each type of window.  Selecting the appropriate window from the
Window menu activates the current window if it has already been opened.
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Holding Shift while selecting the window to open will open a new window.  To
switch between open windows you can use the Window menu and select
from the list of open windows, or you can enter Ctrl+Tab to cycle through the
open windows.

Navigating in Agent
Agent provides you with a rich set of tools for moving between newsgroups,
folders, and messages.  These tools can be accessed from the Navigate
menu, the toolbar, or the keyboard.  Although you probably won't use all the
available options, this section will make you familiar with them so that you
can choose which navigation techniques best suit you.

Moving Between Panes

As you saw in the previous section, Agent is composed of three panes:  the
Groups pane, the Message List pane, and the Message pane.  You can view
all three panes at the same time, or, to maximize the information you see on
the screen, Zoom the current pane in focus to fill Agent's Browser window.

To zoom (maximize) a pane:

Use any of the following options.

Pane icon:   Windows 95      Windows 3.1

Menu option: Navigate→Zoom Window

Keyboard Shortcut: Z

To return to three-pane mode after zooming a pane:

Use any of the following options.

Pane icon:   Windows 95      Windows 3.1

Menu option: Navigate→Zoom Window

Keyboard Shortcut: Z

You can easily move the focus between the panes with either the mouse or
the keyboard.

To move between panes with the mouse:

• When viewing all three panes, simply click on the desired pane.

• When zoomed in on a pane, click the tab for the pane you wish to view:
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To move between panes with the keyboard:

• Press the Tab key to move from the Groups pane to the Message List
pane to the Message pane.

• Press Shift+Tab or Escape to move in the reverse order.

• Press the "1", "2", or "3" keys to move from pane to pane.

Pressing "1" places the focus in the Groups pane, "2" places the focus in
the Message List pane, and "3" places the focus in the Message pane.

Moving Between Messages

Moving between messages is probably the single most common action you
perform in Agent.  That's why Agent provides you so many different ways to
do this.  Before delving into the detail, it's worthwhile to understand Agent's
approach to message navigation.

Agent's navigation commands are organized to allow you to move easily
among message headers (e.g. Skip to next unread) or among message
bodies (e.g. Skip to the next unread message with a body).  Some users like
to work primarily in the message list pane, while others like to work directly
in the message body pane.  Agent allows you to do either (or both) quite
easily.

To facilitate this navigation, Agent provides skip and view  commands.
When you skip to a message, you move to that message but stay in the
same pane, generally the message list pane.  When you view a message,
you move to the message and view it in the message (body) pane, retrieving
the message if it has not yet been retrieved.  Keyboard shortcuts reflect this
distinction.  To skip, use the appropriate letter (e.g. "N" to skip to the next
unread message.)  To view, use Ctrl+letter (e.g. Ctrl+N to view the next
unread message.)

Here are the details:

To move to the previous or next message:

• From the Message List pane, you can use the up and down arrow keys
to move between messages.

• From the Message pane or Message List pane, choose Navigate→Up to
Previous Message (or press "U") or Navigate→Down to Next Message
(or press "D").
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• Either press the Backspace key, type Alt+LeftArrow, or select Back Up
from the Navigate menu to move to your previous highlighted message
(selection).  Agent allows you to backtrack up to 100 moves.

• If you've retraced your steps with the Backspace command, you can
then track forward again through your previous selections by typing
Shift+Backspace or Alt+RightArrow, or by selecting Navigate→Forward.

To skip to the next unread message:

Use any of the following options, to skip to the next unread message,
regardless of whether or not you've already retrieved its body.

Toolbar button:

Menu option: Navigate→Skip to Next Unread Message

Keyboard Shortcut: N

Use any of the following options to skip to the next unread message with a
body.

Toolbar button:

Menu option: Navigate→Skip to Next Unread Message Body

Keyboard Shortcut: B

_____________________________________________________________

OO By default, if the next unread message is in a different group, pressing
"N" or "B" opens that group or folder and selects the first unread
message.  If you would prefer to jump to the Groups/Folders pane
instead (to tell more easily when you're done with a group or folder),
on the Options→General Preferences→Navigation tab uncheck
Skipping to next unread message jumps to first unread message in
next group.

_____________________________________________________________

To skip to the next unread message in a thread:

A thread is a series of related messages grouped together.  For example,
when people post responses to a question in a group, the question and all
responses together are called a thread.  Use any of the following options.

Toolbar button:

Menu option: Navigate→Skip to Next Unread Message in Thread
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Keyboard Shortcut: T

This action is handy because when you reach the last follow-up message,
Agent stops navigating, telling you that the thread is over.

To skip to the next unread group or folder:

Use any of the following options.

Toolbar button:

Menu option: Navigate→Skip to Next Unread Group

Keyboard Shortcut: S

By default, this action marks all the unread messages in the current group or
folder as read before skipping to the next one.  It's a convenient way to tell
Agent that you've read all the interesting messages in the current group.  To
disable this behavior, on the Options→General Preferences→Navigation tab
uncheck Skipping to next unread group marks all messages in current group
read

To move to the next unread message with a body...

...and display the body text, use any of the following options.

Toolbar button:

Menu option: Navigate→View Next Unread Message Body

Keyboard Shortcut: Ctrl+B

Navigating and Retrieving Usenet Messages at the Same Time

Since you need to retrieve a Usenet message's body before you can read it,
Agent allows you to skip to an unread message and retrieve it (or mark it for
retrieval) in one step.  Note: Whether Agent retrieves the message or marks
it for later retrieval is controlled by the Viewing Unretrieved Messages When
Offline options on the Options→User and System Profile→Online tab.
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When configured for offline use you generally mark all the desired messages for
retrieval and then retrieve marked message bodies.  By default, Agent skips to
the next unread message (performs the "N" action) when you mark a message
for retrieval.  You can turn this behavior off by unchecking the box Marking or
ignoring a message skips to the next unread message on the Options→General
Preferences→Navigation tab.

To retrieve the next unread message:

Use any of the following options.

Toolbar button:

Menu option: Navigate→View Next Unread Message

Keyboard Shortcut: Ctrl+N

To go to the next unread message in the current thread and retrieve it,
or mark it for retrieval:

Use any of the following options.

Toolbar button:

Menu option: Navigate→View Next Unread Message in Thread

Keyboard Shortcut: Ctrl+T

Single Key Navigation

You can use the spacebar to move from message to message, similar to the
way older Unix-style newsreaders behave.  By default, the spacebar
performs a "Skip to next unread message" command (the "N" command).
To change this behavior and have the spacebar view the next unread
message with a body (the Ctrl+B command), use Options→General
Preferences→Navigation and check the Single Key Read views next unread
message body option.

Expanding and Collapsing Threads

Agent displays follow-up messages indented under the original message.

See the
section
"Offline Mode"
on page 44,
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To save screen real-estate, these threads are initially shown collapsed, so
only the top-most message is visible.  When a thread is collapsed, the
Expand Thread icon  appears next to it.

To expand a thread, do any of the following:

• Click the Expand Thread icon.

• Select the message and press the "+" key.

• Press RightArrow.

To expand all threads in a group, do either of the following:

• Press Shift+"+" key.

• Press Shift+RightArrow.  (If this doesn't work, make sure the Num Lock
is disabled.)

When a thread is expanded, the Collapse Thread icon  appears next to it.

To collapse a thread, do any of the following:

• Click the Collapse Thread icon.

• Select the message and press the "-" key.

• Press LeftArrow.

To collapse all threads in a group, do either of the following:

• Hold down the Shift key while pressing the "-" key.

• Press Shift+LeftArrow.  (If this doesn't work, make sure the Num Lock is
disabled.)

Agent can also automatically expand threads for you.  By default, Agent
expands threads when you skip to them.

Note:  Agent will automatically expand the thread when you skip to it only if
you have already retrieved the body of the original message.

To prevent Agent from expanding threads when you skip to them, uncheck
the box Automatically expand threads containing new messages on the
Options→General Preferences→Navigation tab.

If you always want all threads expanded, uncheck the Show threads initially
collapsed, also on the Options→General Preferences→Navigation tab.  For
more details about expanding threads, consult Agent's Online Help.
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Group Properties
A powerful feature of Agent is the ability to assign very specific behaviors
either globally or on a per-group basis.  Whenever "group properties" are
described in this User Guide, it is important to note that you can assign any
of these behaviors either to all groups or only to selected groups.

Note: Throughout this manual, the convention for indicating group properties
is Group→Properties→<tab>.  Be aware that this can refer to properties for
selected groups (Group→Properties→<tab>) or for all groups
(Group→Default Properties→<tab>), whichever fits your need.

Setting Default Properties for All Groups

Select Group→Default Properties" to display the Default Properties for All
Groups dialog box.  You'll see a number of tabs containing different types of
group properties.

For example, a default behavior on the Mark Read tab (shown as follows) is
When retrieving new message headers... Mark all existing messages read.
This means that, by default, for every group in which you retrieve new
message headers, all existing messages are marked read.
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Setting Properties for Selected Groups

Following the same example, what if, for some groups, you don't want to
mark existing messages read when you get new headers?  It's quite simple.
Select the group(s) to which this will apply, then choose Group→Properties
and the Properties for Selected Groups dialog box appears.

The Properties for Selected Groups dialog box mirrors all the tabs and the
options on the Default Properties for All Groups dialog box.  For this
example, check the Override Default Settings box on the Mark Read tab and
select the option Do not mark any existing messages read.

When you select more than one group, then select Properties for Selected
Groups, the check boxes and options in the dialog can be in one of three
states:

• Initially, all options will be grayed and may appear checked or
unchecked.  This is because the settings may be different among the
various groups selected.

• Click the Override Default Settings box and it will become (or remain)
unchecked.  Clicking "OK" at this point will reset all selected groups to
the default settings for that tab.

• Click the Override Default Settings box again and all other boxes and
options become active.  Set the options the way you want them and click
"OK" for all selected groups to be given these attributes.
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All group properties work this way.  Default properties apply to all groups
until you override these properties for selected groups.  As you gain
experience with Agent, you'll probably find yourself taking great care fine
tuning your group properties.

Multi-Tasking
Agent allows you to do several things simultaneously.  For example, while
downloading message headers in one group, you can be reading messages
in another group.  As you complete an activity (e.g. marking messages for
retrieval) you may want to initiate an action (e.g. retrieve marked messages)
before moving on to another activity.  If Agent is already performing an
online task, the action you initiate will be queued up and Agent will get to it
when it finishes all other tasks in front of it.  Agent's status bar will tell you
how many tasks are queued, and also tells you which task it is currently
working on.

You can tell Agent to consider certain types of tasks to have higher priority
than others.  In particular, you can tell Agent to retrieve the body of a
message while Agent is already busy performing other online operations.
This makes it possible for you to begin reading new messages in one group
while retrieving headers in another.  See the Options→User and System
Profile→Online tab for details.

Working Online vs. Offline
One of the beauties of working with Agent is that you can work either in
online or offline mode, depending on your individual needs.

• Online mode - Use Agent online if connect time charges are not a
major concern.  In online mode, Agent remains connected to your news
server so you can retrieve messages any time without having to re-
connect.

• Offline mode - Use Agent offline if online costs concern you.  In offline
mode, Agent connects to your news server only when it needs to
perform an online task and then goes offline as soon as the task is
completed.

What follows are the routine tasks you might perform in a typical Agent
session, either in online mode or in offline mode.  These are examples and
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your sessions may vary, depending on the types of things you're trying to
accomplish during a given session.

Keep in mind that even if your preferred method of working is online, you
still have all information available to you while offline.  This is because,
either online or offline, Agent keeps all news and email messages locally on
your hard drive.  You never have to go online to review messages you've
already retrieved.

Online Mode

Here are the steps you might follow for a typical session in online mode:

1. Check for new email.     (This button can be added to your default toolbar as
described on page 177.)

 Menu option: Online→Check for new Email
 Keyboard shortcut: Ctrl+E

2. Read email messages and decide what to do.

 As you read each message, you can do any of the following:

• Post an email reply. 

 This button opens a Composition window.
Menu option: Post→Reply via Email
Keyboard shortcut: R

• File the message in a folder.   Copy to Folder or  Move to Folder
(These buttons can be added to your default toolbar as described on page 177.)

 Menu option:   Message→Copy to Folder or Message→Move to Folder
 Keyboard shortcut:  Alt+M+C+<file number> or Alt+M+V+<file number>

3. Get new Usenet message headers in selected

groups.   
When online it's easy to move from group to group, so you can use this
command for selected groups.  Of course, you can get headers for your
subscribed groups instead, if you like.

Menu option: Online→Get New Headers in Selected Groups
Keyboard shortcut: Alt+O+H

For more
details, see
"Retrieving
Email
Messages"
on page 63.

For more
details, see
"Overview"
on page 111.

For details,
see "Filing
Messages in
Folders" on
page 53.
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4. Retrieve and read Usenet messages.  As you read, there are several
things you might want to do:

• Post a follow-up Usenet message. 

This button opens a Composition window.

Menu command: Post→Follow-Up Usenet Message
Keyboard shortcut: F

• Watch thread.   

This option helps you spot messages of interest.  Agent automatically
retrieves the bodies of responses in watched threads each time you get
new headers in that group.

Menu command: Message→Watch Thread

Keyboard shortcut: W

• Ignore thread.   

This option helps you avoid messages of no interest to you.  Any
responses in ignored threads are marked read, so you don't read them.

Menu command: Message→Ignore Thread

Keyboard shortcut: I

• Keep a message. 

This command flags messages you want to keep indefinitely. This
prevents it from being removed during automatic "purging".

Menu command: Message→Keep

Keyboard shortcut: K

• File message in a folder.   Copy to Folder or  Move to Folder (These
buttons can be added to your default toolbar as described on page 177.)

 Menu command: Message→Copy to Folder or Message→Move to Folder

 Keyboard shortcut: Alt+M+C+<file number> or Alt+M+V+<file number>

See
"Retrieving
Messages in
Groups." on
page 58.

For more
details, see
page 106.

For details
about filing
messages in
folders, see
page 53.
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Offline Mode

A typical session using Agent while in offline mode might be as follows.
Remember that the goal of offline work is to minimize connection time.
What you'll want to do is get information in stages, spending time doing
detailed reading while not connected.  Note:  You can use Agent to
automatically go online and then offline when performing these options (see
the next section).

1. Check for new email.     (This button can be added to your default toolbar as
described on page 177.)

 Menu option: Online→Check for New Email

 Keyboard shortcut: Ctrl+E

2. Get new Usenet message headers from subscribed groups.   

Menu option: Online→Get New Headers in Subscribed Groups

Keyboard shortcut: Alt+O+N

3. Go offline.

4. Read through the headers and mark them for later retrieval.   
This option queues messages you want to retrieve, so that you only
need to go online once to retrieve them.

Menu option: Message→Mark for Retrieval

Keyboard shortcut: M

5. Go online and retrieve marked Usenet messages.   

 This option has Agent go online just long enough to retrieve the bodies
for the marked messages from step 4.

Menu option: Message→Get Marked message Bodies

Keyboard shortcut: Alt+O+M

6. Go offline and read all messages at your leisure.  

7. You may want to any of the following:

• Compose email and Usenet replies.  
 These options open a Composition window.
 Menu options: Post→Reply via Email, Post→Follow-Up Usenet Message

 Keyboard shortcuts:   R, F
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Note!  To be most efficient, press the Send Later button  after
composing each message, then send them all at once at a later
time.  (See step 8.)

• Watch thread.   

This option helps you spot messages of interest.  Agent
automatically retrieves the bodies of responses in watched threads
each time you get new headers in that group.

Menu option: Message→Watch Thread

Keyboard shortcut: W

• Ignore thread.   

 This command helps you avoid messages of no interest to you.  Any
responses in ignored threads are marked read.

Menu option: Message→Ignore Thread

Keyboard shortcut: I

• Keep a message. 

This command flags messages you want to keep indefinitely. This
prevents it from being removed during automatic "purging".

Menu option: Message→Keep

Keyboard shortcut: K

• File message in a folder.   Copy to Folder or  Move to Folder
(These buttons can be added to your default toolbar as described on page 177.)

 Menu option: Message→Copy to Folder or Message→Move to Folder

Keyboard shortcut: Alt+M+C+<file number> or Alt+M+V+<file number>

• Compose new Usenet  and email messages.  
 These options open a Composition window.
 Menu options: Post→New Usenet Message or Post→New Email Message

 Keyboard shortcuts: P, Ctrl+M

For more
details, see
page 106.
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8. Go online and Post queued messages.    (This button can be added to
your default toolbar as described on page 177.)

Menu option: Online→Post Usenet and Email Messages

Keyboard shortcut: Alt+O+P

9. Go offline.

Configuring for Online/Offline Behavior

The settings that affect Agent's online and offline behavior are defined on
the Options→User and System Profile→Online tab.

If you want to operate primarily in offline mode, press the button Use Offline
Defaults.  This configures the rest of the dialog box settings for typical offline
use.  If you want to operate primarily in online mode, press the button Use
Online Defaults.  This configures the rest of the dialog box settings for
typical online use.

We've taken great care to set the defaults correctly so that you don't ever
have to worry about any of this, but you may change the settings to suit your
particular needs.
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Below are descriptions of the four key options in this dialog box that affect
how Agent performs offline and online.

Note:  Refer to Agent’s online Help for the options not listed in the table.

Choose this option... ...to have Agent do this.

Go offline automatically
after...

Select this option if you want Agent to automatically
disconnect from your news server after the specified
number of seconds of inactivity.  If you deselect this option,
Agent will not disconnect from your news server until you
close the program or manually disconnect by unchecking
the Online command on the Online menu.

If you intend to read messages online, you might want Agent
to go offline after a few minutes of inactivity.  This gives you
time to read messages, but doesn't leave Agent online too
long.

If you intend to read messages offline, you probably want
Agent to go offline immediately (0 seconds of inactivity).

Load Winsock on Program
Startup

Select this option to have Agent load winsock.dll on program
startup and leave it loaded until you close Agent.  Note:
Always check this box if you are using Dial-Up Networking
(DUN) or Remote Access Server (RAS).  (See the
additional technical information below.)

Viewing Unretrieved
Messages When Offline

Select the action you want Agent to perform when you are
offline and attempt to view a message for which you do not
have the body.  If you want to operate in online mode, you
should select Go online and Retrieve the message's body.
If you want to operate in offline mode, you should select
Mark the message for later retrieval.

Additional technical information about “Load Winsock on Startup.”

The winsock DLL is a system file that provides access to the Internet for
Agent and other Internet client programs.  Each client that uses the DLL
must first "load" the DLL into memory, and also must "unload” the DLL when
finished with it.  If more than one program loads the DLL simultaneously, it
remains loaded in memory until the last program unloads it.

If you have a dial-up connection to the Internet, the winsock DLL also
controls when your system dials and hangs up the phone.  Most winsock
DLLs wait to begin dialing the phone until the first program tries to access
another host (for example, when Agent tries to access your news server).
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Thus, even if a program loads the DLL immediately upon startup, the DLL
won't dial the phone until the program actually tries to perform some online
operation.

When the DLL hangs up the phone depends on the kind of DLL.  Most 16-bit
DLLs don't hang up the phone until the last program unloads the DLL from
memory.  Thus, even if all programs have finished performing online
operations, these DLLs will keep the connection active until all programs
have actually unloaded the DLL.  On the other hand, the Microsoft 32-bit
DLL (used in Windows 95 and NT for Dial-Up Networking) hangs up the
phone as soon as the last program finishes all online operations, even
though the DLL is still loaded in memory.

Most Internet client programs load the winsock DLL immediately upon
program startup and keep it loaded until you close the program.  This works
well for 32-bit programs using the Microsoft DLL.  But, from the previous
explanation, you can see that it doesn't work very well for 16-bit programs,
since the only way to for the these DLLs to hang up the phone is to close all
clients, thereby unloading the DLL from memory.

Agent, on the other hand, can dynamically load and unload the DLL as it
goes online and offline, which makes it possible for Agent to cause the DLL
to dial the phone automatically whenever Agent goes online, and more
importantly, hang up the phone whenever Agent goes offline.

The "load winsock on startup" option controls when Agent should load and
unload the DLL.  When the option is checked, Agent loads the DLL
immediately upon startup and keeps it loaded until you close Agent.

When the option is unchecked, Agent loads the DLL only when going online
and unloads it as soon as Agent goes offline.  For most 16-bit DLLs, which
won't hang up the phone until unloaded, you should leave this option
unchecked, so that Agent will load and unload the DLL dynamically as it
goes online and offline.  You may also need to uncheck this option for
certain 32-bit DLLs that operate the same way as 16-bit DLLs.

For the Microsoft Windows 95 and Windows NT 32-bit DLL, you should
check this option, since it is not necessary to dynamically load/unload the
DLL to force it to dial or hang up the phone.

Setting Up Your Connection

As described in the note above, for 32-bit systems, Agent takes full
advantage of Windows Dial-Up Networking features, greatly enhancing the
ease with which you can go online and offline.  Dial-Up Networking tells
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Agent to automatically dial your service provider and establish a network
connection.
_____________________________________________________________

OO In Windows 95, the automatic dialer is referred to as Dial-Up
Networking (DUN).  In Windows NT, the automatic dialer is referred to
as Remote Access Services (RAS).

_____________________________________________________________

With built-in support for DUN, Agent can automatically establish a dial-up
connection when going online and automatically hang up the connection
when going offline.  This support allows Agent to integrate smoothly with the
Windows 95 and Windows NT dialers, greatly enhancing the ease with which
you can go online and offline.

To define DUN settings:

Select Options→User and System Profile→Dial-Up and the following dialog
box will display.

Complete the settings on the Dial-Up tab as follows:
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1. Open dial-up connection before going online - If you check this
option, Agent will establish the specified dial-up connection each time it
goes online.

2. Prompt before connecting - If you check this option, Agent will display
the following dialog box before establishing the connection. If you don't
check this option, Agent will proceed.

Note:  One reason you might want to select this option is for extra
security.  You can then manually enter the password each time you
connect, rather than having Agent supply it automatically.

You can use this dialog box to change a connection, user name,
password, and/or phone number.  If you check the Save Password box,
Agent saves the password and automatically enters it for you each time
you attempt a new connection.  To start dialing, press Yes.  To cancel
the connection but still go online, press No, and to cancel the connection
but not go online, press Cancel.

3. If another connection is already open, use it instead - Check this
option to have Agent use an open connection to your server, if you
already have one.  This is useful for users who may use more than one
ISP.  With this box checked, Agent will use the connection that is
already open rather than attempting to establish the default connection,
which might be different.

4. Connection - From the list, highlight the name of the connection to be
used.  The list contains all the DUN connections currently defined.
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5. Properties - Press this button to edit the properties of the selected
connection.  This displays the standard DUN connection properties
dialog box.  (Not available in Windows NT).

6. New connection... -  Press this button to open the standard DUN wizard
dialog box, where you can create a new connection entry.  (Not available
in Windows NT.)

7. User Name/Password - Enter the user name and password to be used
for the connection.  If you want Agent to prompt for the password each
time you connect, leave the Password field blank and check the Prompt
before connecting box above.

Windows 95 - A separate user name and password are stored for each
connection in the DUN database.  Changing the entries here changes
the DUN entries.

Windows NT - There is no facility for accessing the DUN user name and
password.  For this reason, Agent stores a single user name and
password for use by all connections.

8. Close dial-up connection after going offline - If this option is
checked, Agent will disconnect the dial-up connection after going offline,
but only if Agent opened the connection.  If Agent did not open the
connection, then Agent will not close it.

9. Title of Connection Status Window - This option is only visible if you
are running Windows 95 or Windows NT 3.5.  Use this option if you are
running a non-English version of Windows 95 or NT 3.5.  When the
Windows 95 DUN dialer (or NT 3.5 RAS dialer) completes a connection,
it displays a window in the middle of the screen showing the connection
status.  When Agent is configured to open a DUN connection
automatically, after the connection has been established, Agent
searches for the DUN window and minimizes it.  By default, Agent
searches for a window title beginning with "Connected to."  If you are
running a non-English version of Windows 95 or NT 3.5, you can enter
the window's correct title here.

10. Start Dial-Up monitor on first connection attempt - This option is
only visible if you are running Windows NT 4.0.  In Windows NT 4.0,
Agent launches the Dial-Up Networking Monitor on the first connection
attempt.  You will see the monitor icon on the task menu system tray.
Agent doesn't attempt to close the monitor when it hangs up, nor does it
re-launch the monitor on subsequent connection attempts, should you
close the monitor manually.  Uncheck this box if you don't want Agent to
launch the monitor.
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CHAPTER 4

All About Messages
Once you start using Agent on a regular basis, you'll quickly find that the messages for your
subscribed groups will begin to pile up.  At some point, you're bound to think, "How do I keep
track of it all?".  There are a number of options in Agent that help you to manage and view
your messages more efficiently.  So, to that end, this chapter was created to focus
specifically on issues concerning messages.

We've broken this chapter into these major areas:

1 Organizing Messages

1 Retrieving News Messages

1 Retrieving Email Messages

1 Message Filters

1 Viewing Messages

1 Finding Messages

1 Keeping Messages

1 Printing Messages

Organizing Messages
What would our offices be like if there were no file folders?  Chaos is a word
that comes to mind.  Like a good filing system in an office, Agent offers
electronic folders so you can better organize your messages.

Filing Messages in Folders

Using folders to organize your messages is one of the simplest and most
intuitive tasks in Agent.

To Create a folder:

1. Select Group→New Folder.

2. Enter a name for the folder and press OK.
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The new folder will appear in the Groups/Folders pane below the list of
newsgroups.

To view folders:

From the Group→Show Groups and Folders flyout menu, choose the
desired view for the Groups/Folders pane.  Three of the four available
choices display your folders:

• All Groups and Folders

• Subscribed Groups and Folders

• Folders

A check mark indicates the view that is currently in effect.

Filing options you can use:

• The "drag and drop" method.

• Using the Copy to Folder or Move to Folder menus.

• Setting up Agent to automatically file inbound email.

Note:  You cannot file messages without bodies into folders.

To drag and drop a message into a folder:

1. View all three panes in your Browser window (i.e., make sure the
Navigate→Zoom Window option is unchecked).

2. Highlight the message in the Message List pane.  You can select more
than one message, dragging them all at once.

3. Click anywhere on the highlighted message and, while holding down the
mouse button, drag the message to the desired folder.

Note:  By default, Agent will move a message when you drag and drop
it.  To copy the message instead, press and hold the Ctrl key.  You'll see
a "+" sign in the folder while you're dragging the message which
indicates that you're copying, not moving it.

4. Once the cursor is directly on top of the desired folder, release the
mouse button and the message will be dropped into that folder.

To copy or move a message into a folder:

Highlight the message (or messages) to be filed choose one of these
equivalent methods to open either the Copy to Folder or the Move to Folder
flyout menu:

See "Filing
Inbound Email
Automatically "
on page 67.
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Menu options: Select Message→Copy to Folder or Message→Move
to Folder -> <folder name>.

Context menu: Rightclick the message header or body to open its
context menu and select Copy to Folder or Move to
Folder -> <folder name>.

Keyboard shortcuts: Alt+M+C opens the Copy to Folder flyout menu.
Alt+M+V opens the Move to Folder flyout menu.

If you don't see the desired destination folder on the flyout menu, you can
select All Folders at the bottom of the flyout.  This displays a dialog box that
lists all your folders.

To add one of these folders to the flyout menu, just press the Manage Menu
button.  This displays the Manage Folder Menus dialog box, where you can
add the folder from the Folders list to the Menu list.  (For assistance, check
the online help.)  When you press OK, that folder will be added to both the
Copy to Folder and Move to Folder flyout menus.  You can add as many as 9
folders to the flyout menu.  If you find yourself moving messages to the same
folder frequently you can add a toolbar button to move or copy the highlighted
message to that folder with a single keystroke (see p 177. ).

For details
on creating
toolbar
buttons,
see p. 177.



Chapter 4

56

_____________________________________________________________

OO An alternative way to add your most frequently used folders to the
Copy to Folder and Move to Folder flyout menus is to select the
Options→Menus and Toolbars→Folder Menus tab.  You will notice
that the Folder Menus tab and the Manage Folder Menus dialog
box are the same.

_____________________________________________________________

Saving Messages to File

In addition to storing messages in folders with Agent, you can save
messages to disk and keep them as part of your Windows file system.

To save one or more messages to a text file:

Highlight all the messages in the Message List pane that you want to save,
then select File→Save Messages As (or press Alt+F+A).  This displays the
Save Messages As dialog box, shown as follows.
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_____________________________________________________________

OO Agent only saves messages whose bodies have been retrieved.  If you
select a collapsed thread, Agent saves all messages in the thread.

_____________________________________________________________

This dialog box has the same fields as any standard Save As dialog box,
with the exception of the following options that are unique to Agent:

1. Append to existing file - Check this box to append the messages to an
existing file.  If you uncheck this option and save the messages to an
existing file, Agent will erase the current contents of the file.

2. Save raw (unformatted) message - Check this box if you only want the
"raw", or unformatted, message data to be saved to a file.  This means
that you will save the message header details (e.g., Path, From, Subject,
Date, etc.) and the message text.  In addition, any attachment in the
message is saved as a series of lines of coded characters.

3. File Format - Select the format for the messages being saved.  The
options are described below:

Choose this
option...

...to have Agent do this.

Unix message file Save the messages in the standard Unix message format.
This allows you to import messages back into Agent.

Precede each
message with...

Adds the specified text to the beginning of each message
saved.

No separator
between messages

Does not include any additional text between the saved
messages.

4. Header Fields to Include - Select the header fields you want included
in the header of the printed items.  The options are described here:
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Choose this option... ...to have Agent do this.

All fields Saves all the header information with the message bodies.

Selected fields Saves selected header elements (e.g., To, From,
Newsgroups, Subject, Date, etc.) along with the message
bodies.  You can enter whatever fields you like.

No fields (Body only) Saves only the message bodies without any header
information.

_____________________________________________________________

OO If you want to re-import messages into Agent, make sure you use
these three options for exporting: Save raw message; Unix message
file; All fields.

_____________________________________________________________

Retrieving News Messages
In Chapter 2, you learned about retrieving an initial sampling of news
messages to see which groups interest you.  This section will give you more
details about retrieving news messages and explain some of the commands
Agent provides to help you manage your list of messages.

Retrieving Message Headers in Newsgroups

The Online menu and your toolbar offer the following options for retrieving
new message headers.

• Get New Headers in Subscribed Groups

• Get New Headers in Selected Groups

• Get All Headers in Selected Groups

• Sample Headers From Selected Groups

Choose the one that accomplishes what you want to do, described as
follows:

Get New Headers in Subscribed Groups retrieves new headers that have
been added since you last retrieved headers in your subscribed groups.

To add
buttons that
aren't
currently on
the toolbar,
see page
177.
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Get New Headers in Selected Groups retrieves the new headers that have
been added since you last retrieved headers in each of the selected groups.

Get All Headers in Selected Groups retrieves all headers from the
selected groups, including headers that may have been purged in previous
sessions.

Sample Headers From Selected Groups - Agent retrieves a limited
number of the most recent headers in the selected groups.  You can either
retrieve a specified number of headers, or for a specified number of days.

Note:  Because you retrieve the most recent headers when using the
"sample headers" feature, immediately after you retrieve a sampling, no new
headers will be retrieved by either Online→Get New Headers in Subscribed
Groups or Online→Get New Headers in Selected Groups.

If you want to retrieve messages prior to those that you just sampled, either
increase the sample size and sample headers again or use the option
Online→Get All Headers in Selected Groups.

Retrieving Message Bodies

Agent provides several ways to retrieve the bodies of messages that are of
interest to you.  Two of these methods are available from the Online menu
or from the toolbar.

• Get Selected Message Bodies     

• Get Marked Message Bodies       

Here’s how they work:

Get Selected Message Bodies retrieves the bodies for one or more
messages you have selected in the Message List pane.

Get Marked Message Bodies retrieves the bodies of messages the you
have marked for later retrieval. This is particularly useful when using Agent
in offline mode.  See Chapter 3 for an example of an offline session.

In addition, you can retrieve bodies for all new messages when retrieving
headers.  Use the Group→Properties→Retrieve tab and check the box,
Retrieve bodies for all new messages.
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Catching Up in Groups

If you've been away from Agent for an extended period and want to start
reading only current messages without worrying about having to read
messages posted while you were gone, Agent’s “catch up” feature is for you.
Agent will make it appear that you’ve retrieved all the messages in the
selected groups up to the “catch up” time, even though you haven’t really
retrieved or read any of these messages.

To catch up with a group's messages:

Select Online→Catch Up With Selected Groups.  This option queries the
server to find the highest message number, but it doesn't retrieve any
headers.  That way, the next time you get new headers, you’ll only get
messages posted since you did the catch up.
_____________________________________________________________

OO You may also catch up by sampling a limited number of the latest
messages.  (Select Online→Sample Headers.)

_____________________________________________________________

Watching Threads

Certain threads of discussion may be quite interesting and you may want to
make sure that Agent always gets the bodies of the latest messages for this
thread.  You can do this by using the Watch Threads option.

To watch threads:

Place your cursor on the thread you wish to follow and use one of the
following (equivalent) methods:

Toolbar button:

Menu option: Message→Watch Thread

Keyboard shortcut: W

The Watch Thread icon  will then precede that message and any
responses to that message.  When you retrieve new headers, Agent will
automatically get the bodies of all responses to watched threads.

Ignoring Threads

The Ignore Thread option has the opposite effect of Watch Thread.  For  any
thread you definitely do not want to follow, you can use "Ignore Thread" to
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tell Agent never to retrieve new messages for the selected threads.  This can
reduce the number of new, unread messages presented to you each time
you get new message headers.

To ignore threads:

Place the cursor on the thread you wish to ignore and use any one of the
following equivalent methods:

Toolbar button:

Menu option: Message→Ignore Thread

Keyboard shortcut: I

The Ignore Thread icon  will then precede that message and any
responses to that message.  When you retrieve new headers, Agent will
automatically mark these messages as read, even those retrieved in later
sessions.

Important!  Be sure to keep at least one header in a watched or ignored
thread in order for this feature to work.  Alternatively, make sure you have
set the purge properties on the Group→Properties→What to Purge and
When to Purge tabs so this message header remains as long as the thread
will be active.

Managing Crosspostings

Many Usenet enthusiasts post the same message to several newsgroups.
This practice, known as "crossposting", is advantageous for the sender,
because a crossposting reaches a wider audience than a posting to a single
group.  On the receiving end, however, crosspostings can be annoying.
When retrieving new headers, you may find yourself re-reading the same
crossposted message in several of your subscribed groups.  Fortunately,
with Agent you can manage the crosspostings you retrieve and can prevent
this problem from occurring.
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To manage crossposted messages:

Open the Group→Properties→Crossposts tab.

On this tab, you can enable crosspost checking and select from a number of
options to fine tune Agent's behavior.  These options are described as
follows:

• Enable crosspost checking - Check this box to enable crosspost
checking in Agent.  This applies to all groups.

• If a message header has already been retrieved in one group...

Retrieve the header normally - This disables crosspost checking
globally, but Agent will continue to maintain a list of headers used for
checking.

Mark the header read - Agent marks the crossposted message headers
read in all groups, except the first group in which the message is
retrieved.

Skip the header (do not retrieve it) - Agent skips crossposted messages
in all groups, except the first group for which the crossposted message
has been retrieved.



All About Messages

63

Example:

If...

you retrieve headers for groups a,b,c,d,e, and a message was posted to
groups b,d,e...

then...

Agent would retrieve the header only for group b, because that is the
first group for which the header has been retrieved.

• Look for crossposted messages only when retrieving NEW headers
When you check this box, Agent does crosspost checking only when
retrieving new headers.  If you leave this box unchecked, Agent does
crosspost checking whenever you retrieve headers, such as sampling or
retrieving all headers.

• Detect crossposted messages by - This option controls the criteria
Agent uses when checking for crossposted messages in all groups.  The
two choices are Subject, author, date, and lines and Message ID.  In
general, the former gives better crosspost detection.

• Clear cache used to detect crossposted messages - Press this button
to remove the list of most recent message headers.  Agent maintains
this list as the basis for crosspost detection.  (This data is in the file
xpost.dat in your Agent data directory.)

Retrieving Email Messages
In an earlier chapter, you learned the basics about checking for email during
a typical Agent session.  This section will provide more details on how you
can optimize Agent for use as your email program.

Checking for Mail

Use the Options→Inbound Email→Checking Mail tab to set your preferences
for checking email.
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Receiving Email with POP Options:  These options apply only to POP
mail servers.  They tell Agent when to check for email and what it should do
with the messages it finds.  The following table describes what each option
does:

Choose this option... ...to have Agent do this.

Automatically check for
email every...

Automatically check for new email
periodically.  Enter the number of minutes
between checks.

Note:  Agent must be running in order to
check for mail.

Check only when online Check for new mail only if you are already
online with your service provider.
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Choose this option... ...to have Agent do this.

Unload winsock (hang
up) between checks

or

Leave winsock loaded
between checks

Many winsock drivers automatically hang
up a modem when no programs are using
any driver anymore.  If your winsock has
this feature, you can use these options to
control whether Agent unloads the
winsock driver between checks for email,
thereby causing the driver to hang up the
modem.

Leave messages on
server

Note: This option is useful
when you retrieve messages
from the same email account
with more than one computer.

See p. 88 for a way to optimize
Agent use at two sites.

Keep messages on your mail server after
retrieving them.  Normally, Agent deletes
messages from the server as they are
retrieved.

Note: Once a message has been retrieved
and left on the server, Agent will not retrieve
the message again.  If you subsequently
uncheck this box, Agent will delete all the old
messages from the server the next time you
check for new email.

Until retrieved at both of
my sites

This option is grayed unless you select
"Leave messages on server" above.
Check this box if you are retrieving
messages at two sites and want Agent to
leave your messages on your server until
they have been retrieved at both sites.

If a message has
already been retrieved,
mark it read

This option is to help people who receive email
at two sites.  When you check this box, if Agent
retrieves an email message that the server
indicates has already been retrieved
(presumably at your other site), Agent will mark
the message read.

Skip messages longer
than

Maximum lines to
sample

Leave email messages unretrieved if they
are longer than the maximum number of
lines specified.

When Agent encounters a message larger
than the specified value, Agent will retrieve
the number of lines of the message as
specified.

When this box is checked, Agent will leave
the message on the server and won't
retrieve it again.  Uncheck this box to
force Agent to retrieve the message the
next time you check for new mail.
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When New Email Arrives

Use the Options→Inbound Email→Alerts tab to tell Agent how to notify you
when new email arrives.

Choose this option... ...to have Agent do this.

Display message box Pop up a message when new mail is
received.

Play sound Play a sound when mail is received.  If
your PC is set up to play .wav files, you
may specify the location of a WAV file to
play.  If you check Play sound  but leave
WAV file blank, Agent will play the Email
Receive sound defined in the Sound
module of your Windows Control Panel.

Only if new messages
were marked unread

Check this box if you want Agent to beep
or play the specified WAV file only if new
retrieved messages are marked unread.
Checking this box is useful if you've
created message filters that automatically
mark certain messages read when they
are retrieved.  In such cases, you may not
want Agent to beep or play a WAV file to
notify you that there is new mail.

When you receive email, the status bar will display the number of messages
unread, marked read, and deleted.  Agent will display the results of the most
recent email retrieval, as well as the accumulated counts since you last read
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an unread email.  Why would you want to know the accumulated counts?  If
you have Agent set to automatically retrieve email every <n> minutes, you
many not check your email for several retrieval cycles.  Accumulated counts
keep track of all email received since the last time you read your mail.  The
accumulated counts will be reset the first time you read an unread email
message.

Whenever you receive unread email, the Agent program icon changes,
indicating that you have received mail.  However, Agent will not show this
New-Email icon if no new email is unread, that is, if all email retrieved was
marked read or deleted.

Filing Inbound Email Automatically

When you first configure Agent to retrieve email, you define a folder into
which email will automatically be filed.  As you start to receive more email
with Agent, you certainly will want to create more folders and have Agent put
messages in the most appropriate folder for each message.  The next
section will show you how to do this using Agent’s easy-to-use yet powerful
message filtering feature.

By default, any mail that is not routed automatically by a filter will be filed in
the folder you created when first configuring for email.  If you want to change
this default folder, use the Options→Inbound Email→Folder tab and either
select an existing folder from the drop-down list, or create a new folder by
pressing the New Folder button.

Message Filters
Agent provides a powerful and flexible set of features to allow you to get just
the messages you want, ridding yourself of the nuisance of unwanted
messages while getting all the details of messages which are of interest to
you.  Using filters for news messages can be extremely important if you
regularly retrieve headers from extremely active groups, some of which can
generate literally hundreds of headers each day.  Without such a broad
filtering mechanism, your Message List could rapidly become
unmanageable.  Similarly, using filters for email messages allows you to
avoid unsolicited commercial email (“spam”) while retrieving and filing
automatically the messages you want.

Creating a Message Filter

Usenet and email message filters consist of the following components:
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• A filter expression, specifying the criteria Agent should use when
matching filters with messages.  For the casual users, Agent will supply
filters expressions automatically when creating filters based on existing
messages.  For power users, Agent’s expression language is versatile
and powerful, allowing full control when defining criteria for matching.

• One of the available kill actions or watch actions.

• A priority between 0 (lowest) and 1000 (highest).  Filters are evaluated in
priority order.  If more than one filter matches a message, the action of
the filter with highest priority is carried out.

• An optional expiration date, expressed in the number of days the filter
should be kept.  Agent automatically deletes expired filters, helping you
keep the number of filters from getting out of hand.

• An enabled/disabled flag.  This allows you to temporarily disable a filter
without deleting it altogether.  You can also use the Filters tab on the
Group Properties dialog to temporarily disable all filters for selected
groups.

You can create filters based on existing messages, or from scratch.

To create a filter based on a message:

1. Highlight the message that will be the basis for your filter.  This can be
either a Usenet message or an email message.

2. Open the Message→Filters flyout menu.

3. Select “Add Kill Filter ...” or “Add Watch Filter ...”, depending on the type
of filter you want to create.

4. Complete the settings in the Add Filter dialog box (see the next section).
Note that Agent knows whether you’re creating a filter for a Usenet
message or an email message and opens the appropriate dialog box.

To create a filter from scratch:

1. If the filter will apply to a specific group, make sure the group is
highlighted.

2. Select Window→Open Email Filters or Window→Open Usenet Filters.

3. Open the Add Filter dialog box using one of the following equivalent
methods:

Toolbar button:  for kill filters or  for watch filters.
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Menu option: Filter→Add Kill Filter or Filter→Add Watch Filter

Keyboard shortcut: Ctrl+K for kill filters or Ctrl+W for watch filters.

4. Complete the settings in the Add Filter dialog box (see the next section).

The Add Filter Dialog Box

Depending on the type of filter you want to create (Usenet or email), the
appropriate dialog will be opened.  You’ll notice that these dialogs are quite
similar, yet have some important differences.  Here are the details of each
dialog.

The Add Usenet Filter Dialog

If you're creating a kill filter, the default setting in the Kill Action section will
appear.  In the example above, you see the default setting in the Watch
Action section.  In fact, when defining filters the only difference between a
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watch and a kill filter is the initial appearance of the dialog box options.  You
can start creating a watch filter and change it to a kill filter, or vice-versa.

Note: to define the default settings for Usenet watch and kill filters, use the
Group→Properties→Filters tab.

Here are the options for using this dialog box:

1. Filter Expression - Enter the expression that tells Agent what to look for
in determining if a message will match the filter.  If you’re creating a
filter from an existing news message, Agent automatically inserts the
selected message's subject (for a watch filter) or author (for a kill filter)
into this field.  If you want to change the filter expression, you can either
manually enter the subject or author on which you want to filter, or you
can use the following buttons to have Agent automatically insert the
subject or author of the currently selected message.

a. Paste Subject - Press this button to add a subject filter.

b. Paste Author - Press this button to add an author filter.  Below this
button is a drop-down list, where you can choose exactly how the
author information will be entered.  Your choices are:

• Name only (e.g., author: John Smith), or

• Address only, (e.g., author: jsmith@anyco.com), or

• Entire field (e.g., author: jsmith@anyco.com John Smith)

Note: the Paste Subject  and  Paste Author  buttons are active only
if you create a filter directly from a selected message.  If you create
a filter from scratch, these buttons will not appear.  See the section,
“Filter Expressions”, in this chapter, for details on creating correct
filter expressions.

c. Lower Case - Press this button to convert all text in the Search For
field to lower case.  This ensures that Agent will filter on all
instances of the subject or author, no matter whether the retrieved
headers use upper case, lower case, or a mixture of the two.

2. Kill action - Select the default Kill action for your filters.  The options
are:

a. Delete - Agent will not retrieve the header at all.

b. Mark read - Agent will retrieve the header, but mark it read.

c. Ignore thread - Agent will retrieve the header, but mark its thread
Ignore  and mark the message read.
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3. Watch action - Select the default Watch action for your filters.  The
options are:

a. Retrieve body immediately - Agent will retrieve the message body
immediately .

b. Mark for later retrieval - Agent will mark the message for later
retrieval .

c. Watch thread - Agent will watch the entire thread  and mark the
message for later retrieval.

4. Keep - Check this box if you want Agent to permanently keep  any
message retrieved when the filter action is anything other than delete.

5. Scope - Select Global if you want the filter to apply to all groups, or
select Group: <newsgroup> if you want the filter to apply only to the
current group.

6. Priority - Enter the priority for the filter, between 0 (lowest) and 1000
(highest).  If a message matches the expression for more than one filter,
the filter with the highest priority will be applied.

7. Disable filter - Check this box to temporarily disable the filter.

8. Expire this filter after - Check this box if you want the filter to be
automatically deleted after either a fixed number of days after the filter
was created (enter the number of days) or a fixed number of days after
the filter last was used (enter the number of days and check the Of
Inactivity box.)

9. Apply filters to group immediately - Check this box to apply all filters
to the selected group as soon as you close the dialog box.  Check “This
message only” to restrict application of the filter to the selected
message.  (This checkbox only appears if you are creating the filter from
an existing message.)
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The Add Email Filter Dialog

As mentioned above, this dialog is very similar to the “Add Usenet Filter”
dialog.  However, you can use this dialog to instruct Agent to automatically
file email messages in folders and to remove email messages from your
POP server.

Note: to define the default settings for email watch and kill filters, use the
Options→Inbound Email→Watch and Options→Inbound Email→Kill tabs.

Here are the options for using this dialog box:

1. Filter Expression - Enter the expression that tells Agent what to look for
in determining if a message will match the filter.  If you’re creating a
filter from an existing email message, Agent inserts the Any-Sender field
followed by the author of the selected message.  Note: Any field name
you enter is legal, as well as the special names "any-sender" and "any-
recipient". If you want to change the filter expression, you can either
manually enter the change (see the section, “Agent’s Expression
Language”, on p. 75 for details on how to do this), or you can use the
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following buttons to have Agent automatically insert the proper field, in
the proper format, from the currently selected message.

a. Paste Field - Press this button to open the Paste Field dialog box.
From this dialog box, select the field that you want pasted into the
“Filter Expression” box.

Note: the Paste Field  button is active only if you create a filter
directly from a selected message.  If you create a filter from scratch,
this button will not appear. See the section, “Filter Expressions”, in
this chapter, for details on creating correct filter expressions.

b. Lower Case - Press this button to convert all text in the Search For
field to lower case.  This ensures that Agent will filter on all
instances of the filter expression, whether the retrieved headers use
upper case, lower case, or a mixture of the two.

2. Kill action - Select the default Kill action for your filters.  The options
are:

a. Delete - Agent will delete the message, not filing it in a folder.

b. Mark read - Agent will file the message in the specified folder,
marking it read.

c. Ignore thread - Agent file the message in the specified folder, mark
its thread Ignore  and mark the message read.

3. Watch action - Select the default Watch action for your filters.  The
options are:

a. Retrieve - Agent will retrieve the message, file it in the specified
folder, and mark it unread.

b. Watch thread - Agent will file the message in the specified folder,
watch the entire thread  and mark the message unread.

4. Keep - Check this box if you want Agent to permanently keep  any
message retrieved when the filter action is anything other than delete.

5. File in Folder - Select the folder into which you want a message that
matches this filter to be filed.  If you don’t want to use any of your
existing folders, click the “New Folder” button to create a new folder.

6. Do not leave on server - If you have checked the global option "Leave
on server" on the Checking Mail tab of the Inbound Email dialog
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(Options menu), you can override the global option for the filter you're
creating by checking this box.  This is helpful for particular messages
that you always want to remove from the server.  You will find this option
to be useful, too, when you are receiving email at two sites (e.g. at work
and at home).

7. Priority - Enter the priority for the filter, between 0 (lowest) and 1000
(highest).  If a message matches the expression for more than one filter,
the filter with the highest priority will be applied.

8. Disable filter - Check this box to temporarily disable the filter.

9. Expire this filter after - Check this box if you want the filter to be
automatically deleted after either a fixed number of days after the filter
was created (enter the number of days) or a fixed number of days after
the filter last was used (enter the number of days and check the Of
Inactivity box.)

10. Apply filters to folder immediately - Check this box to apply all filters
to the selected folder as soon as you close the dialog box.  Check “This
message only” if restrict the filter activity to the selected message.  (This
checkbox only appears if you are creating the filter from an existing
message.)

Managing Your List of Filters

As you begin to create filters for news and email messages, you will more
than likely want to review the filters you’ve created, perhaps edit them, even
delete them if you have not set your filters up for automatic deletion.  You
can do all these things from the Usenet Filters and Email Filters windows.

To view your existing filters:

1. Select Window→Open Usenet Filters or Window→Open Email Filters.

2. Select the way you want to view your filters.  To do this, open the Select
View dialog.  You can open this dialog by choosing Filter→Select View
or by clicking header bar for the window.  Note that the current view
selection criteria are displayed in the header bar.

To Add, Change or Delete Filters

From the Usenet Filter or Email Filter window you can do the following.
Each option is available from the Filter menu or from a toolbar button.
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Add a New Filter - this is how you create a filter from scratch, as described
earlier on p. 68.

Add a Copy of a Filter - the Add Filter dialog will appear and you can make
any changes you want to an existing filter and save the changes as a new
filter.

Edit a Filter - the Edit Filter dialog will appear and you can make any
changes you want to the filter, then save the filter with these changes.

Delete a Filter - the filter will be removed.  Selecting Filter→Confirm Deletes
will instruct Agent to get your approval whenever you try to delete a filter.

Agent’s Expression Language

When creating Usenet and email filters, or when performing global searches,
you can use Agent's expression language to tailor the criteria Agent uses
when searching for a match.  Many times, all you’ll need to do is use one of
the handy “Paste ...” buttons on the filter or global search dialog.  Other
times, though, you’ll want to form a very specific expression so Agent will
know exactly what you’re looking for.

Note: You may want to jump ahead to the section Usenet Filter Examples (p.
79) or More Filter Examples (p. 86), to see what you can do using Agent’s
expression language.  Then you can come back to this section for specifics
on constructing correct filter and search expressions.

Expressions consist of the following components:

• One or more terms (word combinations on which to filter or search)

• Optional operators (words with special meanings used to combine terms)

• Optional qualifiers (symbols used to restrict the scope of filters or
searches)

Agent's expression language is versatile.  You can either create solely word-
based expressions (to get the best performance), or you can also include
"regular expression" phrases (a more sophisticated expression form
developed by UNIX users).  Although regular expressions are less
straightforward than using simple word-based expressions, they're much
more powerful.

Words, Phrases, and Case Sensitivity

The simplest expression is a single word.  You can combine individual words
to form phrases.  Finally, you can use operators, such as “and” and “or” to
combine phrases into complex boolean expressions.  When matching a
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phrase, Agent ignores all spaces and punctuation in both the filter
expression and the message being tested.  Punctuation and whitespace are
treated as a single space.  Thus, the following expressions are identical:

Mark F. Sidell <m.sidell@forteinc.com>

Mark F Sidell m sidell forteinc com

Mark-F-Sidell-m-sidell-forteinc-com

When words in the filter expression contain all lowercase letters, matching is
case-insensitive.  However, you can force an exact, case-sensitive match by
capitalizing one or more letters in the word.  For example:

subject: shell

will match shell, Shell, sHell, or ShELl found in message subjects.

To force a case-sensitive match, capitalize one or more letters in the word,
such as:

subject: Shell

This would only match Shell.

Operators in Expressions

The three operators used to combine terms in an expression are “and”, “or”,
and “not”, which have the following special meanings:

and Agent must find all of the phrases separated by “and” in order to
match the expression.  (The character “&” can be used in place of the
operator “and” in any expression.)  For example,

 subject: green apples and oranges

matches a subject that contains both the phrase "green apples" and
the word "oranges.

or Agent needs only to find one of the words separated by “or” in order
to match the expression.  (The character “|” can be used in place of
“or” in any expressions.)  For example,

subject: apples or juicy oranges

matches a subject that contains either the word "apples" or the
phrase "juicy oranges”.

not Agent must find no occurrences of the specified word or phrase.
(The character “!” can be used in place of “or” in any expressions.)
For example, the expression
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 subject: apple and not pies

matches all subjects that contain the word apple, but do not contain
the word pies.

You can have Agent treat any operator as normal text by placing quotes
around the word (i.e., "and", "or", "not").  This might be helpful if, for
instance, the word “and” is an integral part of a subject in a filter you're
adding.  For example, to match the phrase “this and (that)”, you can use any
of the following expressions:

this "and" that

"this and (that)"

this "and" "(" that ")"

Note:  When you use any of the Paste Field buttons, quotes are
automatically placed around any operators that are part of the field.

If you include more than one operator in an expression, Agent evaluates
them in the following order, highest priority to lowest priority:

not

and

or

You can change the precedence by using parentheses (...).  For example.

subject: pink or rose and not author: tsmith

tells Agent to match any message for which the subject contains the word
pink, or match any message that contains rose in any field for which the
author does not contain the word tsmith.

But

subject: (pink or rose) and not author: tsmith

means match any message for which the subject contains the word pink or
rose and the author does not contain the word tsmith.

In addition to "and", "or", or "not" the following operators are used in filter
expressions:

* The wildcard character (asterisk), when appended to a word in the filter
expression matches any word in the message that begins with the word
in the expression.  For example, com* matches “command”, “comment”
or any other word that begins with “com”.
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[l,h] To match a range of line counts, enclose the lowest and highest
numbers in the range (separated by a comma) in square brackets.  A “*”
in place of one of the numbers is a wildcard.  For example, [*,10]
matches all messages with no more than 10 lines, and [15,*] matches all
messages with at least 15 line.

% The percent character means that the following term should be case-
sensitive.

= An equal sign that precedes any term in an expression means that Agent
must find an exact match of that term.  When the = operator is applied
to a subject field, Agent first removes any "Re: " prefixes before
performing the match.  For example, the filter

subject: =testing

matches both "testing" and "Re: testing".  But, it does not match "more
testing", since the = operator requires an exact match of the entire field.
If you want to force Agent to do an exact match, but also include re: in
the match (for responses), you can do something like the following:

subject: re and =apple

This filter will match only subjects which contain (exactly) apple and
which also contain re.

Expression Qualifiers

In general, Agent searches as much of the message as possible for the
words or phrases in the expression.  How much of the message is searched
depends on the type of search (Usenet, email, or global search).  You can
use expression qualifiers to limit the search to selected fields.

If a search expression contains no qualifiers, the follow items are searched:

Usenet Filters: The Subject and Author fields only (and not the message
body)

Email Filters:   All header fields (and not the message body)

Global Search: All header fields and the message body

To limit the search to a particular message field, use a qualifier prefix, which
is the name of the field to be searched, followed by a colon.  For example:

subject: testing

searches just the subject field for the word "testing", while

subject: testing and from: tom gold
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searches just the subject field for the word "testing" and just the from field
for the phrase "tom gold".  Thus, it matches only those messages for which
the subject contains the word "testing" and the from field contains the phrase
"tom gold".

Usenet, email, and global search expressions all allow different qualifiers.

Usenet Filters may contain the qualifiers “subject:”, “author:” and “from:”.

Email Filters may use the name of any header field as a qualifier.  For
example, you match all messages posted with Agent with the expression:

x-mailer: forte agent

In addition, email filters may use the following special qualifier words:

any-sender: matches any of these fields: From, Apparently-From,
Sender, Reply-To, or X-Sender.

any-recipient: matches any of these fields: To, Apparently-To, Cc, or
Bcc.

Global Search expressions allow all of the qualifiers allowed by email filters,
and the following additional qualifiers:

body: matches the text sections of the message body.  In other words, it
matches all of the text that you would normally read in the message if
you are not viewing the raw, unformatted message.

raw-body: matches the complete, unformatted body of the message,
including sections containing binary attachments and images.

Usenet Filter Examples

Before proceeding with more details on constructing expressions, the
following examples should help you see how easy it is to create powerful
filters.  These examples illustrate filters for Usenet messages, but
remember, the mechanism is just the same for email messages.

Scenario:  You are an aviation enthusiast interested in knowing more about blimps.  You
have subscribed to the group alt.aviation.methods and want to create a Usenet Filter to tell
Agent to retrieve all messages about blimps in that group.

1. A simple watch filter and a wild card - Highlight a message header
about blimps (e.g., "How Does a Blimp Fly?").  Bring up the Add Usenet
Filter dialog box and complete the following fields as shown:

Filter Expression::  subject: blimp*
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Watch Action:  Retrieve Body immediately

Important!  Be sure to enter the generic format blimp (all in lower case
letters).  Filters are case-sensitive.  Thus, the entry Blimp only matches
headers containing Blimp (with an initial capital letter), while the generic
format blimp matches all instances of the word (e.g., blimp, Blimp,
BLIMP, or Blimp).

To catch all plurals as well, you need to add a wildcard character "*" to
your expression.  So, subject: blimp* will retrieve headers
containing all the singular forms of blimp shown above, as well as the
plurals (e.g., blimps, Blimps, BLIMPS, or BlimpS).  Note:  If you just
enter blimps, only the plural forms of the word will be used for
matching.

2. A filter to restrict the size of messages - In addition to the criteria in
example 1, if you only want to see messages about blimps that are 100
lines or less, you should modify the expression, using the "and" operator
and a line range argument in your expression, as shown.

subject: blimp* and [*,100]

3. A filter to screen out unwanted authors - Now say, in addition to the
above, that you want to filter out any messages by an obnoxious author
named Rocco.  You can modify the expression using the "and" and "not"
operators and the name of the author:

subject: blimp* and [*,100] and not author: rocco

4. A filter to "filter on" a second subject - If you also want to learn about
airships as well as blimps (using the previous criteria), you might want to
modify the expression using the "or" operator and parentheses to
establish precedence:

subject: (blimp* or airship*) and [*,100] and not
author: rocco

5. A filter that reduces clutter - In addition to the previous criteria, you
can tell Agent not to retrieve anything else by creating a kill filter with a
lower priority level.  The settings for the new kill filter should be as
follows:

Filter Expression: subject: *  (all headers will be evaluated)

Kill Action: Delete

Scope: Group: alt.aviation.methods

Priority: 100  (Make this value lower than the watch filter.  That
way, Agent first retrieves the messages about blimps
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because the watch filter has higher priority, then this
filter tells Agent to skip everything else.)

Try creating a couple of filters yourself.  You can use these examples as a
template, or you can be a little more adventurous and create something
completely different based on the basic principles you've just learned.

Regular Expressions

The previous examples illustrate what are called word-based expressions for
Agent filters.  While these are both powerful and easy to use, sometimes
you can’t use them to get the precise behavior you might want.  In this case,
you may want to use what are called regular expressions.

Use Regular Expressions Only When Necessary.

Because of the extra computation required to evaluate regular expressions,
it is recommend that you use them only when necessary, especially in
Usenet and email filters, where the time required to evaluate filters can
significantly affect online performance.  If all you need to do is match words,
then it is much faster to use Agent's simpler word-matching syntax.  For
example, the following word-based filter:

subject: this is a test

is much faster than this regular expression filter:

subject: { this is a test }

In general, you should find that you need to use regular expressions only if
you need to:

• match punctuation characters that are not normally treated as "words".

• match text that appears inside of words.

How to Include Regular Expressions in Filter Expressions

Anywhere a sequence of words to be matched can appear in a filter
expression, you can include a regular expression enclosed in {..} (curly
braces).  Here's an example of a regular expression, combined with a
sequence of words to be matched, as well:

subject: (this is a test and {[0-9]+})

This example matches any subject containing the phrase "this is a test" AND
a regular expression consisting of any sequence of one or more digits.

Rules for Writing Regular Expressions
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Atoms

The simplest regular expression is called an "atom".  An atom can be any of
the following:

• Any character that doesn't otherwise have special meaning.  For
example, the letter "a" is an atom that matches "a" or "A" in the field
being tested.

• The . (dot) character.  A dot matches any character.

• The ^ (carat) character, which matches the beginning of the field being
tested.

• The $ (dollar sign) character, which matches the end of the field.

• The \ (backslash) character, followed by any character.  You can use
backslash to "quote" characters that otherwise have special meaning.
For example, to match the literal character ".", you would write "\.".
Without the backslash, the "." would match any character, not just ".".

• A more complex regular expression enclosed in parentheses (...).

• A "range" of characters, enclosed in [...] square brackets.  A range is
defined according to the following rules:

a. A range may be a simple list of characters.  For example, the range
[qwerty] matches a single occurrence of any of the characters q, w,
e, r, t, or y.

b. A range may be a character range, specified as x-z.  For example,
the range [0-9] matches a single occurrence of any character in the
range 0 through 9.

c. More complex ranges may be built with the previous two rules.  For
example, the range [a-z0-9] matches any letter or digit.  (Remember
that Agent's regular expressions are normally case-insensitive.
That's why you don't need to include A-Z in the range.)

d. If a range begins with a ^ character, it matches any character not in
the specified range.  For example, the range [^a-z0-9] matches any
character that is not a letter or a digit.

e. To include the characters ^, [, ] , or - inside a range as literals, prefix
them with a \ backslash.  For example, the range [^\^\]] matches any
character that is not ^ or ].

Controlling the Extent of an Atom's Match



All About Messages

83

You can modify an atom by following it with special operators that control
how much of the field the atom should match.  The special operators are:

* This matches a sequence of zero or more matches of the atom.  For
example, the expression {a*} matches zero or more occurrences of the
letter a.

+ This matches a sequence of one or more matches of the atom.  For
example, the expression {[0-9]+} matches one or more digits.

? This matches zero or one occurrence of the atom.

For example,

{ab(c)*} matches the letter "a", followed by the letter "b", followed by
zero or more occurrences of the letter "c".  Thus, it matches "ab", "abc",
"abcc", etc.

while

{(abc)*} matches zero or more occurrences of the sequence "abc".
Thus, it matches nothing, or "abc", or "abcabc", or "abcabcabc", etc.

Concatenating Atoms

You can concatenate atoms to form more complex sequences to be
matched.  Here are some examples:

{forte} matches the sequence consisting of "f", followed by "o", followed
by "r", followed by "t", followed by "e".

{a?b} matches zero or one occurrences of the letter a, followed by one
occurrence of the letter b.  Thus, it matches "ab" and "b".

{[0-9]+/[0-9]+} matches one or more digits, followed by a "/" character,
followed by another sequence of one or more digits.

{foo(bar)*} matches the sequence "foo", followed by zero or more
occurrences of the sequence "bar".  Thus, it matches, "foo", "foobar",
"foobarbar", "foobarbarbar", etc.

{^foo.*bar} matches the sequence "foo", followed a sequence of zero or
more occurrences of any character, followed by the sequence "bar".  In
addition, the ^ requires that the match occur at the beginning of the field.

Alternative Matches

You can specify alternative matches, by combining sequences of atoms with
the | operator.  For example,

{a|b} matches either the letter “a” or “b”.
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{foo|bar} matches either the sequence "foo" or the sequence "bar".

Filter Operators Applied to Regular Expressions

You can apply the filter operators = (match entire field) and % (case-
sensitive) to regular expressions in the same way that you can use them with
word phrases.

If a regular expression is preceded by =, Agent must match the entire field.
For example, the following filter:

subject: ={begin.*end}

matches any subject that starts with the characters "begin", ends with the
characters "end" and contains any characters in between.

As with word phrases, when the = operator is applied to a subject field,
Agent first removes any "Re: " prefixes before performing the match.

The % operator causes the entire regular expression to be case-sensitive.
Otherwise, regular expressions in Agent filters are case-insensitive.  For
example, the filter

subject: %{[A-Z]+}

matches a subject containing a sequence of one or more CAPITAL
LETTERS.

However, the filter

subject: {[a-z]+}

matches a subject containing a sequence of one or more letters, in any
combination of lower-case or CAPITALS.

Example: How To Filter Out Unwanted Email

Are you being inundated with unsolicited commercial email (UCE) and other
offensive messages?  These types of messages, commonly referred to as
"spam", are a major annoyance to many users.  Here’s a procedure you can
use to help control the flood of unwanted email.

1. Set up three folders, as follows:

• Create one folder for email that you know you want to receive.  You
might call it "inbox".  (Of course, you could create multiple folders to
further categorize messages that you want to save.)

• Create a second folder for UCE/spam.  You could call this folder
"trash".  (Alternatively, you could configure your filters to delete
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spam immediately upon receipt.  The only problem with that
approach is that you might inadvertently delete a message that you
really wanted to keep.)

• Create a third folder for mail that has not yet been categorized.  You
could call this folder "uncategorized" or "to be sorted".

2. Next, configure Agent's default email filter settings to use the three
folders:

• On the Options→Inbound Email→Folder tab, select the default
folder to be your "uncategorized" folder.  This will cause all email
that is not processed by any other filter to be placed there.

• On the Kill tab, set File in Folder: to your "trash" folder.  You will
probably find that the other dialog settings are already appropriate.

• On the Watch tab, set File in Folder: to your "inbox" folder.

3. When you first start receiving email, all new messages will get filed in
the "uncategorized" folder.  After you receive a batch of new messages,
scan through them to decide how you want messages from the same
senders to be processed in the future.

4. For spam messages, press Ctrl+K to create a kill filter using the Add
Email Filter dialog box.  The default filter settings will create a filter that
will place all future messages from that sender in your "trash" folder.

By default, the kill filter will match the sender's complete email address.
That will often be appropriate.  However, you might want to modify the
filter if you want to match any messages from that domain.  For
example, if you receive a message from "great-offer@savetrees.com",
you could choose to trash all future messages from any address at the
"savetrees.com" domain.  To modify the filter to match just the domain,
press the Paste Field button, highlight the "Any-Sender (Domain only)"
entry, and press OK.  (Of course, you could achieve the same result by
manually editing the match expression; using the Paste Field button is
just faster.)

Note that many times spam mail is not directly addressed to you, that is,
it does not have your actual address as the value in the "To:" field.  One
handy way to eliminate this type of spam is to create a kill filter that will
match any message that does NOT contain your actual address.  Here's
an example for a user named Jane Doe:

not any-recipient:janedoe@abc.com



Chapter 4

86

This will work for most spam.  However, you may find that your own mail
system inserts an Apparently-To field into messages that are missing a
To: or Cc: field.  The "any-recipient" filter matches the Apparently-To
field.  If you'd prefer to have a filter that does not match that either, try
the following example:

not to: janedoe@abc.com and not cc: janedoe@abc.com

5. For messages from senders you know and want to receive messages
from in the future, press Ctrl+W to create a watch filter containing those
individuals addresses, for example:

from: (tsmith@acme.com or hank.lloyd@zsu.edu)

6. When you create either a kill or watch filter, you can check the Apply
filters to folder immediately option to cause Agent to reroute all matching
messages immediately.  If you aren't sure that you want to reroute all
matching messages in the folder, you can check This message only.

As you define more kill and watch filters, you will find that Agent will get
better at automatically routing your email, and there will be fewer
"uncategorized" messages that you have to deal with.

More Filter Examples

People create filters for a variety of different reasons.  What follows is a
sampling different expressions you might want to refer to when creating your
own filters.

To isolate and remove unwanted messages

More than likely you receive unwanted messages of all sorts, from "get-rich-
quick" schemes to offensive or sensitive subjects.  Here are several
examples of expressions used to "kill" this type of message:

1. To improve performance, you might want to combine a number of types
of spam you wish to eliminate in one filter.  As other key words that
offend you pop up, you can always add them to the expression.  Note
that in the example below, the vertical bars are equivalent to the
operator "or".

subject: ($ | $$ | $$$* | $money* | sex* | porn*| xxx*)

2. To prevent Agent from retrieving message headers that start with
characters such as !, $, <, -, etc. (usually spam), use a filter like this:

subject: {^[^a-z"]}
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Since regular expressions in Agent are case-insensitive unless preceded
by the % operator.  This expression allow subjects which start with upper
case letters, or those which start with lower case letters, or those which
start with a quotation mark.

Here’s how it works: The first “^” means, “match if the string is at the
beginning of a line.”  The second "^" character, inside the brackets "[ ]",
means "not these characters", i.e. "match any character that is *not* any
upper or lower case letter or quotation mark.”

To filter on a particular word

1. To match anything ending in "right", followed by a space or the end of
the field, you can use the following expression:

{right( |$)}

This will match birthright, or forthright, or just right, but not righteous.

2. To match right anywhere in the subject, you can use the following
expression:

{right}

This will match righteous or forthright or just right.

To eliminate "header-only" files with little or no body

[1,2]

Note that the lower range is 1, rather than 0.  This is because some news
servers fail to add a line count to messages, causing all messages to have a
count of zero.

To prevent retrieving headers that use ALL CAPS

Create a filter that matches subjects with all capital letters.  Use the filter to
either delete all matching messages or place them in a "trash" folder.

subject: =%{[^a-z]+}

Remember that regular expressions in Agent are case-insensitive unless
preceded by the % operator.  The % operator is needed here so that the
filter will exclude subjects which have upper case letters but no lower case
letters, as well as those with no letters at all.

Here’s how this expression works:

The equals sign "=" means "must match entire field".  In other words, the
field must consist entirely of characters that are not lower-case letters.  The
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expression “[^a-z]” means "match any character that is not a lower case
letter."  Finally, the plus sign “+” means "there must be one or more of the
preceding characters in the field."

A Final Example: How To Optimize Agent For Use At Two Sites

This example shows how you can combine preferences for retrieving email
(see p. 63) with email filters to fine tune your use of Agent at work and at
home.

Say you have a single POP box and you use Agent as your email program
both at work and at home.  Since you only have a single address, you
receive both personal and professional email into the same POP box, and
you might receive either type of mail at either location on any day of the
week.  You'd like to get your work email at work, and your personal email at
home.  First, check the Leave messages on server and the Until retrieved at
both of my sites options on the Options→Inbound Email→Checking Mail tab.
This way you'll get your professional and personal messages both at work at
home, and Agent will automatically remove them from the server when
they've been received at both sites.

Now tell Agent to selectively retrieve certain kinds of messages in one
location but not the other.  For example, say you receive a newsletter that is
related to your work and you're never interested in receiving it at home.  On
your copy of Agent at work, create an email watch filter that retrieves the
message, files it in a folder of your choice, then removes the message from
the server.  (Do this by checking the "Do not leave on server option" when
you create the filter.)  On your copy of Agent at home, create an email kill
filter for this same message (using any field appropriate to recognize the
message), setting "delete" as the kill action.  Make sure you do not check the
Do not leave on server option.  If you do, you'll never get the message at
work if you first see it at home.  Follow the same steps for other email,
personal or professional, until you get the balance you want between what
you receive at work and what you receive at home.

Viewing Messages
If there is one certainty in life, it's the fact that everyone has their own way of
viewing things.  What works well for one may not for another.  Agent
understands this and has built in features that allow you to change how
Agent displays messages to best suit your tastes and needs.
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Sorting Messages

In the Message List pane, you can sort messages by thread, subject, author,
date, or size.  You can have a different sort for each group and, whenever
you start a new session, Agent always remembers the last sort you used for
each group.

To sort messages:

Below are equivalent options.  Choose the one that's easiest for you:

Menu option: Select a sort type on the Group→Sort Messages by flyout menu.

Mouse option: In the Message List pane, click the column header label identifying
the sort (e.g., Date).

_____________________________________________________________

OO Using the menu option, you can select multiple groups/folders from
the Groups/Folders pane, then choose the desired method to sort all
of them at once.

Using the mouse option, you can sort by thread or size by clicking the
leftmost column until Thread or Size appears in the column label

_____________________________________________________________

Agent displays the most recent messages at the bottom of the Message List
pane, when sorted by date and the largest messages at the bottom, when
sorted by size.

To change the order of the date and size sorts:

1. Select the Options→General Preferences→Message List tab (shown
below).

2. Check the Date sorts descending and/or Size sorts descending box.
_____________________________________________________________

OO You must re-sort the group or folder after checking or unchecking
these boxes for the changes to take effect.

_____________________________________________________________

Changing the Way Threads Display

In addition to sorting your message headers, you can fine tune the way the
threads are viewed in the Message List pane.

To define how threads display:
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Select the Options→General Preferences→Message List tab to see the
following settings affecting how threads display.

 The options in the Threading section are described in the following table:

Choose this
option...

...to have Agent do this.

Enable threading
by subject

Include messages with the same subject under the same
thread, even if the follow-up message does not contain a valid
reference to the original.

Note: People frequently mispost responses.  This option
helps match follow-ups with the message to which they are
responses

Start a New
thread when a
follow-up subject
changes

Create a new thread when a follow-up message’s subject is
different than the main message’s subject.

(When this option is unchecked, Agent attaches follow-up
messages to the original, even if the thread's subject
changes.)

Expand thread if Expand the thread in the Message List pane so that the
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necessary to
highlight current
body pane
message

current message is visible.

Choose this
option...

...to have Agent do this.

Initial thread
setting

Show the thread in the selected state whenever you open
Agent (e.g., all threads collapsed)..

When skipping to
unread follow-ups

Show the selected thread state when you skip to an unread
message.  Two additional notes: If you use one of the View
navigation options and the current setting is Do not expand,
then Expand active threads is used.  Also, the View Next
Unread Message Body option on the Navigate menu always
expands the thread, even if the message is the first message
in the thread.

Follow-Up
Indentation

Indent all follow-up messages the specified number of spaces
(in characters) from their parent in the Message List pane.

Maximum
Follow-Up Level

Show up to the specified maximum number of response
levels.  Any responses deeper than this appear at the most
indented level.

Reply Prefixes This is a list of all the prefixes Agent will recognize.  Agent
uses this prefix when processing message subjects.  There
are times when Agent needs to identify and remove the reply
prefix "Re:".  By convention, most people use "Re:" to signify
a reply.  However, other languages use different prefixes for
the same purpose as "Re:". In this entry box, enter any prefix
not on the list that you want Agent to recognize.  Prefixes can
be separated either by a space or comma.  Also, when Agent
searches for prefixes, the match is case-insensitive, so it
doesn't matter whether you enter prefixes in upper or lower-
case.

Note:  Agent always assumes that a reply prefix ends with a
":" colon, so you should not include colons in the prefix list.

Creating and Using Views In The Message List Pane

Agent allows you to specify exactly the types of messages to be viewed in
the Message List pane and in your folders (e.g., Unread messages).  In
either case, the selection is global (i.e., the view applies to all groups or to
all folders).  If you don't see the exact view you want, you can create your
own.



Chapter 4

92

Note: Sometimes a view may not display all messages in a thread.  For
example, you may set your view so you see only unread messages and
some messages in a thread are read.  If you want to see everything in the
thread, highlight the thread and use the command Navigate→Show Full
Thread.  This is a temporary command, showing the full thread only as long
as you remain in the current Message List pane using this view.

To select views on the fly, use any of the following methods:

• Open the Group→View Messages flyout and select a view.

• On the Message List pane header, left click the binoculars  icon and
the Select View dialog box appears, from which you can select a view.

• Hit the “V” key and the Select View dialog box appears, from which you
can select a view.

To create a custom view, use either of the following methods:

• Open the Group→View Messages flyout and select Manage Views.

• In the Groups/Folders pane, right click a group or folder and a context
menu will appear.  On the context menu, open the View Messages flyout
and select Manage Views.
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You can use the Manage Views dialog box to create and add views to the list
of defined views, or to rename or delete existing views in the View list.
Agent is entirely flexible, allowing you to create simple or complex views.
Here's how it works.

For a simple view:

1. Make sure Simple View is selected.  Then press the Add button to bring
up the Add dialog box and enter the name of your new custom view.

Note:  You can create a keyboard shortcut to the new view by adding the
ampersand (&) character before the desired shortcut character in the
view name.  The "&" tells Agent to underline the following character
when the name appears on the View menu and make that character a
keyboard shortcut.

2. When you press OK on the Add View dialog, the name is added to the
Views list and is the current selection.
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3. Now select all the message attributes that will apply to the view and
press the OK button on the Manage Views dialog box.  Whenever you
select this view in the future, the selected attributes apply.

To define more complex views, select the Advanced view option.  When this
option is selected, a Boolean expression field appears where you can enter
an argument that defines precisely what you want to show in your new view.
(See the figure on the following page.)

Using Boolean Expressions to Create Complex View Filters

Earlier in this chapter you were introduced to boolean expressions as word
based phrases that pose conditions.  These conditional phrases consist of
two parts: operands and operators.  When you enter an expression in the
Boolean expression field (see the following figure), Agent uses that
expression each time you retrieve new headers, checking for that defined
condition.  This condition then determines which messages will appear in the
Message List pane.

Expression operands

The expression operands are conditions that can be tested.  They are:

• Read (as in messages that have been read)

• Body (as in message body)
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• Watch (as in watch a thread)

• Ignore (as in ignore a thread)

• Keep (as in prevent a message from being deleted or purged)

• Mark (as in mark a message for later retrieval)

• Incomplete (as in multipart messages with missing parts)

Expression operators

The expression operators that affect how the conditions are tested are listed
below, in order of priority.  Use the word or symbol, whichever you prefer:

• not (or the equivalent symbol !)

• thread (or the equivalent symbol +)

• and (or the equivalent symbol &)

• or (or the equivalent symbol |)

• [low,high]

While the "not", "and", and "or" operators are self-explanatory, "thread"
specifies that if the condition that follows is true, the complete thread
containing the message that matched the condition should be displayed.
Also, "[low,high]" allows you to specify a range of lines in messages (e.g.,
[50,*] specifies messages that are 50 lines or more).

Examples of simple expressions

not read and body - Agent will display all unread message with bodies.

not read and not incomplete - Agent will display all unread messages that
are complete.

!read | keep - Agent will display all messages that are unread or kept.

Examples of advanced expressions

You can also create advanced compound expressions, using more than one
phrase.  To establish precedence, you can surround one of the phrases with
parentheses (...), which changes the order in which Agent will evaluate the
phrase.  The following examples are compound expressions that use
different operands and operators to create unique views:

not read or thread (not read and watch) - Agent will display all unread
messages.  Also, for all unread messages in watched threads, display the
complete thread.
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(thread (watch and keep)) & (not read and body) - Agent will display only
unread messages in threads that are both watched and kept (i.e., preceded
by the Keep icon ).

!ignore & !read & !incomplete & [50,*] - Agent will display all messages
that are not ignored, that are unread, that do not have incomplete body
attachments, and that are a minimum of 50 lines.

Note: When you switch from a simple to advanced filter on the Manage
Views dialog box, Agent displays the boolean expression that is equivalent
to the simple filter that was defined.  When you switch back, Agent attempts
to display the simple filter that is equivalent to the boolean expression.  But,
since expressions can define filters that cannot be defined in the simple way,
the resulting simple filter may not be an exact match.  Agent will warn you
when you do this.

Changing How Message Bodies Display

Display preferences - You can use the Options→Display Preferences
Messages tab to modify the appearance of message bodies, including:

• Tab spacing (the number of characters tabbed text is indented)

• Quoted text markers (the characters indicating quoted text in a
message)

• Dividers between sections of a message body

• How URLs display (color, underlining, highlighting)

Word wrapping - Agent also has a Word Wrap option on the Message
menu that allows you to optimize the way message bodies are viewed.
Using this option is particularly helpful when you receive messages with
very long lines that do not fit on your screen.  Agent will automatically
wrap the text in such messages so that all of the text is visible in the
display window.

Message details - You have the option in Agent to show or hide all the
finer details about a retrieved message (e.g., author, subject, date, total
lines.)  You can also view a message in its formatted or unformatted (raw)
state.

Changing fonts - Agent allows you to specify message text to suit your own needs
and preferences.  You select the display fonts using the Options→Display
Preferences→Fonts tab.

For more
details, see
page 182.

For more
details, see
page 188.

For more
details, see
page 189.

For more
details, see
page 184.
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ROT13 Text

When viewing a message body, you might see text that looks like gibberish
(see example on next page).  When you see something like "V'ir gelrq
gb qtxaybnq SERR NTRAG sebz gurve JJJ cntr.", chances are that the
text has been encoded with a scheme called ROT13.

To better illustrate the point, the phrase “Hello World” encoded with ROT13
looks like this:  “Uryyb Jbeyq”.  ROT13 encoded text cannot be read without
first decoding it.  Agent supports both ROT13 encoding and decoding.

Here's what you do:

To encode a ROT13 message:

1. Highlight the text to encode.

2. Select Edit→Apply ROT13 (or press CTRL+3).  Agent will encode the
highlighted text.  Once encoded as ROT13 text, the message cannot be
read without first decoding it.

To decode a ROT13 message:

1. Highlight the encoded text.

2. Select Edit→Apply ROT13 (or press CTRL+3).

_____________________________________________________________

OO When you decode text in a message you have retrieved, the decoding
only affects your display.  If you return to this message later, you will
again see the encoded, original text.

Encoding text in a message you’re creating affects the actual text.  If
you post the message, other people will see it with the text encoded.

_____________________________________________________________

Finding Messages
As you work with Agent, you likely will begin to accumulate a large number
of both news and email messages.  There will be times when you need to
find a specific message, or several messages about a certain topic or from a
certain author.  Agent provides tools to help with just such a need.
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Find / Find Next

When working in a single group or folder, use the Find function to search for
messages whose subject or author fields contain a particular text string.

To find a message matching a simple text string

a. Set Agent’s focus to the Message List pane of the group or folder where
you want to find the message.  You can do this by selecting any
message in the list.

b. Select Edit→Find (or enter Ctrl+F).

c. When the Find Message dialog appears, enter any part of the subject or
author for which you want to search.

d. Click the Find First button to find the first message in the list containing
the text you entered.  Press Find Next to find the first message below
the currently selected message which contains the desired text in the
subject or author field.  In either case, the dialog box will disappear and
you will be positioned on the found message.

e. If the found message is not the one you want, select Find Next (or enter
F3) to find the next message containing the text you entered.

Global Search

Often, a simple “find” operation isn’t enough.  You may want to search the
body of a message for a text string, or you may want to search for messages
across several groups or folders.  In such cases, you want to use Agent’s
global search feature.

To perform a global search for messages in Agent, select Edit→Global
Search (or enter Ctrl+G).  The Global Search For Messages dialog will
appear.
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Using this dialog, you will execute the search in four easy steps:

1. Tell Agent what to search for.

Search For - enter the search expression in this entry box.  Global
Search expressions are the same as Usenet and email filter
expressions: that is, either word-based expressions or regular
expressions can be used.

• If you don't specify any fields in the expression, Agent searches all
fields and the message body.

• If you enter the field "body:", Agent searches the formatted message
body (i.e., the text you see on the screen when "Show Raw
Message" on the Message menu is not selected).

• If you enter the field "raw-body:", Agent searches the complete raw
body of the message (excluding headers).

Here’s an example:  subject:testing and body: {some regular expression}

Note: Any field name you enter is legal, as well as the special names
"any-sender", "any-recipient", "body", and "raw-body".
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For body searching, regular expressions are line-based.  That is, a
regular expression search matches a line at a time and cannot search
for text that spans multiple lines.  Word based searching spans multiple
lines.  Note:  Lines refer to lines of text bounded by hard breaks, not
word-wrapped lines as displayed on the screen.

Paste Field - press this button to open a Paste Field dialog box, to paste
text from the message that is currently open in the associated Browser
window.

History - press this button to open a dialog box that lists up to twenty of
the most-recently used search expressions, for pasting.

Lower Case - press this button to make the text in the Search For entry
box all lower case.  This allows you to match all instances of your entry
during a search.

2. Specify where you want Agent to look:

Search in Selected groups and folders only - check this box to have
Agent search only the groups and folders that are currently selected
(highlighted) in the associated Browser window.  Note: You can move
back and forth between the Browser window and this dialog.  Thus, you
can open a Global Search dialog box and then return to the Browser
window to select different groups to search.

Search in All Groups in view - check this box to have Agent search all
newsgroups that are visible in the Browser window.  For example, if you
have Subscribed Groups selected, Agent will search all subscribed
groups.

Search in All folders in view - check this box to have Agent search all
folders that are visible in the Browser window.

Search in Visible messages only - check this box to have Agent
search only those messages currently being displayed in whatever
message views you have selected for the Browser window.  Note:
Groups and folders can have different views.  For the currently open
group/folder, this means search whatever messages are currently visible
in the group, not just those that are selected by the view.  Keep in mind
that it's possible for various events, such as receiving new mail, to cause
messages to be temporarily added to a view.

Close when successful - check this box to have Agent close this dialog
box when it is currently in focus and Agent has finished a successful
search.  When unchecked, Agent leaves the window open so that it can
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easily perform additional searches.  This option remains active while a
search is in progress, in case you change your mind.

3. Indicate how you want Agent to go about finding messages.

Find First - press this button to find the first matching message and
position the associated Browser window on it.

Find Next - press this button to find the next matching message, starting
with the message after the message that currently has the focus in the
associated Browser window.

Find Next Group - press this button to find the first matching group,
starting with the group after the group containing the message that
currently has the focus.  Use this button to quickly search for a particular
group or folder.

Find All - press this button to find all matching messages in all selected
groups and folders.

Find All in Current Group/Folder - press this button to find all
matching messages in the currently open group or folder.  This option
ignores the "Search in group/folder" options and only searches the
currently open group or folder.  On completion, Agent causes the
associated Browser window to display only the matching messages.
When it does this, it changes the message view title on the Message List
pane to "Search Results".  The search results are retained until you
change the message view or you move to a different group or folder.

Stop - press this button to stop the search in progress.

Cancel/Close - press this button to have Agent close this dialog box.

4. View the Search Results

Results - this listbox displays the group or folder names and the subject
for each matching message.  It is updated incrementally while the
search progresses.  The window can display up to 8000 messages.  If
the search exceeds that number, Agent stops and displays an error
message.

Jump - press this button to jump to the message selected in the Results
list.   If a search is still active, the search window is minimized.  If no
search is active, this dialog box closes.

Here are some instances when you might want to use Jump.
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• When you're just looking for something and want to position on the
message and leave the Global Search dialog up and with focus.

• When you want to read the message but come back to the Results
list when you're done reading.  To position on the message and
switch focus to the Browser window, use Shift+Jump.  This will
minimize the Global Search dialog.

• When you find what you're looking for and are probably done with
the search.  In this case, Agent positions itself on the found message
in the Browser window and closes the Global Search dialog.

View All - pressing this button causes the Browser window to display a
view of all matching messages for the group containing the message
selected in the Results list.  If a search is still active, the Global Search
dialog is minimized.  If a search is not active, Agent closes this window.
To keep the Global Search dialog open, hold down the SHIFT key while
pressing this button.  Ctrl+double-click is equivalent to pressing the View
All button.

Clear View - press this button to clear the search results view in the
Browser window and revert to the original message view.  Another way
to clear the search results is to simply re-select the current message
view in the Browser window.  This refreshes the view.

Tips for Global Searching

Here are a few tips for using the Global Search for Message dialog box more
efficiently:

• In the Browser window, select a message containing a subject for which
you want to search.  Open a Global Search dialog box and press the
Paste Field button to paste the subject into the search expression.  Then
press Find First and Find Next until you find a group or folder containing
the subject.  Once the group or folder is found, press Find All to display
all matching messages in that group.

• When doing the above type of search, if you only want to search, say,
unread messages, change the Browser window's message view to
unread before searching and choose the Search in Visible messages
only option on the Global Search dialog box.

• If the search reveals too many messages, change the search expression
and do a Find All again, using the displayed results of the last search.
Agent will re-search only those messages selected by the previous
search.
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Keeping Messages
To read messages offline at your leisure, Agent stores all groups and
message data on your hard disk.  Inevitably, your message databases will
grow, causing your hard disk free space to shrink.  For this reason, Agent
has a system to automatically purge (remove) messages after a certain
period to make room for new messages.

You need not do anything to make this happen.  Agent is configured to purge
messages for you at what is considered a prudent rate.  However, you have
the option to create your own purging strategies, or to override purging to
keep selected messages indefinitely.

The following topic, Purging Strategies, describes your options for telling
Agent when and what to purge.

Purging Strategies

You can specify exactly what messages to purge and when you want them
purged on a routine basis (e.g., purge all messages over 10 days old when
exiting Agent).  Purging controls the messages that you keep in your
message database.

Purging does not affect disk space usage.  For example, after purging a
database file that is 1.4 megabytes in size, the file will still take up 1.4
megabytes.  Even though the file may have been emptied of many
messages, the space allotted to the file remains exactly the same.

However, as new messages are retrieved after the purge, they fill in the
space left in the file by the purging.  This keeps the file from getting larger
(at least until the previous maximum size is surpassed).  To reduce the
size, you must follow message purging with database compaction (see
page 107).

To tell Agent when to purge messages:

Open the Group→Properties→When to Purge tab to view the settings below.
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The first two options on this dialog box tell Agent when to purge messages.
Select the one that best fits your needs

• When Retrieving new headers - Check this box to have Agent purge
messages from a group when retrieving new headers for that group.

• When Closing Agent - Check this box to have Agent purge all
newsgroups when you exit Agent.

Note:  If neither of the above options is checked, Agent will not automatically
purge messages.  However, you can purge messages manually from the by
opening the Group→Purge Newsgroups flyout menu and selecting the
desired set of groups.

• When closing Agent, Prompt for confirmation... - When checked,
Agent asks for confirmation before purging (and/or compacting
databases) when you close Agent.  When unchecked, Agent will purge
and/or compact the databases without asking.

To tell Agent what to purge:

Open the Group→Properties→What to Purge tab to view the settings below.

The compacting
options are
described on
pages 107.
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The options on the What to Purge tab are described as follows:

1. Minimal, Low, Medium, High - Press the button that corresponds to the
amount of hard disk usage you expect with Agent on a normal basis.
Since this can be complicated, these four preset options can make all
the detailed settings for you, depending on your concern as to how much
space Agent may take on your system.  After pressing a button, you may
check the other settings and change them to best meet your specific
needs.

2. Purge Read Messages Without Bodies - Select an option from the
choice list to have Agent purge messages for which you did not retrieve
bodies, but which have been marked as read.  The options are On every
purge, When the message is older than... (you set the limit),and When
the message is no longer available on your server.

3. Purge Read Messages With Bodies - Select an option from the choice
list to have Agent purge messages for which you did retrieve bodies and
which have been marked as read.  The options are On every purge, On
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every purge delete body only, When the message is older than... (you
set the limit), and Never.

4. Purge Unread Messages Without Bodies - Select an option from the
choice list to have Agent purge messages whose bodies you have not
retrieved and have not yet been marked read.  The options are On every
purge, When the message is older than... (you set the limit), and When
the message is no longer available (on your server).

5. Purge Unread Messages With Bodies - Select an option from the
choice list to have Agent purge messages you have retrieved, but have
not yet read.  The options are On every purge, On every purge delete
body only, When the message is older than...,and Never.

6. Always get complete list of server's available messages - Check this
box for Agent to retrieve a complete list of available messages
whenever it gets new headers.  This option is useful (but not required)
when you have selected the When the message is no longer available
option in one of the previous steps.  It does, however, increase the time
required to get new headers.

If you uncheck this box, Agent will purge messages with numbers lower
than the range of available messages reported by the news server.
Since there are often gaps in the available range of messages, this
setting may cause Agent to keep messages that are no longer available.

Preventing Agent from Purging Messages

Occasionally you will come across a message that you do not want Agent to
automatically purge (or that you don’t want to accidentally delete).

To prevent Agent from purging a message:

Highlight the message header and use one of the following options:

Toolbar button:

Menu options: Message→Keep

Keyboard shortcut: K

The Keep Message icon  will appear next to the message.  Agent cannot
delete the message until you remove the icon.  To remove the Keep
Message icon, repeat one of the above options.  Once the Keep icon is
removed, Agent will purge the message according to the settings specified
on the When and What to Purge tabs described previously.
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Manually Deleting Messages

In addition to the automatic purging options discussed in the previous topic,
you can always manually delete message headers and message bodies.

To delete a message:

Highlight the headers you want to delete and use one of the following
options.

Toolbar button:

Menu options: Message→Delete

Keyboard shortcut: Del

Note:  You can't manually delete a "kept" message.

To delete a message body:

With the focus in the Message pane, use one of the following options.

Toolbar button:

Menu options: Message→Delete Body

Keyboard shortcut: Ctrl+Del

Compacting Databases

You can compact your databases either manually or automatically to
remove the space you may accumulate after purging or deleting messages.
Note:  In general, you probably do not need to compact your databases
automatically.  Compacting after changing purge settings should be
sufficient.

To manually compact the database files:

Select File→Compact Databases.  Agent scans the databases to determine
how much disk space can be saved.  A message will tell you what you'll
save and you can decide whether or not to proceed.

To automatically compress the database files:

Open the Group→Properties→When to Purge tab to view the settings below.
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The options for compacting databases are described as follows:

• After Manual purges - Select this option to compact the databases
whenever you manually purge messages.

• When closing Agent - Select this option to compact the databases
when you exit Agent.

• Compact only if wasted Space is at least... - Before compacting a
database, Agent checks to see how much space would be saved by the
compact operation.  This setting allows you to bypass the potentially
time-consuming operation if only a small amount of disk space savings,
as a percentage, would be saved.  Enter the minimum amount of disk
space savings, as a percentage of the total size of the database, that will
cause Agent to perform an automatic compaction after either a manual
purge and/or an automatic purge during exit.

• When closing Agent, Prompt for confirmation... - When checked,
Agent asks for confirmation before purging and/or compacting
databases when you close a program.  When unchecked, Agent will
purge and/or compact the databases without asking first.
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Printing Messages
To define Print Setup settings:

Select File→Print Setup to display a standard Print Setup dialog box, where
you specify your printer, paper options, and whether the page orientation will
be vertical (Portrait) or horizontal (Landscape)..

To define Page Setup settings:

Select File→Page Setup to display the Page Setup dialog box.

The Margins settings are much like those on standard Page Setup dialogs.
The other settings, unique to Agent, are described as follows:

1. Print raw (unformatted) message - Check this box to print the
message in its raw form.  This means that you will print the message
header details (e.g., Path, From, Subject, Date, etc.) and the message
text.  In addition, any attachment in the message is printed as a series of
lines of coded characters.

2. Header Fields to Include - Choose which header fields you want
printed with a message.
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3. Page Breaks - Select where you want page breaks.

To print single or multiple messages:

Highlight the desired message headers in the Message List pane and select
File→Print (or press Ctrl+P).
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CHAPTER 5

Composing and Sending Messages
In this chapter, you'll get a close look at the Composition window and the many options you
have when composing and sending messages.  Whether you're composing a simple text
message, or sending someone a ".WAV" sound file as an attachment, Agent makes sending
messages a seamless operation. This chapter is broken out into the following topics:

1 Overview

1 Fields

1 Signatures

1 Address Book

1 More About Text

1 More About Sending

Overview
There are several types of messages that you can compose in Agent.
Here's the basic procedure to follow when composing any one of these
types.

1. Open a Composition window for the type of message you want to
compose (e.g., new email message) using either the toolbar button, the
option on the Post menu, or the associated keyboard shortcut:

2. Enter an address.  For Usenet messages, Agent automatically inserts
the currently selected group in the Newsgroups field.  For email (except
follow-ups), you enter an address in the To field.

If the address you want is in your Agent Address Book, just press 
(the Pick Address button) on the Composition window and select the
address from the list.

For information
about the types
of messages
you can send,
see page 112.

See "Selecting
an Address" on
page 124
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3. Enter the message subject (new messages only).  Enter a brief
description describing what the message is about.  When composing
replies, Agent automatically inserts the subject for you, prefaced by
"Re:", indicating that it's a reply (see the example below).

4. Enter the message text.  In the Text box, type the body of your
message.

5. Add any attachments.  Press the  button and use the
Attachments dialog box to attach the file (e.g., a GIF image) to your
message.

6. Send the message.  You have the following options:

• Send Now  , Ctrl+N, or Message→Send Now

• Send Later  , Ctrl+L, Message→Send Later

Note:  To save the message without sending it, either press ,
type Ctrl+S, or select Message→Save.

Types of Messages You Can Send

There are eight types of messages you can send.  To open each type of
Composition window, select the option on the Post menu, the toolbar button,
or the keyboard shortcut, whichever is easiest.

New Usenet Message is used to create a new message to post in the currently selected
newsgroup.  Agent automatically inserts the newsgroup name into the Newsgroups field.

Toolbar button:
Keyboard option: P
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Follow-Up Usenet Message is used to create a response to the currently selected news
message.  Agent automatically inserts the group to which you're posting the response and the
subject, prefaced by "Re:" to show that it's a response.

Toolbar button:
Keyboard option: F

New Email Message is used to create a new email message.

Toolbar button:
Keyboard option: Ctrl+M

Reply via Email is used to reply to the selected email message.  Agent automatically inserts the
address and the subject, prefaced by an RE: to show that it's a reply.

Toolbar button:
Keyboard option: R

Reply to All, is used to post a reply to each of the recipients of the original message.

Toolbar button:
Keyboard option: Shift+R

Forward Quoted is used to create an email message which contains the text of the currently
selected message.  Agent automatically inserts the lines of original text preceded by the quoted text
marker (e.g., ">"), as well as the subject preceded by "[fwd]", so the recipient will know that it's a
forwarded message.

Toolbar button:
Keyboard option: Alt+P+W

Forward Unquoted is used to create a new email message which contains the text of the
currently selected message.  Unlike Forward Quoted, though, the text is not preceded by the quoted
text marker.  Agent automatically inserts the subject preceded by "[fwd]", so that the recipient will
know that it's a forwarded message.

Toolbar button:

Keyboard option: Alt+P+N

Forward Verbatim is used to create a new email message in which the selected messages are
attached to it.  Agent automatically inserts the subject of the first of the selected messages.

Toolbar button:

Keyboard option: Alt+P+V

Note:  For any of the Forward options, you can change the "[fwd]" indicator in the Subject field, on
the Options→Posting Preferences→General tab.
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_____________________________________________________________

OO By default, whenever you select a Reply or Forward option, Agent
will include the text of the original message in the Text: portion of
the Composition Window.  This is called “quoting” the original text.
However, if you select a portion of the text in the original message,
Agent will include only this selected text in the new Composition
Window.

When quoting text in a Reply or Forward operation, Agent will strip
everything after the last occurrence in the quoted text of “--” or “-- “
(there’s a space at the end of the second item).  Agent does this so
you won’t quote long signatures, quoting instead only the text of the
message.  See p. 191 (Signature Delimiter) for more information on
this feature, including information on how to deactivate the feature.

_____________________________________________________________

You'll find that the Composition windows for these different message types
are quite similar.  Below is a new Usenet message Composition window.

And here's what the Composition window looks like for a new email
message.
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Fields
There are a number of different fields you can use in the Composition
window other than the default fields To, Newsgroups, Subject so that your
message is targeted exactly the way you want it to be.

To show all available fields on the Composition window:

Press , or you can use the keyboard shortcut Ctrl+D or the Message→All
Fields option.  Use the method that's easiest for you.

Below is the Fields list that displays in the middle of the Composition window
and a description of each type of field.  To set or choose the value for any
field, highlight the field, then enter the desired value in the Value for <field>
entry box.

Note:  Check the Use Defaults box if you wish to use the default value that
has been defined on the Group→Properties→Post tab.  Checking this box
can be helpful if you change the value for a field and later decide to revert
back to its default value.



Chapter 5

116

Bcc - A list of email addresses (separated by commas) of people to receive a copy
of the message without the primary recipients (the ones listed in the To and Cc
fields) knowledge.  If you enter a value for this field when posting a message, it will
cause Agent to also post an email message to the specified recipients in the To
field.

Cc - A list of email addresses (separated by commas) of people to receive a copy of
the message.  If you enter a value for this field when posting a message, it will
cause Agent to also post an email message to the specified recipients in the To
field.

Distribution - (Usenet messages only) This field controls how widely the message is
distributed.  For example, a distribution of "california" might limit the distribution of
the message to news servers residing in California.  To make the distribution work
correctly requires the cooperation of the Internet Service Providers (ISPs) who
manage news servers, and it has never been widely adopted.  You might want to
consult with your ISP about how it might be used at their site.

If multiple areas are listed, they must be separated by commas (similar to the
Newsgroups field).  User subscriptions are still controlled by the Newsgroups field,
but now, in addition to the specified newsgroups, there is a second variable:  the
Distribution range.  The message is sent to all systems subscribing to the
newsgroups within the specified Distribution range.

For the message to be transmitted, the receiving site must normally receive one of
the specified newsgroups AND must receive one of the specified distributions.

For example, a message concerning a car for sale in New Jersey might have
headers including:

Newsgroups: rec.auto,misc.forsale

Distribution: nj,ny

so that the message about the car for sale would only go to persons subscribing to
rec.auto or misc.forsale within New Jersey or New York.

A follow-up message should default to the same "Distribution" line as the original
message.

Expires - (Usenet messages only) The date you want the message to expire.
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Followup-To - (Usenet messages only) The newsgroups where you want follow-up
messages posted.  Note: You can set this field to "poster", which forces users to
post email replies to you.

From - The email address and optional full name of the person who posted the
message or sent the email.

Keywords - Optional keywords to help categorize the message or email message.

Organization - (Usenet messages only) Your company, school, etc.

Reply-To - The email address where you want replies sent.  If you normally want
replies sent to your From email address, you can leave this field blank.

Sender - The name of the entity responsible for submitting the message or email
message to the network.  Normally, this field is blank, to indicate that the From field
also names the submitting entity.  For example, if Rennie Kent is visiting George
Mitchell and wishes to use his computer to post an email message, George would
temporarily set his Sender field to his own email address and set the From field to
Rennie's email address to indicate that the messages are being submitted by
George on Rennie's behalf.

Summary - (Usenet messages only) An optional summary description of the
message.

To - The email address and the optional full name of the person to whom the Usenet
message or email message will be sent.

Signatures
A signature is one or more lines of text that Agent automatically places at
the bottom of news messages and email messages that you send.  When
you create a new message, you can select from a list of defined signatures
to best fit the type of message you're composing.  For example, you can
define a “personal” signature and a different “business” signature.
_____________________________________________________________

OO You can define as many signatures as you wish.  We suggest you
choose the most frequently used signature as the default.

_____________________________________________________________

To insert a signature into a message:

There are two ways to insert your signature into a message.

• Select the signature from the Signature: dropdown list on the
Composition Window.  Agent will automatically append the selected
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signature to the end of the message.  This signature will not appear in
the Composition Window, but is appended when the message is sent.

• While composing a message, select Edit→Paste Signature, then select
the desired signature from the Paste Signature dialog.  The signature
will be added at the insertion point in your message.  This method has
the advantage that you will see exactly how your signature will appear in
the message.  When you use this method, Agent will not automatically
append the signature indicated in the dropdown list in the Composition
Window.

To create a signature for a posting:

Select the Options→Posting Preferences→Signatures tab to view the
following settings:

Complete the settings on the Signatures tab, described as follows:

1. Names - Each name listed in this box is a signature you've added using
the Add Signature dialog box (see step 2).

2. Add - Press this button to display the Add Signature dialog box and add
a new name to the Names list.
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3. Rename - Press this button to edit the name currently highlighted in the
Names list.

4. Delete - Press this button to delete the name currently highlighted in the
Names list.
__________________________________________________________

OO If you accidentally delete a signature, press the Cancel button to
close the dialog box and cancel all of your changes.

__________________________________________________________

5. Default Signature - Select the signature you wish to use by default.
Select [None] if you do not want to have a default signature.  When you
post a message or send an email, Agent automatically uses your default
signature.  You can choose a different signature to be the default for
each group or override the signature used for a specific message, using
the Signature list in the Composition window.

Note:  Changing the default signature also changes the signature setting
on the Group→Properties→Post tab.

6. Text - Enter any text that you want to appear with the currently selected
name in the Names list.  If you want a separator to appear between the
rest of the message and the signature, you need to include it here.  A
common convention on the Internet is to begin your signature with a line
containing two dashes (followed by a space), as shown below:

--<put one space here, no brackets>
Mark Prince
Forté Support

7. Use Existing File - If you want to share a signature file from another
program, enter the name of the file containing the signature.  After
entering a valid filename, the dialog will display the contents of the file in
the Text field (step 6).

Note:  Any changes you make to the signature in this dialog box will be
saved to the file, so changes here also affect any other programs using
the same file.

8. Browse - Press this button to browse for a signature file.

Address Book
With the click of your mouse, you can open Agent's Address Book, where
you can list all of your frequently used email addresses.  This saves you
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from having to remember the details of email addresses.  Just use a name
(or alias) in place of the address and Agent will fill in the details for you.

To open the Agent Address Book:

Select Window→Open Address Book and the Address Book window will
display.

This Address Book Window contains:

• A list of names (or aliases) that you can use when composing messages.

• The true email address associated with the currently highlighted name.

• Comments (optional) describing the currently highlighted name.

• An optional Field Text field for use with mailing lists (see page 123).

To create and manipulate the names in the address book, select from the
options in the Address menu or the toolbar buttons.

Using the Address menu

You can either select Address from Agent's menu bar (the Address Book
must be open), or you can place the cursor in the Names section of the
Address Book and click the right mouse button.
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Select this
option...

...to do this

New create a new name and address.

Rename change an existing name.

Delete remove the selected name and address from the Address Book.

Save Save any changes to a name or address.

Reset reset the addresses and comments for the current entry if it was
modified and you wish to return it to its original state, without
saving the changes.

To, Cc, Bcc append the name of the selected entries to the Composition
window.

Note:  Holding Shift while selecting this option tells Agent to add
the entry's addresses instead of names.  Pressing Enter or
double-clicking a highlighted name is equivalent to selecting the
To option.

Check Addresses have Agent check that syntax of an address entry to ensure that
it's structure is valid..

Confirm Edits/
Confirm Deletes

have Agent ask you each if you want to change or delete an
address each time you attempt either of these actions.

Expand Addresses expand an address to its full address format when it is inserted
into a Composition window via the Address Book window or Pick
Addresses dialog box.

To add a new entry to the address book;

• For any address you use frequently - select Address→New when the
Address Book window is open.

• For authors of an existing message - highlight the message written by
the author, then select Message→Add Author to the Address Book.  The
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address from the message will automatically populate the Address field.
If the email address includes the author's name, Agent will use that to fill
in the Name field.  You can optionally enter comments.

In both instances, the New Address dialog box will appear.  Below is an
example of the dialog box when it is completed.

Creating Mailing Lists

The New Addresses dialog box can also be used to create a mailing list.  A
mailing list is addressed to the name you give to the mailing list, rather than
to an entire listing of the recipients.  This saves space and at the same time
maintains the privacy of the recipients.  Here's how this works:

1. Name - Enter a name for this mailing list (e.g., Multiple recipients of list)
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2. Addresses - Enter the email address of every recipient in the mailing
list, separated by a comma or carriage return.

3. Field Text - Enter a valid email address in Field Text.  Based on the
example, you might enter the following:

"Multiple recipients of list <multilists@acmeinc.com>"

This is what recipients will see in the To field on the message they
receive.  If you don’t define any field text, then all recipients will see the
email addresses of all other recipients.  Field text allows you to hide the
list of names, so each recipient sees only what you have entered as field
text.

Note:  The Field Text value should be a valid email address, since it will
appear in the message in a header field that is normally expected to
contain a valid address.  Some email systems may reject your message
if it contains a field with an invalid email address.

You may want to use the address to which recipients on your list should
send replies.  For example:

My mailing list <reply-here@my.company.com>

_____________________________________________________________

OO If you want to combine several address book mailing lists and show a
single address in the To: field, you can specify the single address as
the Field Text value for one of the address book entries and make all
the others blank.  To make these address entries blank, enter one or
more spaces for the Field Text.  Agent replaces the entry with nothing.

Important!  If you are using the Expand Addresses feature in the
address book when selecting your mailing list entry from the address
book for use in a message, Agent inserts all of the addresses from the
list into the message and DOES NOT use the value for Field Text.
Agent will warn you when this is about to  happen, to verify that you
really want to expand the addresses.

_____________________________________________________________

Finding an Address

If you have a name in mind that is out of view on the Names list, you can
jump directly to the name by using the Find option.  Select Edit→Find and
the Find Address dialog box will appear.
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Depending on what you wish to find, you can search on any one of the
components found in the Address Book Window, including Name, Address,
and Comments.

For example, if wish to find the primary travel agent used by your company,
but do not know the name or address, you would simply check the
Comments box and enter travel agent in the Find What entry box.  Now
press the Find First button and Agent will jump to the first occurrence of
"travel agent".

Note:  For multiple occurrences, press the Find Next button until you arrive
at the desired name.

Selecting an Address

When composing new messages, you can select one or more names from
the Address Book to automatically insert into any one of the following
address fields on the Composition window:

To

Cc

Bcc

The procedure for picking addresses is simple.  Here's how it works.

 To pick addresses:

Press the Pick Addresses button  on the Composition window, which
displays the Pick Addresses dialog box.  All the names listed are those that
have been defined in the Address Book window.
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Note:  Because the Pick Address button is right on the Composition window,
this is probably the easiest way to open the Pick Address dialog box, but
there are two other equivalent methods:

Menu option: Message→Pick Addresses

Keyboard shortcut: Ctrl+K

Use the options on the Pick Addresses dialog box as follows:

1. Names - Select the desired names from the Address Book that you want
to insert in the address field Composition window.
__________________________________________________________

OO Type the first few letters of a name to rapidly skip to that name.
__________________________________________________________

2. To/Cc/Bcc - Press any of these three buttons to append the selected
name(s) from the Names list to the To, Cc, or Bcc field on the message
Composition window.
__________________________________________________________

OO Holding Shift when you press the To, Cc, or Bcc button copies the
addresses in these respective fields instead of the names.
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Also, double-clicking a name is equivalent to pressing the To
button.

__________________________________________________________

3. Find - Press this button to bring up a Find dialog box to find a name
which is out of view on the Names list.  This can be handy if you've
created a long list of names.

4. Edit - Press this button if you want to edit the selected name in the
Names list.  The Address Book window will open, positioned on the
selected name.  From here, you can edit the name using the options on
the Address menu.

5. Comments - The description for the highlighted name defined in the
New Address dialog box.  This read-only descriptor helps you verify that
you've found the right name.  To change it, you can press the Edit button
to jump to the Address Book window.

6. Expand addresses - This option applies to Usenet and email messages
you are sending.  Check this box to cause Agent to insert the actual
email address(es) for an address book entry, rather than the name of the
entry (e.g., amya@acmeinc.com, rather than Amy Anderson).

Address Validation

Agent has a validation feature allowing you to ensure that an email address
you've entered has used a valid format.  When validating an address, Agent
looks for these required address components:

• the characters that identify to whom the message is being sent

• the "@" symbol

• the domain suffix (e.g., a commercial company's name is followed by
the extension .com, or a school's name is followed by the
extension.edu.)

Here's an example:

mkaplan@acme.com

There are times when using a "local" address is also valid.  If your service
provider is set up to handle "local" addresses, you can simply address a
message to the person's name.  So instead of mkaplan@acme.com, you
can simply enter mkaplan as the addressee, as long as Agent is also set up
to recognize the local address as valid.

To help Agent tell a local address from an Address Book entry:
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Select the Options→Posting Preferences→General tab.  Then check the
option Require that local addresses be in Address Book.  Agent will then
warn you whenever you've entered an address without the "@" character
and Agent could not find it in the Address Book.  Unchecking this option
forces Agent to assume that the entry is a local address.

To check the validity of an address:

Any of the actions below will trigger this process.

• Press the Send or Send Later buttons on the Composition window (if the
Validate email addresses box is checked).

• Select Message→Check Addresses when a Composition window is
open.

• Save an entry in the Address Book Window.

• Select Address→Check Addresses when an Address Book window is
open.

• Press the OK button on the Add Address dialog box.

• Press the Check Addresses button on the Add Address dialog box.

Address Expansion

When Agent prepares to send a message, it scans the contents of the To,
Cc, and Bcc fields to produce a complete list of recipients with fully
expanded addresses.  For each name from the Address Book that Agent
finds, it substitutes the true address found for that name.

_____________________________________________________________

OO Agent checks for circular references in an address book.  If an entry is
found a second time, Agent simply will skip over it.

_____________________________________________________________

Importing Addresses

If you have an address book in another program, Agent can import these
addresses so you don't need to manually re-enter them in Agent.  The
addresses must be converted and saved to a file that Agent can then import.
To convert data, use the conversion command for the existing type of
address book.  See the .txt file for each converter for details.  (Converters
are available from the Forté ftp site, ftp.forteinc.com/pub/converters.)  To
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import addresses, select File→Addresses→Import flyout and specify the
path and name of the file containing the addresses you wish to import.
_____________________________________________________________

OO It's recommended that you use the ".txt" extension for the <output
filename> part of the conversion command.

_____________________________________________________________

Attachments
There may be times when you wish to include a graphic file or other type of
attachment with your message.  Agent makes it very easy for you attach any
type of file (e.g., a GIF image) to your message.  Here's how:

To attach a file when composing a message:

Press the Attachments button to display the Attachments dialog box.  Then
press Add and specify the path and name of the file you want to attach, as
shown in the example below.

More About Text
With Agent, you can adjust the text in your composed messages to ensure
that the recipient views the body exactly as you intend it to be viewed,

For more
details about
attachments,
see Chapter 6,
"Using
Attachments.”
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according to the type of system the recipient is using.  This section highlights
the different settings Agent provides for controlling how the text in composed
messages appears.  For more details about how message text is viewed,
see Chapter 4, All About Messages and Chapter 8, Customizing Agent.

Composition Options

Agent is pre-configured so that you can compose and send messages
seamlessly with a minimum amount of effort.  Normally, all you need to do is
compose your message and press the Send Now button.  In certain
situations, however, you might want to modify Agent's default posting
preferences if you know that the program being used by the recipient
requires specific adjustments to view a message properly.  Here's what to
do:

To specify different posting preferences:

Select the Options→Posting Preferences→General tab.  Below are the
default settings that will display.

You can modify any of these settings, as follows:



Chapter 5

130

1. Word-wrap quoted-printable messages - Check this box to have
Agent word-wrap all "quoted-printable" messages.  Uncheck this box to
turn off the word-wrap function.

2. Line Length - Enter the maximum number of characters that can
appear on a single line.  Agent will word-wrap any lines longer than this.

3. Validate email address - Check this box if you want Agent to validate
all email address fields (e.g., To:, Cc:, Bcc) before sending messages.
Uncheck this box if you need to enter non-standard addresses.

 Note:  Agent does not verify that the email address exists.  It simply
checks the format to make sure it is a valid Internet email address.

4. Require that local addresses be in Address Book - "Local addresses"
are handy for sending email to people in your own "domain", such as a
company's computer network.  But Agent can't necessarily distinguish
between a local address and the name of an Address Book entry.

To help Agent, check this box and Agent will warn you if it can't find a
local address in the Address Book.  Then you can either correct the
address if it's misspelled, or tell Agent to assume that it's a local
address.

If you uncheck this box, Agent assumes an address is local if it doesn't
include the "@" character and it is not in the address book.

_____________________________________________________________

OO Most of the time, you'll probably want to leave this option checked.  If
you ever want to force Agent to assume that an address is a local
address, you can simply append "@" to it (e.g., gbrown@).

_____________________________________________________________

5. Saving message also Closes Composition window - When you
check this option, pressing the Save button on the Composition window
also closes the window.  When unchecked, pressing the Save button
saves the message, but does not close the Composition window.

6. Follow-up crosspost action - Tell Agent what to do each time you post
a news message to more than one group.  Your choices are as follows:

• Post the reply to all newsgroups

• Post the reply to selected newsgroups only

• Prompt you each time you post a reply, so that you can choose an
action on a case by case basis.
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7. Include original text in follow-ups and replies - Check this box to
include a copy of the original text in follow-up messages and replies.

8. Prefix for quoted lines - For follow-up and reply messages, enter the
character(s) that precede quoted text (as a distinguishing device).

9. Quoted - This is the string that appears in the Subject field of your
forwarded message if you select Post→Forward Quoted.

10. Unquoted - This is the string that appears in the Subject field of a
forwarded message if you select Post→Forward Unquoted.

11. Verbatim - This is the string that appears in the Subject field of your
forwarded message if you select Post→Forward Verbatim.

_____________________________________________________________

OO The default string for settings 9, 10, and 11 is "[fwd]%subject%".  The
"[fwd]" part of the string indicates that it is a forwarded message.  You
can change this to anything you like (e.g., "forwarded msg.").

The "%subject%" token represents the subject of the original
message.  Agent replaces "%subject%" with the actual original subject
when you compose the new message.  In place of the "subject", you
can use any valid field name and the value for that field will be
inserted.

_____________________________________________________________

Pasting Text as Quoted

There may be times when you are composing replies to a message and you
would like to quote certain portions of the text from the original message.
With Agent, you can accomplish this in two steps.

To paste text as quoted text:

1. Select the portion of text that you want to insert as quoted text, then
copy the text, using one of the following equivalent methods:

Toolbar button:   (Composition window toolbar)

Menu option: Edit→Copy

Keyboard shortcut: Ctrl+C
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2. Open a new Composition window and place the cursor in the Text box.
Then use one of the following equivalent methods for pasting the quoted
text into the new message:

Toolbar button:   (Composition window toolbar)

Menu option: Edit→Paste As Quote

Keyboard shortcut: Ctrl+Q

Each line of the pasted text is prepended by the quoted text character
defined on the Posting Preferences General tab (Options menu).  For
example:

> Ask not what your country can do for you.

> Ask what you can do for your country.

Spell Checking

Agent will check the spelling of any message you compose.  When you first
install Agent, the American English dictionary is used as your default spell
checker.  However, you may also download a number of alternate language
dictionaries when you download Agent files from Forté's FTP to install the
program for the first time.  The ftp address is:

ftp.forteinc.com/pub/dictionaries

For each language, there is a TLX file (general dictionary) and a CLX file
(custom dictionary to which you can add words not in the general dictionary).
Unzip the appropriate zip file in your Agent directory.  The choices are:

• engamer.zip  (American English)

• engintl.zip  (International English)

• french.zip  (French)

• german.zip  (German)

• italian.zip  (Italian)

• spanish.zip (Spanish)

To spell check a message you've composed:

Either select Message→Spelling or press F7.

To specify a different dictionary for spell checking:
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1. First, make sure that the correct spell checker is defined for the selected
language.  Select the Options→General Preferences→Languages tab.
On this tab, select the language, then select the spell checker for that
language.

2. Now make this language the default language.  If you want to use this
language (and its spell checker) for all groups and anytime you compose
an email message, select this language on the Group→Default
Properties→Language tab.  If  you want to use this language only for
selected groups, select these groups and use the
Group→Properties→Language tab.

3. To use a different dictionary to check a message you’re composing,
open the Message→Properties dialog and select the desired language.

More About Sending
This section takes you beyond the basics of sending a message, as
described in the Overview, and explains various preferences and options
available to you when sending messages.

Setting Format Preferences for Sending

Agent allows you to specify the format for messages you're sending.  There
are two formats in which you can send message text:  "quoted-printable" and
"7bit / 8bit".  You can decide which format is most appropriate for your
Usenet messages and email messages.

Quoted-printable supports international characters (e.g., accents) via the
mail transfer standard "MIME" (Multipurpose Internet Mail Extensions).

7bit / 8bit text encoding is the other type of text encoding commonly used
when posting messages on the Usenet.

_____________________________________________________________

OO When sending messages to recipients with MIME-capable systems,
quoted-printable is the best way to format your messages.  You never
have to worry about paragraphs being chopped off at odd places.

If you're sending messages to recipients with non-MIME-capability
(e.g. users of America Online) or if you're posting to newsgroups
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where quoted-printable isn't yet the accepted standard, 7bit / 8bit is the
best format to use.

_____________________________________________________________

Advantages of quoted-printable vs. 7bit / 8bit formatting:

If you know that the message recipient's system is MIME-capable, that's the
ideal situation.  MIME is the internationally recognized standard for
transferring data.  Quoted-printable (MIME) has a few distinct advantages
over 7bit / 8bit formatting:

• Quoted-printable prevents transferal problems.  It uses only 7 bits to
encode 8-bit characters, which helps to ensure that information won't be
lost when messages are transferred via 7-bit gateways.

• Quoted-printable correctly encodes non-ASCII characters (such as
accents and other characters used in different languages).

• Quoted-printable allows lines of text to be arbitrarily long.  It
automatically inserts invisible line breaks where necessary to keep the
physical line lengths within the viewer's prescribed limits.

To set your general preferences for formatting:

1. Select the Options→General Preferences→Languages tab.
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2. For each language in the Languages list, select either 7bit / 8bit or
Quoted printable (MIME) as the format for Usenet and email text.

To override the default format for individual messages:

1. While in the Composition window, select Message→Properties to open
the Message Properties dialog box.

2. Select the language for the message (if it is other than the default), and
check the box Override default settings, as shown in the example below.

3. Select the desired format for the message body, either 7bit / 8bit or
Quoted printable (MIME).

Word wrapping preferences:

One of the advantages of quoted-printable is that lines of text can be any
length.  If you've set your preference as quoted-printable, Agent treats the
message text as one long line of text.  It inserts invisible line breaks where
necessary so that the lines always appear correctly within the window in
which the message is viewed.  A message text in 7bit /8bit format, wraps at
the line length specified in Agent's Posting Preferences.

To set the line length at which message text is automatically wrapped:

Select the Options→Posting Preferences→General tab.  In the Line Length
entry box, specify the maximum number of characters per line.  Note that
only unquoted lines are wrapped.  Quoted lines (for example, when replying
to or forwarding a message) are not wrapped when sent, regardless of the
setting on this tab.
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To word-wrap messages:

Choose from one of the following options for wrapping the text of a message
you're composing.

Toolbar button:

Menu option: Message→Word Wrap

Keyboard shortcut: Alt+M+O

The text in the Composition window will be wrapped to fit the size of the
window.
_____________________________________________________________

OO This wrapping is for your display only.  When the message is sent,
each line is wrapped at the value defined in the Posting Preferences
dialog box.  If the screen is wide enough, you’ll see the message as it
will be sent.  If the screen is not wide enough and you want to see
what the message will look like when sent, turn off word wrapping in
the composition window.

_____________________________________________________________

Checking a Message's Status

The Outbox is a temporary place where messages are kept until they are
sent.  The composition commands Send Later and Save store messages in
the Outbox.  Also, by default, the Send Now command stores outbound
message in the Outbox.  In all cases, you can use the Outbox to check a
message’s status after sending.   However, it is recommended that you keep
successfully sent messages in folders rather than the Outbox.  See below for
how to do this.

To Open the Outbox:
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Select Window→Open Outbox.  The Outbox window shows a record of all
saved, pending and sent messages and their status (see example below).

Icon Description

red sad face

A problem occurred when this message was sent.  Double-click
the message to make sure all the fields were completed correctly.
Then press the  Send Now or  Send Later button to re-send the
message.

yellow happy face
The message was successfully sent.  This icon may never
appear in the Outbox folder if you've set up Agent to automatically
route specific messages to specific folders.

The message is queued for uploading (i.e., you pressed the Send
Later button after creating a message).  To send the message
now, select Online→Post Messages and Emails.

The message is in the process of being sent.

To file a sent message in a folder:

You can move messages manually, or (recommended) have Agent
automatically route messages to the folder of your choice when they are
successfully sent.  By filing messages in folders you can use the features of
folders (sorting, printing, views, and resending copies of messages) which
are not available in the Outbox.

To copy or move the message into a folder, open the Message→Copy to
Folder or Message→Move to Folder flyout menu and choose a folder.  If you
copied the message to a folder, it will now appear in the Outbox and in the
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selected folder.  If you moved the message into a folder, it will no longer
appear in the Outbox, but will now appear in the selected folder.

To have Agent automatically file your sent messages, select the desired
folder from the File sent Messages in folder: list on the
Group→Properties→Post tab.  You can also file a composed message
simply by showing all fields on the Composition window and selecting the
desired folder from the Filing drop-down list.

Re-sending Messages

As described above, messages you send can be saved in the Outbox or in a
folder.  Re-sending messages depends on where they were filed.

 To re-send email from a folder:

1. Make sure the sent message was filed in a folder, not the Outbox.

2. Highlight the message from the folder listed in Message List pane.

3. Choose Post→New Copy of Message.

4. (Optional)  Change the message as required (e.g., change the recipient).

5. Press Send Now or Send Later to transmit the message.  In the folder
you will have both the copy of the original message and the new copy of
the message just sent.

To re-send email from the Outbox:

1. With the message selected in the Outbox, choose Message→Open.

2. (Optional)  Change the message (e.g., enter a different recipient).

3. Press Send Now or Send Later to re-send the message.  Agent will
display a message saying the message has already been sent, and asks
if you want to send it again.  Press OK to re-send.  Note that you will
only have the new copy of the sent message, replacing the original
message in the Outbox.

Canceling Usenet Messages

There may be a time when you will want to cancel a message that you
posted to a newsgroup, realizing that it should never have been sent.  Agent
allows you to cancel any Usenet messages you have posted, but not those
posted by other people.
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Using Agent's cancel option, a request is posted to your news server to
delete the selected message.  This same request is also passed along to
other Internet news servers so that they can delete the message as well.

To cancel a message:

1. Highlight the message header you want to cancel.

2. Select Post→Cancel Message.

____________________________________________________________

OO "Crossposted messages" only need to be canceled from one of the
crossposted groups.

_____________________________________________________________

3. In the Compose Usenet Message window, press Send Now or Send
Later to transmit the message to your news server.  You should not
make any other changes to the message.

After sending the cancel request, the message will continue to appear in
Agent until it is automatically purged or you delete it.  Since some servers do
not accept cancel requests, you may want to verify that the posting was
actually deleted.

To verify that the message was deleted:

1. Highlight the message header you canceled.

2. Delete the message’s body by selecting Message→Delete Body.

3. Try to retrieve the message’s body again by selecting Online→Get
Selected Message Bodies.  If the cancel request was accepted, the
Message Body Not Available icon  will appear next to the message.

Using MAPI

MAPI is a Windows standard defining how Windows programs send email.
You can set up Agent to send email using MAPI if you're using Agent for
reading and composing messages, but you want to use your corporate email
system for sending messages.

To set up Agent to use MAPI:

1. Select the Options→User and System Profile→System tab.
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2. Select the option Send email messages with MAPI.

Note:  You must have a MAPI enabled mail system online for this option
to be available.  Otherwise the option will be grayed.

Selecting the Send email messages with MAPI option causes the following
things to happen:

• Agent uses the MAPI Send Message window rather than the message
Composition window.

 Note:  The addresses and message body are initialized as appropriate,
but once the MAPI window has been opened, Agent no longer has
control over the message.  The sent message is saved in your MAPI
email system, not in Agent's Outbox or folders.

• The Forward Verbatim option is disabled.

• Your signature is not appended to email messages.  Instead, you must
use whatever signature mechanism is provided by your MAPI system.

• On the Group→Properties→Post tab, the Copy follow-up messages to
author via email options is disabled.

• There is no facility for sending a message as both a news message and
an email message.  For example, Agent ignores the "To:", "Cc:", and
"Bcc:" fields in news messages.

Agent will not send any pending email messages that may have been
stored in your Outbox prior to enabling MAPI email.  You should be sure
to send any pending messages via SMTP prior to enabling MAPI email.
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CHAPTER 6

Using Attachments
There may be times when you need to send or receive information that cannot be contained
in a simple text message.  For example, you might want to view a picture or hear a sound
that has been posted to a newsgroup.  Or you may want to send a word processor file or
spreadsheet file to a colleague or friend.  To do this, you need to use file attachments.  In
this chapter we’ll discuss how Agent allows you to send and receive attachments,
streamlining things for the casual user while allowing the “power user” full control when
handling attachments.

This section will cover the major points in using file attachments.  Refer to Agent’s Online
Help for full details.  For those of you who want a quick overview of how to view
attachments, you may want to jump ahead to the section, “Example: A Way to View
Attachments” on page 160.

The topics in this chapter are:

1 Some Basic Concepts

1 Retrieving Messages With Attachments

1 Saving Attachments

1 Sending an Attachment

1 Message Digests

1 Example:  A Way to View Attachments

Some Basic Concepts
The first thing you should know is that, for most users, Agent will take care
of attachments automatically for you.  You don't really need to know or do
anything special to use this feature.  Refer to the sections, "Retrieving
Messages with Attachments" and "Sending an Attachment" in this chapter
for simple steps you can follow.
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If you want to dive into the details of working with attachments, you should
become familiar with some terms that are used.  Don’t be intimidated by all
this...it’s really pretty straightforward.

Encoding and Decoding

Email and news messages are transmitted across the Internet as text
messages.  Unfortunately, many of the files on your computer (e.g.
spreadsheets, or pictures) are not text files.  Before these files can sent they
must be changed into a text representation.  This transformation of
computer, or binary, information into text is called "encoding".  Similarly,
when you receive an encoded message, it must be changed back into binary
information, using a process called "decoding".

UUEncode and UUDecode have been the most widely used methods of
encoding and decoding binary information.  More recently, methods
associated with the MIME (Multipurpose Internet Mail Extensions) standard
have begun to replace UUEncode and UUDecode.  While there are certain
advantages to using MIME over UUEncode/UUDecode, it really doesn’t
matter which you use, as long as the person on the receiving end has an
application which can process the information correctly.  Agent is such an
application, determining which encoding method has been used and
performing the appropriate decoding operation to receive the attachment
correctly.  As a general rule of thumb, newsgroups still use UUEncode /
UUDecode for handling binary attachments, while most email messages are
now sent using MIME for attachments.

For reading messages, Agent supports UUDecode, Base64, and
AppleDouble formats.  For sending messages, Agent supports UUEncode
and Base64 encoding.

Multipart Attachments

Binary files can be quite large, often too large to be sent as part of a single
message.  This means it’s quite common in working with attachments that
more than one message will be used to transmit a single attachment.

Typically the subject line of a message will tell you if the message is part of
a multi-part attachment.  For example, you might see something like [1/2]
(or [2/2]) to tell you that the message contains part 1 (or part 2) of a 2-part
attachment.

See how to
control the
encoding
format when
sending
messages on
page 157.

See page 153 for
details about
receiving and
sending multipart
attachments.



Using Attachments

151

MIME Types

The MIME standard defines attachments to be of specific types, according
to their use.  Casual users of Agent need not be concerned with the various
types and what they mean, as Agent will handle things automatically for
you. To work with MIME types in Agent, select the Options→General
Preferences→MIME Types tab.

Launching an Attachment

Simply retrieving an attachment may not be enough to examine its contents.
If the attachment is a spreadsheet, you’ll need to read the file using your
spreadsheet application.  If it’s a picture, you’ll need to use a viewer.  The
process of using an application to view the file attachment is called
"launching" the attachment.

By default, Agent will use your Windows registry settings to determine which
application should be launched for this attachment.  After retrieving a
message with an attachment, if you look in the body pane, you’ll see the icon
for the application which will be used.  You can override the Windows
settings by using the Options→General Preferences→MIME Types tab.

For details
about Agent's
preconfigured
MIME types,
see the online
help.
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To override the Windows default settings:

1. Highlight the MIME type for which you want to change the application.

2. Make sure all extensions for this type are listed in the Extensions box.

3. Enter the pathname of the new application in the Application box (or use
the Browse button to find the application).

4. Click OK.

Saving an Attachment

An attachment is part of a message in Agent.  You can “detach” and save
each attachment as a file.  When saving the attachment, you can specify
whether Agent retains the attachment in the message or removes it.

Message Sections

The MIME standard allows a message to have several sections and the
sections can be of different types.  Each attachment you place in a message
is a separate section.  Each section can have its own "disposition" (i.e., the
way it is inserted in the message).  The disposition options are:

• Attachment - the section is appended to the message.  Typically this is
how you want to send an attachment.

• Inline - the section remains a separate attachment, however it may be
viewed within Agent, rather than through a separate program.

 Note:  Agent will only display inline text attachments.  To view image
attachments, you must first configure a viewer.

• Text insertion - the section is inserted as text directly into the message.

In the message body, if a text section has a content description, the
description appears in a title box above the section.  Otherwise, text sections
are preceded by a single horizontal line.  You can use the keys Alt+UpArrow
and Alt+DownArrow to navigate between the sections.

Message Index

Agent’s "message index" allows you to see all sections of a message in a
single dialog box.  It shows you the type, disposition, size, encoding method
and file status of each section, and it also displays the icon of the application
that will be used when launching the section.  You can view the index for any
message by highlighting the message and selecting Message→Index or by
typing Ctrl+I.  Here's an example.
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Retrieving Messages with Attachments
There really is nothing special to do when retrieving messages that might
contain attachments.  Email attachments are retrieved automatically as the
email is received.  When working with newsgroups, simply get headers from
the groups in which you’re interested.  Then scan the message list and
retrieve the bodies of the messages that interest you.  To control how Agent
retrieves attachments, use the Group→Properties→Receive Files tab.
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For common use, you'll want these boxes checked on the Receive Files tab:

• Detect Uuencoded files automatically

• Join multipart messages when retrieving headers

• Ignore fragments

Refer to the Online Help for complete details for all options.

Basic Retrieval Process

To retrieve and launch an attachment in a newsgroup:

1. Get new headers for the newsgroup.

2. Select any message in the message list.

Note: If you checked Join multipart messages automatically on the
Group→Properties→Receive Files tab, you’ll be selecting the joined
message.  If you did not configure the group for automatic joining, then
you must manually decode the attachment.  (See the procedure for
manually decoding an attachment below.)

3. Retrieve and/or view the attachment by selecting File→Launch
Attachment.  Alternatively, double-clicking the attachment will launch it if
you have checked the option Double-clicking launches attachments on
the Group→Properties→Receive Files tab.
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_____________________________________________________________

OO To help you distinguish messages with attachments from those without
attachments, Agent color codes the icons in the message list pane.

The envelope indicates email and the page indicates news messages.

   (white) Messages with plain text

   (yellow) Messages with attachments

   (green) Messages for which all attachments have been saved
_____________________________________________________________

You'll notice that a message with an attachment is generally much larger
than a simple text message.  In the Message List pane, you'll see the
number of lines in the message.  If you retrieve the message body, the
Message pane will tell you the size of the attachments in bytes.

Retrieving Multipart Attachments

By default, Agent is configured to automatically detect multipart attachments
and join them together into a single message.  For example, if Agent comes
across a two part message, it will join the two parts and place [*/2] in the
subject to indicate that a two part message was combined.

Note:  If all parts aren't available when you retrieve headers, the Incomplete
Attachment icon  appears in the Message List pane.  The Message pane
tells you what parts weren't available from the news server.

You'll find two settings for joining multipart messages on the
Group→Properties→Receive Files tab.  The initial configuration shows both
Join multipart messages options to be checked.

One reason you might choose to uncheck the option Join multipart
messages when retrieving headers is if your news server's feed is so slow
that sections of some multipart attachments are purged before all of the
sections have arrived.  By disabling auto-joining during header retrieval, you
can have Agent go ahead and retrieve the bodies for incomplete multi-part
messages and then you can join them later manually, described in the
following procedure.

To manually join a multipart attachment:
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1. Select all the messages that contain the attachment by clicking on one
message and then, with the Control key pressed, clicking on the
remaining messages.

2. Select Message→Join Sections.

3. Make sure the messages are in order.  If they aren't, use the Up and
Down buttons in the Join Sections dialog to order them in correctly.

4. Launch or save the attachment by pressing the corresponding button.  If
you are offline and have not yet retrieved the attachment's messages,
Agent will immediately go online to download and decode the
attachment.

Viewing an Attachment as Text

Sometimes you may receive a message as an attachment when it's really
just text, and all you want to do is read the text.  Usually this happens when
someone sends the text incorrectly or when another program formats
information in such a way that it is sent as an attachment.  In either case, the
solution is simple.  On the Options→General Preferences→MIME types tab,
simply check the boxes Display when Inline and Display when attachment
for each MIME type appropriate.  Agent will immediately display the text of
your message.

Saving Attachments
Agent allows for a lot of flexibility in deciding when and how attachments are
saved.  You can have Agent save attachments automatically or you can
save attachments manually.

Saving attachments automatically

You can set up Agent to save attachments automatically while retrieving
bodies or receiving email by checking Save attachments automatically on
the Group→Properties→Receive Files tab.  This approach is convenient if
you know you'll want to save all attachments as files, but downloading will be
slower, since Agent must save each attachment to a file and save it in the
message (at least temporarily), in case an encoding error is detected.
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Saving attachments manually

An alternate approach is to leave attachments in the message and save
them manually.  This method has the advantage of making downloads
somewhat faster and not cluttering your disk with files that you may choose
not to save.

There are two ways to save attachments manually:

• Select one or more messages, then select File→Save All Attachments.
Each attachment is saved with its filename as it appears in the Message
Index dialog box.  To ensure that Agent joins all the parts of multipart
attachments when saving the message, the option Join multipart
messages when saving or launching attachments
(Group→Properties→Receive Files tab) must be checked.

• Select a message, then select Message→Index.  The Message Index
dialog box will display (see p. 152), allowing you to view the message's
index and to save or launch individual sections.

Sending An Attachment
Attaching files to messages with Agent is easy.  Follow the steps below:

1. Create a new message (either news, or email).

2. Check the format of your message attachment.  You can control the
format for the attachments in your message while in the Composition
window by selecting Message→Properties to open the Message
Properties dialog box.  Under the Attachments heading, select either
UUEncoded or MIME from the Format list.
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You can also control the default options for attachments on the
Group→Properties→Send Files tab.  On this tab, you can define the
default format for both Usenet and email messages.

Using the same dialog (or tab) you can tell Agent how to handle large
attachments.  As a rule of thumb, Usenet message attachments longer
than about 500K bytes should be sent as multiple messages to make
sure all news servers can handle the attachment correctly.  However,
you should probably not break up email messages, as some email
programs may not be able to receive multipart attachments.

3. Attach the desired files.  In the Composition window, press the
Attachments button to display the Attachments dialog box.

Using the Attachments dialog box, you can add, and delete attachments.
For each file attached to the message, you can define placement
(disposition, i.e., how it is attached), give an optional description, and
specify its type, which Agent will usually determine automatically.

4. Add a text message (optional).  You can include a message along with
the attachment.  The message appears before the attachment. If you
include a message, Agent also includes your signature.

5. Send the message.  When you have finished creating a message and
are ready to send it, Agent will build the message in the following order:

a. Write the main body (text) of the message.
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b. Add any Insert in text body attachments in the main body, in the
order in which these attachments appear in the Attachments dialog.

c. Add the signature, if any.

d. Add all other attachments (i.e., all attachments which are not Insert
in text body) in the order in which they appear in the Attachments
dialog box.  On the Attachments dialog box, you can use the Up and
Down buttons to change the ordering of the attachments.

Note: Even if Insert in text body attachments are interspersed with other
attachments, all Insert in text body attachments are inserted as a group,
followed by all other attachments.

Message Digests
A "digest" is a group of messages with bodies which are combined into a
single MIME message of type multipart-digest.  Often newsletters are sent
this way, assembling their various parts into a single message.

Sending a Digest

To send a digest:

1. In the Message List pane, select the messages to include in the digest.

2. Select Post→Forward Verbatim.

If you already have a Composition window open, the Forward Verbatim
dialog box appears.  Just press the Append to selected message button
to attach the selected messages to the Composition window.

If you don't already have a Composition window open, Agent will
automatically open one and attach the messages to it.  Note:  In the
Subject field of the Composition window, Agent uses the subject of the
first of the selected messages.

3. Select Message→Properties to open the Message Properties dialog box.
Check the Override box, then make sure the Attachments Format: is
MIME and the option Send attached messages as a Digest is checked.

If the you want to add more messages to the digest, you can return to the
message list and select additional messages, choose Post→Forward
Verbatim, and append the messages to the existing outbound message.
When sending the message, Agent places the digest at the end of the
message, after all other attachments.
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Receiving and Bursting a Digest

Receiving a digest is as simple as receiving any other message.  All
sections of the digest are contained in a single message.  To see what's
contained in the digest, open the Message Index, either by selecting
Message→Index or press Ctrl+I.  From the index, you can see at a glance a
description of each section in the digest.  Highlight a section of interest, then
use the Go to option to view the text of that section.

If you like, Agent will create a separate message for each part of the digest,
a process known as “bursting” the digest.

To burst a digest:

Check the option Burst digests into separate messages on the
Group→Properties→Receive Files tab (see page 154).  The next time you
receive an attached digest, the digest will be broken into separate
messages.

Note:  After bursting a digest, Agent retains the complete original message
so that you can:

• access the message in its original form, in case something went wrong
with the bursting

• read any introductory text which might appear before the digest section.

• forward or save the entire original message

Also, when Agent bursts a digest, it places all the messages in the same
group or folder into which the original message is stored.  (Email filters are
not applied to the individual files as they are stored.)

Note: In order for Agent to burst a message or message section, it has to be
of type "multipart/digest".  A text message which happens to contain other
messages is not a digest and, thus, won't be burst by Agent.

Example:  A Way to View Attachments
This chapter will conclude with an example illustrating how you might use
Agent for viewing pictures found in any of the binary newsgroups (e.g.
alt.binaries.pictures.cartoons).  You’ll see how many of Agent’s
configuration options can be used to optimize viewing of attachments.

To tailor they way you view attachments to suit your needs:
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1. Make sure you have configured an application for viewing pictures.
(Although this is not specifically an Agent function, directions for doing
this are in Agent’s online help.)

2. Set properties for the group appropriately.  With the group selected,
choose the Group→Properties→Receive Files tab.  Then make sure
these options are checked: Detect UUEncoded files automatically, Ignore
fragments, Join multipart messages when retrieving headers, and
Double-clicking launches attachments, as illustrated below.

3. On the Group→Properties→Directory tab, make sure you have specified
the correct directory for saving attached files.
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4. Define a kill filter for this group.  Use a Skip filter, searching for
[*,99].  This will prevent most non-binary messages from being
retrieved, as it will skip any messages containing fewer than 100 lines.

5. You may want to sort the group by size, with the smallest messages at
the top (Group→Sort Messages by→Size).  This can be useful if you
have a slow connection, so you focus on the messages that can be
retrieved most quickly.

6. Define a view that does not show incomplete multipart messages, and
activate this view (Group→View Messages→Manage Views).

7. Go online and get new headers for this group.

8. Scan through the headers, select the messages you are interested in,
and retrieve message bodies for these messages.  Note that steps 4, 5
and 6 should have made it easy for you to scan through the message
list.

9. From the top of the group message list, hit the “B” key, and cycle
through the messages that have bodies.  For each one, double-click the
header (or press Enter) to view the attachment.

Note: if a message has more than one attachment, open up the
message index and launch each part individually.
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10. If you want to save the attachment, simply hit the “A” key (or right click
on the message and select Save All Attachments).
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CHAPTER 7

Agent and Other Applications
Agent is a fully integrated part of your Internet suite of products, allowing you to directly
invoke the application of your choice to process Internet URLs.  In addition, from Internet
Explorer and Netscape, you can use Agent as your email and news program.  Finally, you
can use Agent hand-in-hand with other newsreaders, or with other copies of Agent, through
the use of a standard newsrc file.

This chapter is broken into the following areas:

1 URLs in Agent

1 Using a Newsrc File

URLs in Agent

What is a URL?

A URL (Uniform Resource Locator) is an address used to locate a resource
on the Internet.  The format of the URL depends on the type of resource.
Here are some examples:

URL Type of address

http://www.forteinc.com World Wide Web address

agent-info@forteinc.com email address

ftp.forteinc.com FTP address

Here are the URL types that Agent recognizes:
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file: File news: Usenet News
ftp: File Transfer Protocol nntp: Usenet News
gopher: Gopher snews: Secure Usenet News
http: Hypertext Transfer
Protocol

telnet: Telnet

https: Secure Hypertext
Transfer Protocol

wais: Wide Area Information
Servers

mailto: Email Address

Displaying URLs

Agent highlights all URLs it encounters -- in header fields, in message text,
even in the Composition window as your create messages.  By default,
URLs appear green and underlined, but you can modify the style of
highlighting to suit your own taste.

To control the style of highlighting used:

Select the Options→Display Preferences→Messages tab.

By default, Agent enables the following attributes for URLs in the section
How to Display URLs.  You have the option to disable any of these.
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1. Highlight in different color - Check this box for Agent to display URLs
in a different color than normal text.

Note:  To set the URL color, use the URL option on the Display
Preferences Colors tab.

2. Underline - Check this box for Agent to display URLs with an underline.
Uncheck the box to remove the underline.

3. Highlight in Composition Window - Check this for Agent to highlight
URLs while you're composing a message.

Note:  To optimize speed in composing messages, you might choose to
turn off this option.

To control which types of URLs are highlighted:

Select the Options→General Preferences→URL Types tab.

For each URL type in the drop-down menu you can decide whether you want
to enable URL launching.

If you uncheck the Enable Highlighting and Launching option for a particular
URL type, that type will no longer be highlighted by Agent.

Some other things to note:
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• Whenever your cursor is positioned over a highlighted URL, it will
change to an arrow.

• If you right click while the cursor is over a URL, you'll get an abbreviated
context menu with options for handling the URL.

• If you select text, then right click, you'll get a context menu, which
includes options for handling URLs.

Launching a URL

When you double-click on a highlighted URL, Agent will invoke the
application on your system used for handling that type of URL.  This is called
“launching” a URL.  For example, if you double click the URL
http://www.forteinc.com, Agent will invoke your Web browser, with focus
on Forté's home page.  If you double click an email address, Agent will open
up an Agent Composition window with the selected URL in the "To:" field.

You can customize launching behavior to suit your needs.  On the
Options→General Preferences→URLs tab, note the section, Launching
URLs.

These options are described as follows:

1. Double-click to launch - Checking this box allows you to launch a URL
in a message by double-clicking the URL.  If you uncheck this box,
double-clicking just selects the text (i.e., it does not launch the URL or
copy the text to the clipboard).

Note: There are a variety of formats for URLs.  Even if Agent does not
seem to recognize a URL with an uncommon format, you can still launch
it (see below) by dragging the mouse across the URL to select it, then
right-clicking the selection and choosing Launch URL from the context
menu that appears.

2. Copy to clipboard - Check this box to have Agent copy the URL to the
clipboard at the same time that it launches the URL.

Note: This option only applies when you launch a URL.

3. Force web browser to open a single Window - Checking this box
forces your web browser (e.g. Netscape or Internet Explorer) to use its
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current window for displaying URLs sent to it by Agent, even if the
browser is normally configured to open a second window.

_____________________________________________________________

OO Technical Note: This option forces the argument passed via the
WWW_OpenURL command to be:

"%1",,0xFFFFFFFF,,,,,

no matter what the registry says it should be.  So, if you're a Netscape
user and this is checked, you shouldn't have to make any other
changes to Agent to cause Netscape to load only one copy of itself.

_____________________________________________________________

4. How to interpret a name@domain URL - Select the way in which you
want Agent to interpret URLs detected in a message.  Because there is
potential ambiguity between an email address and a news message ID,
you need to tell Agent how to resolve the ambiguity when encountered.

By default, Agent attempts to distinguish between the two (i.e. it makes
an educated guess).  But you have the following options:

• Prompt for action, where Agent will always ask you how to proceed.

• Assume the URL is an email address.

• Assume the URL is a message-ID.

• Make an educated guess.  (Technical details are in the online help.)

Launching message URLs poses a special problem for Agent.  The message
ID can refer to any news message, whether it's in the current group, other
groups or folders, or even on the host news server.  You need to tell Agent
where it should look.  On the Options→General Preferences→URLs tab, the
Search for message URLs in: section allows you to specify your preferences.

• Select which set of groups in which you want Agent to search the
message URL.
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• Check the Folders box to have Agent search your folders for the
message.

• Check the News Server box to have Agent search for the message on
your News Server.  If you check the Prompt before going online box,
Agent will ask you if you want to proceed before going online.

You can define specific launch behavior for each type of URL using the
Options→General Preferences→URL Types tab.  By default, Agent will use
your Windows registry/association settings to determine which application to
use, but you can override this behavior directly by selecting one of the other
options in the How to Launch URLs section of the URL Types tab.

Use Windows registry settings - This setting is only available in the
Windows 95 and Windows NT 4.0 version of Agent.  This is the default
setting that allows Agent to work in harmony with the Windows 95 and
Windows NT 4.0 system.

Use Custom settings (below) - Checking this option activates the Custom
Settings section on the URL Types tab.  You may use this setting in cases
where you are using an application such as Netscape that requires different
settings than the defaults.  If you enter netscape.exe as the application,
for example, Agent activates the other custom settings, automatically
checking the Use DDE option and inserting Netscape as the application.

Send URL to Agent - This option is normally not available (grayed out).  It
is only available when you have selected nntp: Usenet News from the URL
dropdown list at the top of the URL Types tab.
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Making Agent Your Default News/Email Program

You can easily configure your system so that Agent is used whenever you
encounter a news message or an email address in your web browser.

To make Agent your default news/email program:

Use the Make Agent the web browser service for... options on the
Options→General Preferences→URLs tab.  Agent will update your system
registry so that anytime you launch a news message and/or an email
message from your Internet Explorer or Netscape browser, Agent will be
launched.

• If you select an email address, Agent will bring up a Composition
window with the email address in the "To:" field.

• If you select  a message ID, Agent will find the message and bring up
the message pane with this message, following the search instructions
you specified on the URLs tab.  (See page 169.)

For Internet Explorer 3.0 and above - Select View→Options→Programs.
Agent will be one of the choices for News and Email.  Select Agent.

For Netscape 3.0 and above - you don't need to do anything else.
However, because of limitations in Netscape, Agent can respond to URLs
passed from Netscape only if Agent is already running.

Using Shortcuts and Internet Explorer’s Favorites List

If you've installed Microsoft's Internet Explorer you can do the following:

Add URLs to Internet Explorer's Favorites list.  (32-bit Agent only)

Highlight the URL in a message and select Edit→Add URL to Favorites (or
use the URL context menu).  On the Add URL to Favorites dialog that
displays, press Save  to add the URL to the list.  (See the following
example.)
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Using the Add URL to Favorites dialog box, you can insert the URL
anywhere in your Favorites hierarchy.  Anytime you’re in Agent and you
want to see the contents of the Favorites folder, simply select
Window→Open Favorites Folder.

Create shortcuts to email or news messages.  (32-bit Agent only)

Such shortcuts will activate Agent directly.  For example, if you have Agent
set to be the default email program, you will follow these steps:

1. Right click a mail-to link in Internet Explorer and select Copy Shortcut.

2. Right click anywhere on your Windows desktop and select Paste
Shortcut.  A shortcut will be created on our desktop, showing Agent's
Email icon.

3. Double-click the Email icon and Agent will be invoked, showing a
Composition window with the mail-to link in the "To:" field.

_____________________________________________________________

OO Note to Netscape Users: The shortcut feature described above will
work in Netscape if you've installed Internet Explorer on your system.

_____________________________________________________________

What if you use multiple copies of Agent?

Agent's URL-related features work smoothly for people who use multiple
copies of Agent.  You can have a single copy of Agent as both your news
and email service (or neither), or you can have a different copy of Agent for
each.  You can configure Agent to work just the way you want.

Agent will configure itself so that two users can share the same computer
with separate Agent databases, and have URL launching work correctly.  For
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example, if a husband and wife share a computer, when the husband
launches a URL from his web browser, Agent will be initialized with the
husband's database.  Likewise, Agent will launch with the wife's database
when she's using the computer.  This feature only works under Windows 95
or Windows NT, and requires:

• A unique login account ID for each user.

• AGENT.EXE be stored in a common directory, with Agent databases in
separate working directories.

Using a Newsrc File
A newsrc file is a text file used by Unix systems and by some other
Windows-based newsreaders to record the list of newsgroups available to
and used by an individual. The newsrc file records the total list of groups,
which groups have been subscribed to, and the range of messages that
have been retrieved and read for each group.

Agent stores this same group information in its own database using a
proprietary format.  As long as you use a single version of Agent (always on
the same machine), there's no need to worry about using a newsrc file.
However, if you use Agent at home, while at work you use a Unix-based
newsreader (or another copy of Agent), you can use Agent's newsrc
import/export feature to keep your home and work newsreading in synch.

Exporting a Newsrc File

Select File→Newsrc→Export.  You'll see the Export Newsrc File dialog box.
Do the following:

• Specify the filename and destination for the newsrc file Agent will
create.

• If you want only your subscribed groups exported, check the box Export
subscribed groups only on the Export Newsrc dialog box.

When a newsrc file is exported, Agent uses both its list of messages that
have been retrieved and the unread state of retrieved messages to build the
newsrc list of read messages, as follows:

• The lowest range of messages already retrieved by Agent is extended
down to the number 1.

 For example, if the range of retrieved messages is [100-150,200-240],
Agent extends the first range to yield [1-150,200-240].
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 Note:  This is done to prevent already-retrieved messages from being
marked unread if the same newsrc file is re-imported.

• Retrieved but unread messages are removed from the list.

Importing a Newsrc File

If you have placed a newsrc file in your Agent data directory (either by
exporting it from Agent or producing it from another application), you can
import the file and update your groups list in Agent.

Select File→Newsrc→Import.  You'll see the Import Newsrc File dialog.

Specify the name and location of the file to import.  Then select the desired
options, described below.

• Update retrieved message counts --Check this box if you want Agent
to update the count of retrieved messages and their unread states when
a newsrc file is imported.  Agent's list of retrieved messages is updated
so that it includes the list of messages in the newsrc file, as well as the
messages currently stored in Agent's database for each group.

 So...messages that may have not been included in the newsrc because
they were marked unread, but which have already been retrieved, are
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included in Agent's updated list of retrieved messages.  All existing
messages listed in the newsrc file are marked read, and all existing
messages not listed in the newsrc file are marked unread (but see the
next item.)

• Mark messages read only -- Check this box for Agent to use the
newsrc ranges to mark existing messages read, but not to mark any
messages unread.  When you uncheck this box, Agent also marks as
unread any messages not listed in the newsrc range.

• Update list of subscribed groups -- Check this box if you want Agent
to update the list of subscribed groups when a newsrc file is imported
and include subscribed groups not in your current list of subscribed
groups in Agent.

• Add new Groups -- Check this box if you want Agent to add new
groups when a newsrc file is imported and contains groups not already in
your database.

• What to Do With Extinct Groups -- Choose how you want extinct
groups (groups which are no longer available on your news server) to be
handled.

Automatic Import and Export of Newsrc Files

You can configure Agent to automatically import a newsrc file on program
startup and export a newsrc file on program exit.  Use the Options→General
Preferences→Newsrc tab to preset the options Agent will use when
importing and exporting.  The options are the same as those described
above for manually importing and exporting newsrc files.
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CHAPTER 8

Customizing Agent
You have a wide range of options for customizing Agent, from designing toolbars and
personalizing the Folders menus, to customizing the layout of Agent's panes and even the
look of text in messages.  In short, Agent is a highly flexible tool that fits the way you work.

In this chapter, you will learn how to customize:

1 Toolbars

1 Folders Menu

1 Window Display

1 Message Display

1 Agent.ini

Toolbars
This is, arguably, one of the "coolest" features Agent offers, because toolbar
icons are both fun to look at and functional.  The ability to customize your
toolbars is important because of how differently people work and how their
personal preferences vary.  Toolbars can be designed for:

• Agent's main browser

• The Outbox

• The Composition window

• The Address Book

• The Usenet Filters window

• The Email Filters window

• Agent's Log
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To customize toolbars:

1. Select the Options→Menus and Toolbars→Toolbars tab, shown below.

 

2. From the Window list, choose where you want to add a toolbar
command.

3. From the Commands list, choose the command you want to add.

4. In the Toolbar list, select where you want the command to appear and
press the Add button  The command is inserted in front of this selection.
On the toolbar, the icons appear in the same order (left to right) as the
commands on the Toolbar list.  You can change the order of the
commands using the Up and Down buttons.

You can group similar types of icons, separating the groups by a slight
space. To insert a space between one icon and another, press the Separator
button.

If you change your mind about an icon, you can remove it from the toolbar
by pressing the Delete button.  The deleted command reappears as a choice
on the Commands list.  At any point, you can revert back to Agent's default
toolbar settings by pressing the Reset button.

Finally, you can change the size of the icons on the Options→Display
Preferences→Main Window tab.  Make sure that Show Tool Bar is selected.
Then specify the desired percentage to expand or shrink the buttons.  Size
changes are effective in increments of 5%.  For example, any percent from
101%-105% will cause the buttons to expand by 5% (to 105%).
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Folders Menu
The Folders menu appears as a flyout menu from Message→Copy to Folder
and Message→Move to Folder options.

Using the following procedure, you can customize the Folder menu so that it
lists one or more of the folders to which you frequently copy or move
messages.

To customize the folder flyout menus:

Select the Options→Menus and Toolbars→Folder Menus tab.
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Under Folders, you'll see all currently defined folders.  Select each folder
that you want to add to the Folders flyout menu and press Add.  The folder
will switch from the Folders list to the Menu list.  You can list up to nine
folders on the Folders flyout menu.

To remove a folder from the menu, simply select the desired folder in the
Menu list and press Delete.  The folder is removed from the Menu list and
reappears as a choice on the Folders list.

When you close the dialog box, verify that your selections appear on the
Folders menu (e.g., on the Copy to Folder flyout).

Window Display
By default, Agent displays all three window panes upon startup.  Once you
have used the program a few times, you may want to customize the layout
by rearranging the three panes.

Changing the Layout of the Panes

Select Options→Window Layout and the button bars below will display.

The button bars on the Window Layout dialog box are described as follows:

• Layout of Panes - These buttons show all of the available pane layouts.
Click a button to choose that layout.

• Contents of Panes - For the layout above, these buttons show all of the
ways you can organize the Group pane, Message List pane, and
Message pane.  To distinguish the three types of panes, the text on the
buttons has been color coded:

Black text indicates the Group pane.
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Red text indicates the Message List pane.

Blue text indicates the Message pane.

Click a button to choose that content arrangement.

Once you've made your selections and have closed the dialog box, the
window will reflect your selections.

To resize the panes:

Simply drag the border between the two panes.

To save your new arrangement as the default:

Select Options→Save as Default Window Layout.  Whenever you start
Agent or open a new browser window (Window→Open New Browser), this
layout will be used.  The Save as Default Window Layout command saves
the pane layout, pane sizing, and information on whether or not the pane is
zoomed.

Changing the Appearance and Behavior of Agent's Windows

Select the Options→Display Preferences→Main Window tab.

The Main Window tab options are described as follows:

1. Show Toolbar - Select this option to display the Agent toolbar directly
below the menu bar.

2. Size of buttons - Specify the percentage to expand or shrink the
buttons.  The default size is 100%, or 20x20 pixels.  A number greater
than 100% expands the buttons, and less than 100% shrinks the buttons.
Size changes are effective in increments of 5%.

3. Show Status Bar - Select this option to display the Agent status bar at
the bottom of the window.
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4. Reposition on last message when restarting program - Check this
box if you want Agent to reposition itself on the message that was
selected at the time you last closed Agent.  If you don't check this box,
when you open Agent the next time, Agent positions itself on the first
message in the Message List pane.

Select the Options→Display Preferences→Browsers tab to view options
pertaining to all browser windows:

1. Scroll Margins - Set this value to control how close the highlighted row
in the Groups/Folders pane or the Message List pane gets to the top or
bottom of the screen.  When scrolling in these panes by using Up Arrow,
Down Arrow, Page Up or Page Down, you'll always see the number of
rows specified (2 is the default) above and below the row Agent jumps to
(except, of course, when you reach the top or bottom of the pane).

2. Show Author's full email address - Check this box to display email
addresses and full names in the Author column.  When this box is
unchecked, only the names are displayed.

Message Display
Agent allows you to customize the message text that appears in the
Message pane to suit your own needs and preferences.

Changing the Appearance of Messages

In the previous section, you saw how two of the tabs on the Display
Preferences dialog box are used to change the appearance and behavior of
Agent's browser windows.  You can use the three remaining tabs on the
Display Preferences dialog box to customize such things as how quoted text
and URLs display, what style and size of fonts are used, and what colors are
used for normal text, quoted text, and URLs.
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Select the Options→Display Preferences→Messages tab, which is used to
change the appearance of message bodies.

These are your options on the Messages tab:

1. Tab Spacing - Enter the length of tab stops, in characters.

2. Quoted Text Markers - Enter the character(s) that will signify quoted
text from a previous message.  Quoted text markers are commonly used
to indicate what part of a message has been copied or carried over from
another message.  Agent displays this text in the color specified for
quoted text on the Colors tab of the Display Preferences dialog box.

3. Show dividers between sections - Check this box to insert a horizontal
line between the different sections of message bodies.  For example, if
you've enabled Show All Header Fields on the Message menu, there will
be a divider between the header fields and the body of the message.

4. How to display URLs - You can choose the attributes that you want to
apply to URLs, including specifying a new color for URLs, and whether
URLs are underlined or become highlighted when they are entered in the
Composition window.

5. Show Buttons on composition window - Check this box to show the
Send Now, Send Later, Save, All Fields, Cancel, and Help buttons
directly as part of the Composition window.  By default, these buttons
are not on the Composition Window toolbar.
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Selecting the Options→Display Preferences→Fonts tab allows you to
change the fonts in Agent's messages and browsers.

Your options for changing the fonts in messages are described below.

Browser - Press this button to change the font for the Groups pane as well
as for the Outbox, Usenet Filters, and Address Book windows.  Fonts for the
Message List and Message panes are defined below.

Fonts for the Language - In the rest of the dialog box, you may select
which fonts to use for each language that you have defined.  Use this
combobox to select the language you may want to modify.

Variable-Pitch Body - Press this button to change the font to be used when
displaying message bodies in a variable-pitch font.

Fixed-Pitch Body - Press this button to change the font to be used when
displaying message bodies in a fixed-pitch font.
_____________________________________________________________

OO Often, messages will contain "fancy" signatures or other text that uses
characters to create a graphic image.  If the image is indefinable or
looks distorted, try using the fixed pitch font.

_____________________________________________________________

Message List - Press this button to change the font used in the Message
List pane.
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Use the variable pitch body font - Check this box if you want the font that
was selected for the Variable-Pitch Body setting to be used in the Message
List pane.

Message List Subject - Press this button to change the font of the message
subjects in the Message List pane.

Use the bold version of the message list font - Check this box if you want
the message subjects to be displayed in the bold version of the Message List
font.

Printer - Press this button to change the font used when printing.

Use the variable-pitch body font for Headers - When this option is
checked, Agent uses the variable-pitch body font for the body pane header
and for the Subject field on the message composition window.  Otherwise, it
uses the default system font.

Note:  You only need to check this box if you've selected a font that does not
use the default Windows character set (e.g., a Cyrillic font for Russian), and
you want the text in the different character set to be displayed correctly on
the body pane header and/or subject edit field.

Finally, the Options→Display Preferences→Colors tab allows you to change
the color of text and URLs that appear in message headers and bodies.
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On the Colors tab, you can change each setting to any one of the sixteen
colors in the dropdown palette.  Here's what each setting represents:

Normal Lines - the color for groups, folders, and read message headers.

Unread Messages - the color for unread message headers in the Message
List pane.

Highlighted Unread Messages - the color for unread message headers
when they are selected.  This is usually the inverse of the previous setting.

Normal Text - the color for message body text.

Quoted Text - the color for quoted text in a message's body.

URLs - the color for URLs.

Customizing Agent for Different Languages

Some of the groups of interest to you may be home to conversation threads
in languages other than English.  If the language has an available dictionary
on Agent's ftp site, you can install the dictionary for spellchecking messages
you compose in that language.

In addition to the language dictionary, you may need to install a unique font
so that the text of retrieved messages is viewed correctly.  English, for
example, uses the Latin character set, while Russian and Japanese use
entirely different characters sets requiring alternate fonts.  In Agent, you can
specify the character set on a per-group or per-message basis.

To configure Agent for international fonts:

1. Install the font into your Windows system (see your Windows
documentation for details).

2. Place the language's character set mapping (.csm) file in your Agent
working directory.  For example, you might download the Russian
character set, koi8.csm, from the Agent ftp site into your Agent
directory c:\agent.

3. Configure Agent's preferences as follows:

 a. Select the Options→General Preferences→Languages tab.
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b. Press the Add button to bring up the Add Language dialog box and
add the language (e.g., Spanish) to the list of languages (see
below).

Note:  For fonts that use Non-Latin1 character sets (e.g., Russian,
Japanese, Norwegian, and Swedish), you need to use variable-pitch
fonts in the Message List and Message panes.  To do this, use the
Variable-Pitch Body button, and check the two options Use variable-
pitch body font and Use variable-pitch body font for Headers.

4. Find and subscribe to the newsgroups using the font you installed.

5. Define Group Properties for the selected groups, as follows:

a. In the Groups pane, select the desired newsgroups.
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b. Select the Group→Properties→Languages tab.

c. Set two options: check the Override default settings box and select
the language associated with the newsgroups (see below).

Word Wrapping

Agent allows you to word wrap retrieved message bodies with lines too long
to fit in the display window.  Here’s how text in messages will appear when
the Word Wrap function is enabled or disabled:

• Enabled Word Wrap - All text in the message will be visible no matter
how small the display window.  This allows you to see all of the
message, but may make it hard to determine the original format of the
message.

• Disabled Word Wrap - The message text will appear in its original
format, but you may have to use the horizontal scroll bar to see all of it.

To enable or disable the word wrap feature:

Select Message→Word Wrap.  When a check appears by the command, it
is enabled and the text in very long messages will wrap to conform to the
size of your window.  Select the command again to disable it.
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Showing or Hiding Details in Messages

The details (or header fields) about a retrieved message body (e.g., author,
location, and server) can be displayed at the top of the message or can
conveniently be hidden to make it easier to read the message text.

To show and hide header fields:

Choose from one of the following equivalent methods to show the header
fields.  Then repeat that action to hide the header details again.

Toolbar button:   (To customize your toolbar with this button, see page 177.)

Menu option: Message→Show All Header Fields

Keyboard shortcut: H

Note:  The Show All Header Fields option will not hide header details that
somebody else quoted and included in the message.  In that case, it is part
of the message body and will always be displayed.

In addition to header details, at any time you have the option of viewing the
"raw" message, which simply means the original text of message bodies in
an unformatted state.  For example, if you want to view a retrieved message
with a GIF image attachment in its raw state, you would see all the header
fields and the original encoded lines of the attachment (unformatted).

You can tell Agent which header fields to display.  This is controlled through
the file Agent.ini, described in the next section.

To view raw message details:

Choose from one of the following equivalent methods to view the message
in its raw state.  Then repeat that action to view the message again in its
formatted state.

Toolbar button:   (To customize your toolbar with this button, see page 177.)

Menu option: Message→Show Raw Message

Keyboard shortcut: Alt+M+S

_____________________________________________________________

OO Important!  If Show Raw Message is selected, Agent will not convert
quoted-printable messages to the correct format, which may cause the
message to be viewed incorrectly (e.g. characters like “=3D” or “=20”
will appear in the message).

_____________________________________________________________
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Agent.ini
The Agent.ini file contains all of the settings that control Agent's operations,
its behavior under different conditions, and the way it displays information.
In general you can (and should) control these setting by using the menu
options and preference dialogs described in this manual.  However, not all
settings are available through menus and dialogs and can only be changed
by altering the file directly, using the text editor of your choice

When you open Agent.ini in a text editor, you'll notice that the settings are
organized in functional categories, indicated by square brackets ([ ]) (e.g.,
[Address], [Online], [Toolbars]).  This helps you to find quickly the exact
setting you wish to modify.

You should, of course, make a backup of the Agent.ini file before making
any changes to it.  This will save you the trouble of having to reset all your
Agent preferences just in case anything goes wrong.  And whenever you edit
Agent.ini, make sure you turn off any automatic word wrapping in your
editor.  Some of the lines in Agent.ini are quite long, and wrapping them
would make them multi-line, in which case they will no longer work correctly.

In this section some of the more useful settings (which are not available
through menus or dialogs) are described in detail.  To learn what each
setting in Agent.ini means and where in the program you can find that
setting, you can refer to Agent's Online Help.  The topic ".INI" is at (or near)
the top of the search index.  In the AGENT.INI help topic, you can click on
each of the functional categories to jump directly to the settings in that area.
If the setting is on a dialog box in Agent, you can jump from the AGENT.INI
help topic directly to the help topic for that dialog box.

Details of Some Agent.ini Settings

[View]

ProgressStyle=0
This setting controls the format of the graphical online task progress
indicator in Agent's Status Bar.  The options are:

0 Display the progress indicator in its own box on the Status Bar.
1 Display the progress indicator in its own box, and include text

showing the percentage of the task completed so far.
2 Display, in its own box, text showing the percentage of the task

completed so far without a graphical progress indicator.
3 Display the graphical progress indicator over the text describing
  the current task.
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4 Do not display the progress indicator.

[Article]

NewsBaseFields="<fields>"
NewsAllFields="<fields>"
MailBaseFields=!to,!subject,!from,!date,cc,bcc
MailAllFields="<fields>"
These settings control which header fields are displayed at the top of  the
message body.  The News parameters control Usenet messages, and the
Mail parameters control email messages.  The "Base" parameters control
the  fields that are always displayed, if non-empty (see below).  The "All"
parameters control the fields that are displayed when "Show All Header
Fields" is activated..  Each parameter contains a list of comma-separated
field names, with fields displayed in Agent in the order listed in these
settings.  If a field name is preceded with a !, then the field is always
displayed.  Otherwise, the field is displayed only if it's actually contained in
the message.  If a  "Base" (news or email) parameter is empty, then no
fields are displayed when "Show All Header Fields" is inactive.  If an “All”
(news or email) parameter is empty, then all fields are displayed when
"Show All Header Fields" is activated.

[Attachment]

Executables="exe,bat,com,cmd"
This setting controls the executable applications recognized by Agent.  For
these file types, Agent will display a warning before attempting to launch
files of this type, protecting you from possible computer virus contamination.

[Message]

GMTDates=1
When non-zero, Agent will post all news and email messages in GMT format
rather than your local timezone.

ShowAllFields=0
When non-zero, Agent will allow editing of the Control and Approved
message fields used for posting to moderated newsgroups.

SignatureDelimiter="^--()?$"
This setting tells Agent which characters mark the beginning of a signature.
When Agent sees the final occurrence of this string of characters in text to
be quoted, all text after this delimiting text is stripped from the quoted text.
To deactivate this feature, place a right parenthesis just after the first
quotation mark in the string.  For example,
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SignatureDelimiter=")^--()?$"

[Timing]

Parameters in this section allow you to control how long before a "timeout"
message is displayed in Agent.  If you think the server is dropping your
connection, or having "lags" in the download of headers, then you can
increase the amount of time Agent will wait before generating the error
dialog box.  All times are in seconds.

GetHostByNameTimeout=30
This setting controls the timeout period for looking up the host's name.

ConnectTimeout=10
This setting controls the timeout period for connecting to the host.

ResponseTimeout=120
This setting controls the timeout period for waiting for a response from the
host.

SendTimeout=60
This setting controls the timeout period for sending a command to the
server.  This is the maximum time the program will wait during a blocked
transmission, not the total time allowed to send a message.

PostTimeout=60
This setting controls the timeout period for posting a message or email
message.  This is the maximum time the program will wait during a blocked
transmission, not the total time allowed to send a message.

PostResponseTimeout=360
This setting controls how long Agent will wait for an acknowledgment from
the server after posting a message or email message.

QuitResponseTimeout=30
This setting controls how many seconds Agent will wait for a Quit
acknowledgment from the server.

[Debugging]

ShowUID=0
When non-zero, Agent will show the group/folder id's in the Groups pane.
This number is the base filename for each group's IDX and DAT files,
allowing you to find the actual files which correspond to a group or folder.

ShowArticleDetail=0
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When non-zero, Agent will show some detailed information about messages
at the bottom of the Message pane.  In particular, this shows the message's
number as reported by the news server.

ShowBuild=0
When non-zero, Agent will display the build number in the title bar.
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creating views, 93–96
crossposting messages, 61
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tab spacing, 183
toolbars, 177–78
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window display, 180–82
word wrapping, 188

customizing the Folders menu, 179–80

Daylight Savings Time, 16
default news/email program, 171
default signature, 121
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deleting messages, 108
Dial-Up Networking, 48

defining settings, 49
dictionaries for spell checking, 135
digests, 159–60

bursting, 160
sending, 159

disposition (of message sections), 152
distribution field, 118

email. See mail
encoding and decoding attachments, 150
expanding addresses, 129
expanding and collapsing threads, 37
expanding threads automatically, 38
expires field, 118

Favorites list, 171
field text, 125
fields, 117–19
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defined, 118
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when printing messages, 110
when saving messages, 57

file attachments. See attachments
filing mail automatically, 67
filing messages in folders, 42, 45, 53–56

when sending messages, 140
filter examples, 86
filter expression language, 75–79
filter expressions, 70, 72
filtering messages. See message filters
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find / find next, 98
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drag-and-drop method, 54
Manage Folder Menus dialog, 55
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Folders menu, 179–80
follow-up to field, 119
fonts, 97, 184
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Forté

Customer Support, 7
ftp site, 130, 135
web site, 6

forwarding messages, 115
from field, 119

Getting Help, 6
Customer Support, 7
Forté's web site, 6
newsgroups, 7

global search, 99–103
GMT time, 191
group properties, 39

for all groups, 39
for selected groups, 40

groups
catching up, 60
finding, 19
new, 30
properties, 39
refreshing, 18
sampling messages in, 20
selecting, 40
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subscribing, 22, 30
viewing, 23, 28

groups/folders pane, 28

header fields
displaying, 189, 191

hiding message details, 188

icons, 30–32
expand, collapse thread, 31
for attachments, 155
Groups/Folders pane, 30
message body, 31
Message List pane, 31
Outbox, 140
unread mail, 67

ignoring threads, 31, 43, 45, 61
importing addresses, 130
Insert key, 32
installation, 11

electronic, 13
shrinkwrap, 13

Internet Explorer, 171
Internet Explorer's Favorites list, 171

keep command, 107
keeping messages, 31, 43, 45, 103–9
keywords field, 119

languages, 186
launching attachments, 151
local addresses, 129, 132

mail
alerts, 66
checking for, 63
default inbox folder, 23
email defined, 4
filing automatically, 67
replying to, 42
retrieving at more than one site, 65, 88
retrieving for the first time, 23
unread mail icon, 67

mail (SMTP) server, 16
mailing lists, 125

field text, 125
managing crosspostings, 61–63

MAPI, 142
marking messages for retrieval, 30, 31, 37, 44
marking messages read, 36
menu bar, 28
message (body) pane, 29
message details, 188
message digests. See digests
message display, 182–89
message fields, 117
message filters, 67–89

add email filter dialog, 72
add Usenet filter dialog, 69
creating, 68
deleting, 75
editing, 75
examples, 86
expiring, 71, 74
filter expression language, 75–79
filter expressions, 70, 72
filtering out spam, 84
managing, 74
regular expressions, 81–84
Usenet filter examples, 79–81

message index, 152
message list pane, 29

resizing columns, 29
showing author's full address, 182
views, 92

message properties, 137, 157, 159
message status, 31, 32
messages

canceling Usenet messages, 141
composing, 113
creating an address book entry from, 124
deleting, 108
digests, 159–60
display options, 182–89
displaying, 97
filing in folders, 42, 45, 53–56
filters, 67–89
finding, 98–103
fonts, 97, 184
forwarding, 115
international fonts, 186
keeping, 31, 43, 45, 103–9
languages, 186
marking for retrieval, 30, 31, 37, 44
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marking read, 36
message index, 152
posting queued messages, 46
printing, 110–11
properties, 137, 157, 159
purging, 103–7
raw, 57, 189
replying to, 115
re-sending, 140
retrieving bodies, 22
retrieving headers in selected groups, 42
retrieving headers in subscribed groups, 22,

44
retrieving marked messages, 44
sampling, 20
saving, 114
saving to a file, 56–58
sending, 114
showing details, 188
sorting, 29, 89
viewing, 89–98
word wrapping, 97

MIME, 150
MIME types, 151

multipart attachments, 150
retrieving, 155

multiple selection, 21, 40
multi-tasking, 41

navigating, 33–38
and retrieving messages, 36
moving between messages, 34
moving between panes, 33
moving to next or previous message, 34
retrieving next unread message, 37
retrieving next unread message in a thread,

37
single key navigation, 37
skipping to next unread group, 36
skipping to next unread message, 35
skipping to next unread message in a

thread, 35
skipping to next unread message with body,

35
skipping vs. viewing, 34

Netscape, 171, 172
new groups, 30

news (NNTP) server, 16
news server authorization, 17
newsgroups

defined, 4
examples, 5

newsrc files, 173–75
automatic import and export, 175
exporting, 173
importing, 174

offline mode, 41
configuring, 46
typical session, 44

Online Help, 6
online mode, 41

configuring, 46
typical session, 42

organization field, 119
Outbox, 139–41

icons, 140
opening, 139
re-sending messages from, 141

overwriting text, 32

pasting text as quoted, 134
picking addresses, 113, 126–28
POP servers, 24

using APOP, 24
posting messages. See sending messages
posting queued messages, 46
printing messages, 110–11
properties for all groups, 39
properties for selected groups, 40
purging messages, 103–7

preventing, 107
what to purge, 105
when to purge, 104

quoted printable format, 136
quoted text, 133, 134
quoting text in messages, 116

refreshing the groups list, 18
registration, 13

electronic, 14
shrinkwrap, 14

regular expressions, 81–84
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Release Notes, 6
Remote Access Services (RAS), 49
replying to mail, 42
replying to messages, 115
reply-to field, 119
retrieving attachments, 153–56
retrieving mail, 23

with POP, 24
with SMTP, 25

retrieving mail messages, 63–67
retrieving marked messages, 44, 59
retrieving message bodies, 22, 59
retrieving message headers

in selected groups, 42
in subscribed groups, 44

retrieving multipart attachments, 155
retrieving news messages, 58–63
ROT13, 97

sampling messages, 20
saving attachments, 152, 156–57
saving messages to a file, 56–58

header fields, 57
scroll bars, 30
scroll lock key, 32
scroll margins, 182
selecting an address, 126–28
selecting multiple groups, 40
selecting multiple headers, 21
sender field, 119
sending attachments, 157–59
sending messages, 114, 136–39

7-bit / 8-bit format, 136
canceling Usenet messages, 141
checking status, 139
filing messages in folders, 140
forwarding, 115
message types, 114
new messages, 114
posting queued messages, 46
preferences for individual messages, 137
quoted printable format, 136
quoted printable vs. 7-bit / 8-bit, 136
replying, 115
re-sending, 140
setting format preferences, 136
using MAPI, 142

servers
mail (POP), 24
mail (SMTP), 16
news (NNTP), 16

setting message preferences, 131
setting up a connection, 48
shortcuts, 171
showing buttons on the Composition window,

183
showing message details, 188
signatures, 119–21

creating, 120
default, 121
delimiter, 191
inserting, 119
stripping, 116, 191

single key navigation, 37
size of toolbar buttons, 178
sorting messages, 29, 89
SPA (Secure Password Authentication), 25
spam, 84
spell checking, 134–35

dictionaries, 135
status bar, 30, 41, 67, 181, 190

indicators, 32
subscribing to groups, 22
summary field, 119
system requirements

16-bit Agent, 12
32-bit Agent, 12
PC, 12

tasks, 41
threads, 29

displaying, 90
expanding and collapsing, 37
expanding automatically, 38
ignoring, 31, 43, 45, 61
watching, 31, 43, 45, 60

three pane layout, 18, 27
changing the layout, 180
groups/folders pane, 28
message (body) pane, 29
message list pane, 29
moving between panes, 33
resizing panes, 181

time zones, 16, 191
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timeout parameters, 192
title bar, 28
to field, 119
toolbars, 28, 177–78

unread mail icon, 67
unread messages, 30, 32
URLs in Agent, 165–71

and Internet Explorer, 171
and Netscape, 171, 172
copying to the clipboard, 168
displaying, 166, 183
Internet Explorer's Favorites list, 171
interpreting URLs, 169
launching, 168
URL types, 165
using Windows shortcuts, 171
working with web browsers, 169

using multiple copies of Agent, 172
UUEncode, UUDecode, 150

validating addresses, 128
view filters. See views
viewing

folders, 54
groups, 23, 28
message bodies, 22, 29
messages, 89–98
subscribed groups, 23

views, 92
advanced, 94
creating, 93–96
currently selected view, 31
examples, 96
selecting, 92
simple views, 93

watching threads, 31, 43, 45, 60
window display, 180–82

Agent's main window, 181
windows in Agent, 32

address book, 122
composition window, 116

showing buttons, 183
email filters, 68, 74
Outbox, 139
Usenet filters, 68, 74

Windows registry, 170
Windows shortcuts, 171
Winsock

loading, 25, 47
unloading, 65

word wrapping, 97, 132, 138, 188
working offline, 41
working online, 41

zooming in and out, 29, 33


