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Working with Tables
After completing this lesson, you will be able to:

· Change the format of a table.

· Sort records in a table.

· Find records in a table.

· Use filters with a table.

· Establish relationships between tables.

· Create subdatasheets.

· Import records from an external source.

Microsoft Access provides many ways to change the entry, format, properties, organization, and storage of information in your database tables. As the tables in your database become more efficient, your database becomes more efficient.

To reduce errors during data entry, you can modify individual fields within tables to accept only certain types of data or specific data formats. For example, you can set a Date field to accept only six numbers and have Access automatically insert slashes between those numbers so that all dates in the field will appear in the format 10/27/99. You can further reduce the amount of time spent typing by importing information from other tables or spreadsheets into Access.

After the data is entered into the table, you can change the organization of the data by performing a sort to list information numerically or alphabetically. For example, you could organize a table of employee hiring information by date hired, salary offered, or position. If you want to see only some of the information in a table, you can use a filter to restrict the data that appear by specifying which criteria you want to view, such as records for employees who make more than $30,000 or who were hired after January 1.

When there are many tables in a database, you might find that you spend a lot of time flipping back and forth between tables. You can save time by establishing relationships between tables that contain similar fields and creating subdatasheets, which display the data from one table in another.

To complete the procedures in this lesson, you will need to use files named Database Fundamentals 03 and ImportPractice in the Database Fundamentals Practice folder that is located on your hard disk.

Formatting a Table Datasheet

When you create a table, Access automatically formats the table with a 
10-point Arial font and silver gridlines. Access uses this default format because it is easy to read on a computer screen.
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If you don’t want to use the default format, you can customize table appearance by changing the font, the font size, and the font properties (such as whether the font is bold or italicized). You can also change the background color, alter the color of the gridlines, or assign a special effect to make cells appear raised or sunken. You can change the height and width of rows and columns, freeze columns and even hide columns. The illustration below shows the same table shown above with a sunken cell effect and a 14-point Times New Roman font.
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As you can see in the previous illustration, some of the data is not completely visible because the columns for the fields are too narrow. By default, Access sets column widths to one inch and does not adjust the columns’ widths if font size and formatting make the text longer than one inch.

The easiest way to make a column wide enough to show all the data is to double-click the line that separates the column from the next column. Access automatically expands the column to the correct size to show all the data. To make a column wider or narrower than this automatic setting, move the mouse pointer over the line between the field names until the pointer changes to a resizing double-headed arrow, and drag the column edge to the left or right.

In this exercise, you open the Database Fundamentals 03 database, change the font of tblEmployees to 12-point bold Times New Roman, change the table background to light blue, use a special effect to make the cells appear raised, and then adjust the column widths to accommodate the formatting changes.

1
With Access open, click the Open button on the Database toolbar.

The Open dialog box appears.

2
Click the Look In down arrow, click the icon for your hard disk, and then double-click the Unlimited Potential folder.

3
Double-click the Database Fundamentals Practice folder.

4
 Click the Database Fundamentals 03 database, and click Open.

The Database window for Database Fundamentals 03 appears.

5
On the Objects bar, click Tables, if necessary.

6
Click tblEmployees, and click Open on the Database window toolbar.

The table opens in Datasheet view.
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7
On the View menu, point to Toolbars, and click Formatting (Datasheet), if necessary.

The Formatting toolbar appears.

8
On the Formatting toolbar, click the Font down arrow, scroll down, and then click Times New Roman.
The font changes to Times New Roman.

9
On the Formatting toolbar, click the Bold button.

The font changes to bold.

10
On the Formatting toolbar, click the Font Size down arrow, and 
click 12.
The font changes to 12 points.
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11
On the Formatting toolbar, click the Fill/Back Color down arrow, and click a light blue square.

The table background changes to light blue.

12
On the Formatting toolbar, click the Special Effect down arrow, and click the Raised (second) option.

The table changes to the raised cell effect.
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13
Move the mouse pointer over the line between the Address and City field names until the pointer changes to a resizing double-headed arrow.

14
Double-click the line.

The column expands so that the widest record in the Address field, 241 W. 29th Avenue, is fully visible.

15
Double-click the line between the City and State field names.

The column expands so that the widest record in the City field, Sandyland Cove, is fully visible.

16
Scroll to the right, and double-click the line between the Home Phone and Notes field names.

The column expands so that all the phone numbers are fully visible.
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17
On the Table Datasheet toolbar, click the Save button.

Access saves the table.

18
Click the Close button in the top-right corner of tblEmployees.

The table closes.

These steps can be followed to export any Access object, not just tables.

Sorting Records in a Table

Even if you didn’t follow a particular order when you first entered data into a table, you can quickly organize the data in a field alphabetically or numerically by performing a sort. There are two types of sorts: ascending and descending. An ascending sort organizes the data in a field from the lowest value to the highest or in alphabetical order starting with A. A descending sort has the opposite effect; it organizes the data in a field from the highest value to the lowest or in reverse alphabetical order starting with Z.

To reorganize data, you click in the field that contains the values that you want to sort and click either the Sort Ascending or Sort Descending button on the Table Datasheet toolbar. For example, Adventure Works has a table that tracks employee data and has fields for employee ID, last name, and first name, among others. To sort the records in the database by employee ID, you click in the EmployeeID field and click the Sort Ascending button. To view the employee data in alphabetical order by last name, you click in the LastName field and click the Sort Ascending button.

Even though you sort using the data in only one field in a record, all the fields in a record move together. This feature keeps related data together during sorts and prevents you from accidentally separating data within records.

In this exercise, you sort the data in tblHumanResourcesData so that the record for the employee with the highest salary appears at the top. You then perform another sort so that the employee IDs appear in order.

1
Click in any record in the Salary field, and click the Sort Descending button on the Table Datasheet toolbar.

Access reorganizes the table in descending order by salary.
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2
Click in any record in the EmployeeID field, and click the Sort Ascending button on the Table Datasheet toolbar.

Access reorganizes the table in ascending order by employee ID, as shown in the illustration on the following page.
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3
On the Table Datasheet toolbar, click the Save button.

Access saves the table.

Finding Records in a Table

Tables in Access often get very large, and finding certain data can become very time-consuming. To locate specific information in a table, you can use the Find command. For example, in a table listing employee names and addresses, you could use Find to locate the record for an employee with a specific last name or to locate all addresses for employees who live in Santa Barbara.

You can use the Find command to search just one field or the entire table. If you are working with a large table, limiting your search to a single field means that the search will run faster than it would if the search had to examine all the information in the table. For example, if you are searching for the employee with the last name of Chai, the search will run faster if you search just the LastName field, instead of the entire table. By default, Access searches the last field you clicked in before beginning the search. If you want to search the entire table, you can select that option in the Find and Replace dialog box.

In this exercise, you use the Find command to locate the human resources information in tblHumanResourcesData for the employee with the job title of Host.

1
Click in any cell in the Title field.

2
On the Table Datasheet toolbar, click the Find button.

The Find and Replace dialog box appears, with Title already in the Look In box.
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3
In the Find What box, type Host, and click Find Next.

Access selects the record that contains Host in the Title field.

4
Click the Close button in the top-right corner of the Find and Replace dialog box.

The Find and Replace dialog box closes.

Using Filters with a Table

By using a filter, you can restrict data so that only records in a table meeting certain criteria are displayed. For example, you can create a filter to view records in tblHumanResourcesData for only employees who earn more than $30,000 a year.

In Access, you can create filters in two different ways. Filter By Form allows you to specify a field and a specific value in that field to use as the filter. Filter By Selection filters based on the contents of the currently selected field.

Filters do not affect the table itself, and they can be turned on and off using the Apply Filter and Remove Filter buttons. These two buttons are actually the same button: the button name changes (although the picture on the button does not) depending on the filter state. After you have created a filter, the Apply Filter button becomes the Remove Filter button. When you click the Remove Filter button, the table reverts to its original display.

In this exercise, you create a filter that restricts the data in tblHumanResourcesData to employees who earn $30,000 or more a year.

1
On the Table Datasheet toolbar, click the Filter By Form button.

The Filter By Form window for tblHumanResourcesData appears.

2
Click in the Hours field, click the down arrow that appears, and then click 40.


[image: image10.png]| thHumanResourcesData Filter by Form
Employee ID_| Date Hired |





3
On the Filter/Sort toolbar, click the Apply Filter button.

The table appears, showing only records for employees who work 40 hours each week.
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4
On the Table Datasheet toolbar, click the Remove Filter button.

The table returns to its original display.

5
In the Title field, click any record for a Marketing Rep.

6
On the Table Datasheet toolbar, click the Filter By Selection button.

The table appears, showing only records for employees with the title Marketing Rep.
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7
On the Table Datasheet toolbar, click the Remove Filter button.

The table returns to its original display.

8
On the Table Datasheet toolbar, click the Save button.

Access saves tblHumanResourcesData.

9
Click the Close button in the top-right corner of tblHumanResourcesData.

The table closes.

Establishing Relationships between Tables

You can establish relationships between tables that contain similar information or fields. There are three types of relationships that you can establish between the fields in tables: one-to-one, one-to-many, and many-to-many. Many-to-many relationships are beyond the scope of this course.

A one-to-one relationship exists when two tables have an identical field containing the same information, meaning each record in a table has one matching record in a related table. For example, both tblEmployees and tblHumanResourcesData have an EmployeeID field that contains 28 records listing the employee IDs for the same 28 employees of Adventure Works. The lists are identical, which means that employee H101 has one record in tblEmployees (listing the employee’s address and phone number) and one record in tblHumanResourcesData (listing the employee’s salary, position, date of hire, and hours worked per week). The relationship between tblEmployees and tblHumanResourcesData is a one-to-one relationship because if there is a record containing H101 in the EmployeeID field of tblEmployees, there is one and only one record containing H101 in tblHumanResourcesData.

A one-to-many relationship exists when each record in a table has one or more matching records in the related table. For example, tblVendors lists the vendors that sell products to Adventure Works. Each vendor and its vendor ID appear only once in tblVendors. The products ordered from these vendors are listed in tblProducts, and because each vendor sells more than one product, the VendorID might appear several times in this table. If you established a relationship between tblVendors and tblProducts, the result would be a one-to-many relationship.

An advantage to establishing relationships between tables is that you can enforce referential integrity, which helps prevent inaccurate values from being entered into related fields. Referential integrity requires that the record(s) in one table in a relationship have one or more corresponding records in the other table in the relationship. If referential integrity were enforced between tblVendors and tblProducts, for example, you could not enter a product into tblProducts if the vendor was not also listed in tblVendors.

Relationships between tables can be created, modified, and enforced with referential integrity from the Relationships window, which is opened by clicking the Relationships button on the Database toolbar.

You can print the relationships as they appear in the Relationships window by clicking the Print Relationships command on the File menu. When you print relationships, a report is created that contains the relationships exactly as they appear in the Relationships window. You can customize this report and save it as a separate object in the database.

In this exercise, you create a one-to-many relationship between the VendorID fields of tblVendors and tblProducts, print the relationships in the database, and enforce referential integrity.

1
On the Database toolbar, click the Relationships button.

The Relationships window appears.

2
On the Relationship toolbar, click the Show Table button.

The Show Table dialog box appears.
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3
Click tblProducts, and click Add.

Access adds the field list for tblProducts to the Relationships window.

4
Click tblVendors, and click Add.

Access adds the field list for tblVendors to the Relationships window.

5
Click Close.

The Show Table dialog box closes, and the Relationships window becomes completely visible.
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6
In the tblProducts field list, click VendorID, and drag the field name on top of the VendorID field in the tblVendors field list.

The Edit Relationships dialog box appears, as shown below.
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7
Select the Enforce Referential Integrity check box, and click Create.

The Edit Relationships dialog box closes, and a line appears between the VendorID fields in the tblProducts and tblVendors field lists, indicating that a relationship exists.
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8
On the Relationship toolbar, click the Save button.

Access saves the Relationships window.

9
On the File menu, click Print Relationships.
The relationships in the database appear as a report in Print Preview.

10
On the Print Preview toolbar, click the Print button.
A message box appears, telling you that Access is printing the table.

11
Click the Close button in the top-right corner of the Print Preview window.

An alert box appears, asking if you want to save changes.

12
Click No.

The alert box closes.

13
Click the Close button in the top-right corner of the Relationships window.

The Relationships window closes.

14
Click tblProducts, and click Open on the Database window toolbar.

The table opens in Datasheet view.

15
Click the New Record button.

16
In the VendorID field, type RQ, and press Tab.

17
In the Description field, type Pillow Chocolates (1000), and press Enter.

An alert box appears, indicating that you cannot add this record because a related record is required in tblVendors.

18
Click OK.

The alert box closes.

19
Click in the VendorID field, delete the existing text, type RS, and then press Enter.

Access selects the text in the Description field. No alert box appears; RS is an acceptable value.

20
Click the Close button in the top-right corner of tblVendors.

The table closes.

Creating Subdatasheets

If you have two tables in a one-to-many relationship, you can create a subdatasheet to allow you to see the records from one table while the other table is open. A subdatasheet is a table within a table. For example, if you create a subdatasheet from the one-to-many relationship between tblVendors and tblProducts, you can see the products carried by each vendor listed in tblProducts by expanding the record in tblVendors.

For a subdatasheet to work, there must be at least one identical field in both the table that you are working in and the table that you want to insert as a subdatasheet, and that field must be the primary key for at least one of the tables. For tblVendors and tblProducts, that field is VendorID, the primary key in tblVendors.

In this exercise, you create a subdatasheet in tblVendors that contains the related information from tblProducts.

1
Click tblVendors, and click Open on the Database window toolbar.

The table opens in Datasheet view.

2
On the Insert menu, click Subdatasheet.

The Insert Subdatasheet dialog box appears, with tblProducts already selected.

3
Click OK.

The Insert Subdatasheet dialog box closes, and tblVendors appears in Datasheet view, with plus signs (+) to the left of the records, which indicate the presence of subdatasheets.
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4
Click the plus sign (+) to the left of the first record, for VendorID CH, Erewhon Children’s Store.

The subdatasheet of products offered by Erewhon Children’s Store, taken from tblProducts, appears.
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5
On the Table Datasheet toolbar, click the Save button.

Access saves tblVendors.

6
Click the Close button in the top-right corner of tblVendors.

The table closes.

Importing Records from an External Source

When adding data to tables, you might find that some of the data that you want in your database already exists in a Microsoft Excel worksheet, an HTML file, a text file, or a table from another database program. Although you could print the data and type it in your database, it is easier to import the information into Access from the source.

To import data, the field names in the source must be identical to the field names in the table where the data is being copied. Also, the data types in the source must be compatible with the data types in the table where the data is being copied. For example, if a field in the source contains text and you attempt to copy it into a table for which the corresponding field is a number, you’ll receive an error message.

In this exercise, you import data from the Excel worksheet ImportPractice into a new table in the Database Fundamentals 03 database.

1
On the File menu, point to Get External Data, and click Import.

The Import dialog box appears.

2
In the Look in box, verify that the Database Fundamentals Practice folder is selected.

3
Click the Files of type down arrow, and click Microsoft Excel (*.xls).

4
Click ImportPractice, and click Import.

The first Import Spreadsheet Wizard dialog box appears.
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5
Verify that the Show Worksheets option is selected, and click Next.

The next Import Spreadsheet Wizard dialog box appears.
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6
Select the First Row Contains Column Headings check box, and click Next.

The next Import Spreadsheet Wizard dialog box appears, as shown here:
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7
Verify that the In a New Table option is selected, and click Next.

The next Import Spreadsheet Wizard dialog box appears.
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8
Click Next to accept all fields.

The next Import Spreadsheet Wizard dialog box appears.
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Click the Choose my own primary key option, verify that GuestID appears in the box to the right, and then click Next.

GuestID is selected as the primary key, and the next Import Spreadsheet Wizard dialog box appears.
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In the Import to Table box, delete the existing text, and type tblImportPractice.

11
Verify that the I would like a wizard to analyze my table after importing data and Display Help after wizard is finished check boxes are cleared, and click Finish.

A message box appears, telling you that Access is finished importing the table.

12
Click OK.

The new table, tblImportPractice, now appears in the list of tables in the Database window.

13
Click tblImportPractice, if necessary, and click Open on the Database window toolbar.

The table opens in Datasheet view.
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Click the Close button in the top-right corner of tblImportPractice.

The table closes.

Copying Records into a Table

If the records that you need for your table exist in another table, these records can be copied from one table to another, even if the other table is in another database. If you want to copy data from one table to another, you have to follow the same rules that you follow when importing data from an external source: the field names in the originating table must be identical to the field names in the table in which the data is being copied, and the data types in the originating table must be compatible with the data types in the table in which data is copied.

To copy data from one table to another, you use the Copy and Paste buttons. After you select the data to be copied and click the Copy button, the data is saved on the Office Clipboard. The Office Clipboard is a special file accessible in Microsoft Excel, Word, Access, Outlook, or PowerPoint and can be used to copy and paste data within a file, between files, or between applications.

The Office Clipboard can hold up to twenty-four different items. To choose which saved item will be pasted, to clear the clipboard, or to paste all the items on the clipboard, you display the Office Clipboard from the Edit menu, and then click on any item in the Clipboard that you want to paste into the current database.

Lesson Wrap-Up

This lesson covered how to change the format of tables, sort and find records in a table, use filters, establish relationships among tables, create subdatasheets, and import records from an external source.

If you are continuing on to the next lesson:

· Click the Close button in the top-right corner of the Database window.

· The Database Fundamentals 03 database closes.

If you are not continuing to the next lesson:

· To quit Access for now, click the Close button in the top-right corner of the Access window.

Access and the Database Fundamentals 03 database close.

Quick Quiz

1
What is a subdatasheet?

2
What is referential integrity?

3
What are the two types of filters?

4
What is the difference between a one-to-one relationship and a one-to-many relationship?

5
How do you import records?

6
What does the Find command do?

7
What is the default format for a table?

8
What do input masks and Lookup fields do?

9
What are the two types of sorts?

10
What does a filter do?

Putting It All Together

Exercise 1: Import the Excel worksheet ImportPractice, and name the new table tblGuestList. Change the MailingList field to display either Yes or No. (Hint: Use the Format property for the field.) Sort the table so that the records are arranged alphabetically by last name. Set the text to 12-point Bookman Old Style, and make the background of the table yellow. Adjust the column widths so that all the text is visible. Search for the address that includes the word Carter. (Hint: In the Find and Replace dialog box, set the Match box to Any Part of Field.) Use the Filter By Form button to find only records for guests from CA. Save and close the table.

Exercise 2: Set up a one-to-many relationship between tblSuites and tblReservations. (Hint: The SuiteID field in tblSuites contains the same data as the SuiteNo field in tblReservations.) Enforce referential integrity so that you cannot accidentally make a reservation for a suite that doesn’t exist. Print a copy of the relationships in the database, and do not save the report that Access creates. Save and close the Relationships window.

Exercise 3: Open the tblInsurance table in the Database Fundamentals 03 database and examine it in Datasheet view. Open the tblHumanResourcesData table in Design view and add a field named PlanID. Set its Data Type and Field Length properties according to the data you see in the tblInsurance table. Create a meaningful Caption for the field, and assign one of the existing plan IDs as a Default value. Save the tblHumanResourcesData table and switch to Datasheet view. Assign one of the existing health plan codes to each employee in the tblHumanResourcesData table. Close the table when finished.

Exercise 4: Open the Database Fundamentals 03 database and then open the Relationships window. Create a one-to-many relationship between the tblInsurance and the tblHumanResourcesData table, using the PlanID field as the joint field. Make sure to enforce referential integrity. Print the relationship. Open the tblHumanResourcesData table and insert a new employee (don't forget to enter the new employee in the tblEmployees table as well). Assign a new ID to the employee and create the other required data. Try to assign a Health Plan code of F. Does Access let you assign that code? If not, assign some other valid health plan ID for the record. 

Exercise 5: Open the tblHumanResourcesData table in Datasheet view. Sort the table in ascending sequence using the Health Plan data field. Print the sorted table. Sort the table again using the Employee ID field to return it to its original sequence. Use Filter By Selection to select and filter the table on each of the Health Plan ID codes, starting with A, then B, and so forth. Print the results of each filter before removing the filter. Compare the employees returned for each filter to the list of all employees sorted by health code. Do all of the employees show up in each list for each plan ID? Open the tblInsurance table and insert a subdatasheet using the relationship between the insurance and human resources table. Expand the subdatasheet for each health plan ID and compare the list of employees to the results of your filter printouts for each plan ID code.

Lesson 3








The Raised cell effect is not visible if the table background is white or if the table has colored gridlines.





Notice that the table appears in the default format of �10-point Arial font with silver gridlines.





You can also modify the font properties by clicking Font on the Format menu to display the Font dialog box.





You can also modify the Datasheet format by clicking Datasheet on the Format menu to display the Datasheet Formatting dialog box.





You can also change column width by clicking in the column that you want to change and clicking Column Width on the Format menu to display the Column Width dialog box. Column widths are measured by the number of characters in the field, so a column with a measurement of 4 holds four characters.





You can return column widths to the default settings by clicking in the column that you want to change, clicking Column Width on the Format menu, and then clicking Standard Widths in the Column Width dialog box. You can change the default column width by clicking Options on the Tools menu, clicking the Datasheet tab in the Options dialog box, and then typing a new value in the Default Column Width box.





The record for the employee who earns the largest salary of $45,200 appears at the top.





The record for employee H101, whose employee ID number is first in ascending order, appears at the top.





To open the Find and Replace dialog box, you can also click Find on the Edit menu or press Ctrl+F.


You can change your search to the entire table, rather than a single field, by clicking the Look In down arrow and selecting the table name.





The values in the drop-down menus are values that exist in at least one record in the table.





You can add new records to a table of filtered records. The new records will be included in the original table after the filter is removed.





Most database relationships are one-to-many relationships.





Access 2002 allows you to print a copy of the relation-�ships in your database.





Reports are discussed in more detail in Lesson 6, “Designing a Report.”





You can also open the Show Table dialog box by clicking Show Table on the Relationships menu.





The 1 next to tblVendors indicates that it is on the one side of the one-to-many relationship, while the infinity sign  next to tblProducts indicates that it is on the many side.





RS is the code for Ritzy Restaurant Supply, which is a record in tblVendors.





You can use a subdatasheet to view and edit related records in tables with a one-to-many relationship.





To delete a subdatasheet, point to Subdatasheet on the Format menu, and click Remove.





You can enter new data directly into a subdatasheet by clicking in the first empty record in the subdatasheet and typing.





If it takes a long time to import a spreadsheet, an error might have occurred. To cancel the import, press Ctrl+Break.





If you encounter problems while importing records, Access will add a row to your table called Import Errors. For a list of the errors, double-click the Import Errors table in the Tables section of the Database window





The column headings (field names) for the imported data appear in the row to the right of the number 1.





If you choose the In an Existing Table option, you must be sure that the field names and data types of the data that you are importing match those in the existing table.





If you do not want a certain field to be imported, you can select the Do not import field (Skip) check box.





You can always change or delete the primary key specification in Design view after the table is created.





If you do not have the Table Analyzer Wizard installed on your computer, the I would like a wizard to analyze my table after importing the data check box will not appear.





If you leave the Display Help after wizard is finished check box selected, Access Help will open after you import the table.








