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Designing a Report
After completing this lesson, you will be able to:

· Create a report using AutoReport.

· Create a report using the Report Wizard.

· Add controls to a report.

· Format a report.

· Create calculated controls.

· Preview and print a report.

Reports are similar to forms in that they are based on data in an underlying table or query. However, while forms are designed to facilitate viewing and entering data, the purpose of a report is to print data in an attractive and easy-to-read format. In fact, you cannot actually enter data into a database using a report.

For example, say you wanted to create a list of contact information for all the employees at Adventure Works. You could use the table that contains the data, but the plain, compact presentation might be hard to read.
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You can use reports to present data in a manner that looks professional on the printed page. Compare the format of the table above with the same data arranged in the report below.
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Creating a report is very similar to creating a form. Both reports and forms use controls to organize and display data. As a result, many of the techniques for producing forms discussed in Lesson 5, “Designing a Form,” also apply to reports. Once you create a report, you can add controls to the report, modify the report format, and create calculated controls.

Like other Microsoft Access objects, you can open and modify reports in Design view. But unlike other objects, you can display the report itself in two ways. Layout view, which is specific to reports, displays only the first page of a report. In general, you use Layout view to check the appearance of a report. Print Preview displays the entire report exactly as it will be printed, including all of its data and layout.

To complete the procedures in this lesson, you will need to use a file named Database Fundamentals 06 in the Database Fundamentals Practice folder that is located on your hard disk.

Creating a Report Using AutoReport

In Access, you can create reports in three ways: using AutoReport, the Report Wizard, or Design view. Of these three options, the fastest way to create reports is to use AutoReport. This technique, while quick and simple, does not offer you much opportunity to customize the report. If you use AutoReport, you select only the format for the report and the table or query that the report will be based on; you can’t select the fields, the page orientation, or the font that you want to use in the report. If you want to customize the report further, you modify the report in Design view after it is created.

If you use AutoReport, you can select one of two layouts for your report: columnar layout or tabular layout. Columnar reports present data on a record-by-record basis, similar to a form, with field names displayed for each record. The illustration on the following page is an example of a columnar report based on tblVendors.
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Similar to Datasheet view for tables, tabular reports display field names at the top of each page and the records from the underlying table or query on a line-by-line basis. The following illustration is an example of a tabular report based on tblVendors.
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In this exercise, you open the Database Fundamentals 06 database and use AutoReport to create a tabular report from tblEmployees.

1
With Access open, click the Open button on the Database toolbar.

The Open dialog box appears.

2
Click the Look in down arrow, click the icon for your hard disk, and then double-click the Unlimited Potential folder.

3
Double-click the Database Fundamentals Practice folder.

The Open dialog box displays a list of files stored in the Database Fundamentals Practice folder.

3
Click the Database Fundamentals 06 database, and click Open.

The Database window for Database Fundamentals 06 appears.

4
On the Objects bar, click Reports, and click the New button on the Database window toolbar.

The New Report dialog box appears.
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5
In the New Report dialog box, click AutoReport: Tabular.

6
Click the Choose the table or query where the object’s data comes from down arrow, click tblEmployees, and then click OK.

The report appears in Print Preview, with all the fields from tblEmployees displayed.
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7
On the Print Preview toolbar, click the View button.

The report appears in Design view with the toolbox open, as shown in the following illustration.
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8
On the Report Design toolbar, click the Save button.

The Save As dialog box appears with tblEmployees in the Report Name box.

9
Type rptEmployees, and click OK.

Access saves the report as rptEmployees.

10
Click the Close button in the top-right corner of rptEmployees.
The report closes.

Creating a Report Using the Report Wizard

Compared to AutoReport, the Report Wizard provides more flexibility for creating and customizing a report. The Report Wizard asks questions about the report that you want to create and designs the report based on your answers. Using the Report Wizard, you can select the fields that you want in the report, the layout that best meets your needs, and the style that you want for the report. Even if you plan to modify the report after it is created, the Report Wizard is a good way to create a report because it automates many processes—such as positioning controls—that take time when you create a report in Design view.

To keep related records together and make the report easier to read, you can use the Report Wizard to sort and group the data in the report. You can designate grouping levels to organize data according to the field that you select. For example, if you designate VendorName as a grouping level for a report based on tblVendors, the report places all the records for one vendor name in the first part in the report, the records for the next vendor name in the next part of the report, and so on. The Report Wizard has a number of layout options that you can use to emphasize grouping levels.

Specifying a sort order in addition to grouping levels organizes the report data even more by changing the order of the records within a group. For example, if you create a report of orders from every Adventure Works vendor, you can group the report data by vendor name and sort the orders for each vendor by date in either ascending or descending order. By default, Access sorts the records in ascending order unless you click the Sort button next to the box where you specify the field by which to sort. You can change the sort order back to ascending by clicking the button again. The caption on the button changes to indicate how the records will be sorted.

The Report Wizard also prompts you to choose whether the pages of the report will be in portrait or landscape orientation. In portrait orientation, the short side of the paper is at the top of the page, so more records fit on the page vertically.
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In landscape orientation, the long side of the paper is at the top of the page, so more fields fit on the page horizontally. If the report contains a lot of fields and it’s important to fit all of them on a single page, consider using landscape orientation.

[image: image9.png]



In this exercise, you use the Report Wizard to create a report based on tblAllOrders. You group the report data by VendorName (so that all the information for each vendor is together) and sort the data in descending order by OrderDate (so that the orders for each vendor appear in order by date with the most recent order first).

1
Double-click Create report by using wizard.

The first Report Wizard dialog box appears, with Table: tblAllOrders in the Tables/Queries box, and the VendorName field selected in the Available Fields list.
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2
Click the > (Add) button.

The VendorName field moves to the Selected Fields list.

3
Repeat step 2 for the rest of the fields in tblAllOrders except EmployeeID and VendorID.

The OrderNo, OrderDate, ProductCode, Description, NoOfUnits, Price, and Shipping fields move to the Selected Fields list.
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4
Click Next.

The next Report Wizard dialog box appears, with VendorName already selected in the field list on the left side of the dialog box.
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5
Click the > (Add) button, and click Next.

VendorName is selected as the grouping level. The next Report Wizard dialog box appears.
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6
In the first box, click the down arrow, click OrderDate, click the Sort Ascending button, and then click Next.

OrderDate is selected as the field by which Access will sort the data in each group, and the data will be sorted in descending order. The next Report Wizard dialog box appears.
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7
Verify that the Stepped layout is selected, click the Landscape option in the Orientation section, verify that the Adjust the field width so all fields fit on a page check box is selected, and then click Next.

The report will appear in Stepped layout, meaning that data appear in columns corresponding to the grouping levels. The next Report Wizard dialog box appears.
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8
Click Formal, if necessary, and click Next.

The report will use the Formal style. The next Report Wizard dialog box appears.
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9
In the What title do you want for your report? box, type rptAllOrders, verify that the Preview the report option is selected, and then click Finish.

The Report Wizard closes, and rptAllOrders appears in Print Preview, with the fields from tblAllOrders grouped by vendor name and sorted by order date.
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10
Click the Close button in the top-right corner of rptAllOrders.

The report closes.

Adding a Control to a Report

After you create a report using AutoReport or the Report Wizard, you can customize the report in Design view by adding, modifying, and removing controls.

As with forms, reports are made up of bound, unbound, and calculated controls. When you add fields from a table or query to a report as a control, Access designates the control as a bound control. Bound controls have a connection to an underlying table or query, while unbound controls do not. For example, if you add the EmployeeID field from tblEmployees to a report as a control, Access will display data from the EmployeeID field in tblEmployees in the report.

The reports that you created earlier in this lesson used two types of bound controls: labels and text boxes, which Access usually adds to reports as a pair. Labels describe the data in the text boxes, while text boxes display data from the table or query that the report is based on.
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You can customize a report by dividing it into sections, which display information at different places in the report. Reports have three sections by default: the Detail section, which shows information from the table or query providing data for the report; the page header, which contains text and other controls that appear at the top of every printed report page; and the page footer, which contains text and other controls that appear at the bottom of every printed report page.

The Detail, Page Header, and Page Footer sections for reports are almost identical to these sections for forms. When you work with a report, however, you also have the option of including a report header, a report footer, a group header, and a group footer in your report.


	Section
	Displays Information

	Report header
	At the top of the first printed page of a report.

	Report footer
	At the bottom of the last printed page of a report (below the page footer).

	Group header
	At the beginning of each group of records. The header is named after the grouping level for the records.

	Group footer
	At the end of each group of records. The footer is named after the grouping level for the records.


You must add report headers and footers to a report as a pair, but you can add group headers and footers separately. As with forms, each section of a report has a bar above it that displays the name of the section.
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Using several sections in a report can result in some complications. For example, when you add a field to the Detail section, Access puts both the text box and the related label in the Detail section—although labels are often placed in the Page Header section—which means you have to move the label manually.

In this exercise, you open rptPhoneBook in Design view and add a label in the page footer.

1
Click rptPhoneBook, and click Design on the Database window toolbar.

The report appears in Design view with the toolbox open.
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2
In the toolbox, click the Label tool, and click any blank area in the Page Footer section below the existing controls, about a half-inch from the left edge of the section.

A blank label with a flashing insertion point appears.

3
Type For corporate use only, and click any blank area in the report.
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4
On the Report Design toolbar, click the Save button.

Access saves the report.

Creating a Report in Design View

It is easiest to create reports using AutoReport or the Report Wizard, but you can also create more customized reports by displaying a blank report in Design view and adding the report elements manually. Creating a report in Design view offers more flexibility and design options.

To create a report in Design view:

1
On the Objects bar, click Reports.

2
On the Database window toolbar, click New.

3
In the New Report dialog box, click Design View, if necessary.

4
Click the Choose the table or query where the object’s data comes from down arrow, click the table or query that contains the data that you want to use in your report, and then click OK.

After you follow these steps, a blank report, the toolbox, and a field list for the table or query that you selected appear. You can then add bound controls to the report by dragging field names from the field list to the blank report. To create unbound controls, you use the tools in the toolbox, which can be opened and closed by clicking the Toolbox button on the Report Design toolbar.

Another way to create a report in Design view is to double-click Create report in Design view in the Database window. However, this method does not give you a chance to select a table or query from which to pull values and, as a result, does not open a field list for the table or query that you want to use. To open a field list, you must open the property sheet for the report, click the Data tab, click in the Record Source box, click the down arrow that appears, and then click the table that you want to use.

Formatting a Report

The strength of a report depends on its appearance. Access offers many options for enhancing the appearance and effectiveness of a report by changing its format.

Each part of a report—controls, report sections, and even the report itself—has its own set of properties, which can be changed using the property sheet for that part of the report. Using property sheets, you can change the format of text to include, for example, dollar signs or decimals. You can also adjust the size, font, and color of the report text or the report itself, and you can add lines, graphics, and other controls to the report.

To open a property sheet for a report or part of a report, you double-click the part of the report that you want to format. To open the property sheet for the whole report, you double-click the report selector, which is the box in the top-left corner of the report, next to the horizontal ruler.
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Many sections of the report also can be modified using the Formatting (Form/Report) toolbar, which can be opened or closed by pointing to Toolbars on the View menu and clicking Formatting (Form/Report). To format a control using the buttons on the Formatting toolbar, you click the control so that handles appear on the edges of the control, indicating that the control is selected. If you want to select more than one control, hold down the Shift key and click all the controls that you want to select. To select all the controls on the report, press Ctrl+A or click Select All on the Edit menu. To deselect a control, hold down the Shift key and click the selected control. You can deselect all the report controls by clicking any blank area in the report.

In this exercise, you modify rptPhoneBook. You use the Formatting toolbar to modify the font size, style, and color of the For Corporate Use Only label in the Page Footer section. You use the property sheet to modify the text, style, and color of the rptEmployees label in the Report Header section.

1
In the Page Footer section of rptPhoneBook, click the For Corporate Use Only label.

Handles appear on the label, indicating that it is selected.

2
On the Formatting toolbar, click the Font down arrow, and locate and click on Arial.

The label text changes to Arial font.

3
On the Formatting toolbar, click the Font Size down arrow, and 
click 14.

The label text changes to 14 points in size.

4
On the Formatting toolbar, click the Font/Fore Color down arrow, and click the red square.

The label text changes to red.
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5
In the Report Header section, double-click the edge of the rptEmployees label.

The Label property sheet appears.

6
Click the Format tab, if necessary.

7
Click in the Caption box, delete the existing text, and then type Employee Phone Book.

The label text will read Employee Phone Book.

8
Scroll down, click in the Fore Color box, and then click the Build button that appears.

The Color dialog box opens.

9
Click a blue square, and click OK.
The label text will be blue.

10
Scroll down, click in the Font Weight box, click the down arrow that appears, and then click Bold.
The label text will be bold.

11
Click the Close button in the top-right corner of the Label property sheet.

The Label property sheet closes. Note that the label text now reads Employee Phone Book in a blue, bold font.
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12
On the Report Design toolbar, click the Save button.

Access saves rptPhoneBook.

Creating Calculated Controls

Reports are a convenient way to display the results of calculations performed on data in the database. You can create calculated controls in a report to present the results of mathematical expressions, such as one field multiplied by another, one field multiplied by a number, one field subtracted from another, or two fields added together.

For example, the Vice President of Finance at Adventure Works requests a report that shows the total cost of each order placed by the resort and includes the cost of the items ordered, the number of units in each order, and the shipping cost. You could create a query based on tblAllOrders that contained the requested data, but to present the data in a more attractive format, you would still need to create a report based on the query. With a calculated control, you can do the calculation for the total cost of each order in the report itself.

You enter the expressions for calculated controls into unbound text boxes. You can enter the expression for the calculated control directly into the unbound text box or by typing the expression in the Control Source box in the Data tab of the property sheet for the text box. Expressions begin with an equal sign (=), followed by the name of a field (surrounded by brackets), followed by the appropriate operator, followed by the next term in the expression. For example, to multiply Price by NoOfUnits, you would type =[Price]*[NoOfUnits].

In this exercise, you create a calculated control that will show the total for each order in rptAllOrders.

1
Click rptAllOrders, and click Design on the Database window toolbar.

The report appears in Design view with the toolbox open.
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2
Move the mouse pointer over the bottom edge of the Detail section until the pointer turns into a resizing double-headed arrow, and drag the edge down about one-half inch.

The Detail section increases in size by one-half inch.

3
In the toolbox, click the Text Box tool, align the plus sign (+) on 
the mouse pointer below the left edge of the Description text box in the Detail section, and then click the mouse.

An unbound text box and label appear in the report.
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4
Click the new label, move the mouse pointer over the top-left handle of the label until the pointer turns into a pointing hand, and then drag the label to the right until it touches the unbound text box.
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5
Move the mouse pointer over the center of the label until the pointer turns into an insertion point, click the mouse, delete the existing text, and then type TOTAL.

6
Click any blank area in the report.

7
Double-click the edge of the new text box.
The Text Box property sheet appears.

8
In the Text Box property sheet, click the Data tab.
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9
In the Control Source box, type =[Price]*[NoOfUnits]+[Shipping].

This expression multiplies the price of the items ordered by the number of units ordered and adds the shipping cost.

10
Click the Format tab.
11
Scroll up, if necessary, click in the Format box, click the down arrow that appears, scroll down, and then click Currency.

The data in the calculated control text box will be formatted as currency.

12
Scroll down, click in the Text Align box, click the down arrow that appears, and then click Left.

The data in the calculated control text box will be aligned to the left.

13
Click the Close button in the top-right corner of the Text Box property sheet.

The Text Box property sheet closes.

14
On the Report Design toolbar, click the Save button.

Access saves the report.

15
On the Report Design toolbar, click the View button.

The report appears in Print Preview, with the totals for each order displayed.
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Previewing and Printing a Report

Now you’re ready to perform the function that makes reports most worthwhile: printing them. As with most other database objects in Access, there are two ways to print a report. You can click the Print button on the Report Design or Print Preview toolbar or click Print on the File menu. If you click Print on the File menu, the Print dialog box appears, which offers several options for printing a report. For example, if you wanted to print only one page of a 
10-page report, you could do that by using the Print dialog box.

Before you print, you can look at the report in either Layout view or Print Preview. Layout view and Print Preview share the same toolbar, the Print Preview toolbar, because both views are ways to view what the report will look like when it is printed. Remember, Layout view shows only the first page of the report; if you click the Print button while viewing the report in Layout view, Access prints only the first page of the report. In Print Preview, clicking the Print button on the Print Preview toolbar prints the entire report.

In this exercise, you print the first two pages of rptAllOrders.

1
On the File menu, click Print.

The Print dialog box appears.
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2
In the Print Range section, click the Pages option, type 1 in the From box, press Tab, and then type 2 in the To box.

3
Click OK.

The Print dialog box closes, and Access prints pages 1 and 2 of the report.

4
Click the Close button in the top-right corner of rptAllOrders.

The report closes.

Compacting and Repairing a Database

In Access 2002, the processes to compact and repair a database have been combined. Compacting a database reduces the size of the database by thousands of kilobytes (KB) and stores the data in the database more efficiently. You can compact a database once, or you can instruct Access to compact the database every time you close it.

Occasionally, a database might become damaged and begin to act in strange ways. For example, if the power goes out while you are working with a database, some data in the database might be affected. Every time you compact a database, Access also checks to see if repairs need to be made.

Access detects errors by maintaining an abbreviated list of each record’s contents. If Access detects an error during compacting, it tries to repair the data errors by changing them to fit the internal record. If the data can’t be reconciled with the internal record, Access displays an alert box indicating that an error occurred. If you ever start to have problems with your database and suspect that it might be damaged, you should compact the database to see if the problems can be fixed.

To compact a database:

1
If the database is a multi-user database located on a server or shared folder, verify that the database is not open.

2
Open the database that you want to compact.

3
On the Tools menu, point to Database Utilities, and click Compact and Repair Database.

To instruct Access to compact a database every time you close it (unless another user is using the database):

1
Open the database that you want to compact automatically.

2
On the Tools menu, click Options.

3
In the Options dialog box, click the General tab, select the Compact on Close check box, and then click OK. 

Lesson Wrap-Up

This lesson covered how to create reports using AutoReport and the Report Wizard, format reports, add report sections, add controls to reports, create calculated controls, preview and print a report, and compact and repair a database.

If you are continuing to another lesson:

· Click the Close button in the top-right corner of the Database window.

The Database Fundamentals 06 database closes.

If you are not continuing to another lesson:

· To quit Access for now, click the Close button in the top-right corner of the Access window.

Access and the Database Fundamentals 06 database close.

Quick Quiz

1
What is the difference between Layout view and Print Preview?

2
What are the benefits of compacting a database?

3
How do you specify the pages of a report that you want to print?

4
What are grouping levels?

5
What is the quickest method for creating a report?

6
What three sections does a report have by default?

7
How do you create a report quickly but with more style and layout options than are available with AutoReport?

8
What is a label control?

Putting It All Together

Exercise 1: Using AutoReport, create a tabular report based on tblHumanResourcesData called rptHumanResourcesData. Change the label in the Report Header section so that it reads Human Resources Data, and change the font to be 20 points, red, and italicized. In the Detail section, create a calculated field named Hourly Wage that shows the hourly wage for each employee at Adventure Works, assuming each employee works 2000 hours a year. View the report in Print Preview before you close it.

Exercise 2: Using the Report Wizard, create a report called rptProducts that includes all the fields in tblProducts. Use VendorID as a grouping level, and sort the report in ascending order by Description. Use the Outline 1 layout and the Soft Gray style for the report. Change the label in the Report Header section of the report to read Product List by Vendor, and resize the label to fit the new title, if necessary. In the VendorID Header section, resize the VendorID label so that it is just large enough for the label text, and move the VendorID text box to the left until it touches the VendorID label. Change the text in the VendorID text box to red. View the report in Print Preview, and print it. Save and close the report.

Exercise 3: Create a relationship between the tblHumanResourcesData table and the tblEmployee table, using the EmployeeID field as the join field. Using the Report Wizard, create a report called rptEmplByTitle that includes The Title, EmployeeID, and Salary fields from the tblHumanResourcesData table. Include the LastName and the FirstName fields from the tblEmployees table. Use Title as a grouping level, and sort the report in ascending order by EmployeeID. Use the Stepped layout and choose any report format you like. When previewed, the report should show each job title, followed by all of the employees who are assigned that job title. Using employee ID sequence within each title, the report will show the salary and first and last names for each employee. After previewing the table, switch to Design view and format the table so that each Title appears in a larger font, using a color of your choice, to make it stand out more from the detail data.

Exercise 4: Open the rptEmplByTitle report in Design view. Click the Sorting and Grouping button on the toolbar. In the dialog box that opens, Make sure the Title field is selected, then click in the Group Footer property box. Click the arrow at the right end of the box, and select Yes. A Title footer will be added to the report. Click the Text box tool in the Toolbox, and click in the Title footer section below the Salary field in the Detail section. Click in the label for the text box and enter Total Salary. Click in the text box itself and enter =Sum([Salary]). This will sum all salaries in the Detail section for each title in the report. Double-click the edge of the text box, and when the Property sheet opens, set the field’s Format to Currency. Save and run the report. If you do not like the report’s appearance, switch back to Design view and make any changes you want to enhance the report.

Exercise 5: Open the MyMusic_XXX (where XXX is your initials) database created in Lesson 2 and used again in Lesson 4. Create a report using any Access report creation method of your choice. The report should list your music collection grouped by category or genre (rock, pop, classical, etc.). Add a second grouping level using the database field that describes the format of the item (CD, mini-CD, MP3, vinyl, etc.). Include the name of the artist or group, the year the music was released, the recording company, and your rating for each item in the table. Format the report so it looks attractive and easy to read. When you preview your report, you should see all music in the first category, subgrouped by item format, and then the detail information for each item in the main and sub- groups. That should be followed by each remaining category and its subgroup information.

Lesson 6





You can switch from Design view to either Layout view or Print Preview and back again, but you cannot switch directly from Layout view to Print Preview or from Print Preview to Layout view.








Records appear in two columns and are separated by lines in a columnar report.





Most reports are designed using a tabular layout.





Each record appears on its own line in a tabular report.





Note that there is no Save button on the Print Preview toolbar.





Unless you make changes, AutoReport and the Report Wizard (which you learn about in the next section) will give a report the same name as the table on which the report is based. To follow the Leszynski naming convention discussed in Lesson 1, “Understanding Databases,” you need to delete tbl and type rpt  before saving the report.





Portrait and landscape orientation are also discussed in Lesson 2, “Creating Tables.”





In this example of portrait orientation, there are too many fields in each record to fit them all on one page. The last two fields for each record are on the second page.





In this example of landscape orientation, all the fields in each record fit on the same page.





After you create a report, you can change the paper orientation by clicking Page Setup on the File menu, clicking the Page tab, and clicking the orientation that you want.





You can also open the Report Wizard by displaying the list of reports in the Database window, clicking New on the Database window toolbar, clicking Report Wizard in the New Report dialog box, selecting a table or query on which to base the report, and then clicking OK.





You can click Cancel at any time to close the Report Wizard without creating the report.





If you select more than one grouping level, you can change the priority of each level using the Priority arrow buttons.





When you select an option, the box to the left of the list of options shows an example of what the option looks like.





You can use these styles with any report, even if the report was not created using the wizard. To format a report with one of these styles, open the report in Design view, and click the AutoFormat button on the Report Design toolbar.





Remember that by default, Access will name the report after the table on which the report is based.�


If you click the Modify the report’s design option, the report opens in Design view.


If you select the Display Help on working with the report? check box, Access Help will start after you click Finish.





When you use the Report Wizard, Access saves the report after you click Finish.





On your computer, the years in the report might appear as four-digit years (2004) instead of the two-digit years (04) seen here. 





Calculated controls are discussed later in this lesson.


Controls are discussed in Lesson 5, “Designing a Form.”





The words in bold font are labels, and all the information below the line is in text boxes. The title for rptEmployees is also a label.





Form sections are discussed in Lesson 5, “Designing a Form.”





Creating a group does not create a group header or footer for the group. You create these sections using the Sorting And Grouping dialog box.





If you remove a section, you delete all the controls in that section.





The VendorName Header is the group header for the group of records with VendorName as the grouping level.





After you click the Label tool, the mouse pointer turns into an “A” with a plus sign (+). The plus sign indicates where the label will begin after you click the mouse.





The For Corporate Use Only label is an unbound control because it does not get its data from a table or query.





Property sheets are discussed in Lesson 5, “Designing a Form.”





When the report is selected, the report selector contains a black box, like the example shown here.





If you display a property sheet for several selected controls, the property sheet will show only the properties that the controls have in common.





Notice that although the font is now too large for the label, the label is not automatically resized. You will resize the label in the next exercise.





You can resize the Employee Phone Book label in the next exercise.








Expressions are discussed in Lesson 4, “Creating and Using Queries.”





When you add a text box to your report, Access gives the new text box a label with a number in it. The name of the text box (Text22 in the illustration) will vary from use to use, so your number will probably not match the number of the text box in the illustration.





Remember that Access aligns text data to the left and numbers to the right by default.





Reports are often quite lengthy, depending on how much data is included in the report. In step 15 of the previous exercise, you displayed rptAllOrders in Print Preview.





To print more than one copy of the report, change the number in the Number of Copies box.








To stop the compacting process, press Ctrl+Break or Esc.








