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Spreadsheet Fundamentals
Lesson 5
Rows, Columns, Worksheets, and Workbooks 
5.13

Working with Rows, Columns, Worksheets, and Workbooks
After completing this lesson, you will be able to:

· Hide and unhide rows and columns.

· Freeze and unfreeze rows and columns.

· Move between worksheets in a workbook.

· Add and delete worksheets in a workbook.

· Create a three-dimensional formula.

· Link workbooks.

· Limit the data that appears on the screen.

As you work with Microsoft Excel, you will probably create worksheets that contain more data than can be viewed all at once on screen. You might also find that you need to distribute related data among several worksheets and workbooks. Fortunately, Excel provides you with several methods to work with the content in large worksheets or spread across multiple worksheets and workbooks. These methods include assorted viewing options, the ability to add or delete worksheets in a workbook, and ways to link worksheets and workbooks.

The viewing options are particularly useful if you have a lot of data in your worksheet. You can magnify a worksheet to enlarge cells and see the content more easily, or you can shrink a worksheet so that you can see more of the content in the worksheet at once. Hiding worksheet rows and columns lets you focus on specific information in your worksheet by concealing nonrelevant data. When you want to see those rows and columns again, you unhide them. You can freeze one or more rows or columns so that they always remain in view, no matter how far you scroll down or across the worksheet. This is helpful when you want to keep data labels in sight. You can easily unfreeze the rows or columns to restore the look of your worksheet.

If you want to include related, but somewhat different, data in an existing workbook, you can add one or more worksheets. This allows you to keep the data in one workbook without creating overly large or complex worksheets. You can easily delete worksheets that are no longer necessary. Also, if you want to link different worksheets in a workbook, you can include formulas in a cell that will refer to data in one or more worksheets in the same workbook. You can also link one or more workbooks in a similar fashion.

An important aspect of working with large amounts of data is the ability to focus on the most important data in a worksheet, whether that data represents the best ten days of sales in a month or slow-selling product lines that you may need to reevaluate. In Microsoft Excel, you have a number of powerful, flexible tools with which you can limit the data displayed in your worksheet. In this lesson, you’ll learn how to limit the data that appears in your worksheets.

To complete the procedures in this lesson, you will need to use the files Sports Income05.xls, Food.xls, Budget.xls, and Filter.xls in the Lesson05 folder in the Spreadsheet Fundamentals Practice folder located on your hard disk.

Hiding and Unhiding Rows and Columns

Sometimes you have more rows or columns in a worksheet than you want to see at one time. In such situations, you can hide rows or columns so that they don’t appear on your screen or in worksheet printouts. When you want to see them again, you unhide them.

For example, the activities coordinator at Adventure Works wants to focus on equipment rented during December, January, and February. On the worksheet, she hides the columns for the rest of the year. She already knows that no one rents kayaks during the winter, so she hides that row as well. When she’s finished viewing the winter rentals, she reveals the hidden columns and the row so she can view the rentals for the entire year.

In this exercise, you hide and unhide worksheet rows and columns.

1
Open the Sports Income 05 workbook.
2
Click the column selector for column D (Feb), and drag the mouse pointer to the column selector for column L (Oct).

Excel selects the columns.

3
On the Format menu, point to Column, and click Hide.

Excel hides the columns. Notice that the column labeling has not changed and shows a gap between columns C and M.
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4
Click the row selector for row 3 (Kayaks).

Excel selects the row.

5
On the Format menu, point to Row, and then click Hide.

Excel hides the row. Notice that the row numbering has not changed and shows a gap between rows 2 and 4.

6
Click the column selector for column C, hold down the Shift key, and then click the column selector for column M.

Excel selects columns C and M.

7
On the Format menu, point to Column, and click Unhide.

Excel reveals columns D through L on the screen.

8
Click a blank area of the worksheet outside of the selected area.

The columns are deselected.

9
Click the row selector for row 2, hold down the Shift key, and click the row selector for row 4.

Excel selects rows 2 and 4.

10
On the Format menu, point to Row, and then click Unhide.

Excel reveals row 3 on the screen.

11
Close the workbook without saving your changes.

Freezing and Unfreezing Rows and Columns

When your worksheet is larger than you can display on screen at once, you need to scroll right and down to see all your columns and rows. If your left-most column and top row contain labels, scrolling can make the labels disappear off the edge of your screen—leaving you to wonder exactly what is in the cells you’re seeing.

To remedy this problem, you can freeze rows and columns so that they remain on the screen even when you scroll down and across the worksheet. For example, the chef at Adventure Works uses a workbook to track the amount of food that is prepared by the popular restaurant at the resort. Doing this helps him determine what supplies to order from month to month. He freezes the rows and columns that have labels so he can keep them in view as he scrolls down and across a worksheet.

In this exercise, you freeze and unfreeze rows and columns.

1
Open the Food workbook.

2
Scroll the worksheet to the right and then back to column A.

When you scroll the worksheet to the right, the left-most columns disappear.

3
Click cell B3.

This cell is just below the row you want to freeze and just to the right of the column you want to freeze.

4
On the Window menu, click Freeze Panes.

The month row and Type of Food column are now frozen.

5
Scroll the worksheet to the right.

The left-most column, with the category labels, remains visible on the screen.

6
Scroll down the worksheet.

The month row remains visible on the screen.
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7
Press Ctrl+Home.

Excel scrolls to the top-left unfrozen cell.

8
On the Window menu, click Unfreeze Panes.

The panes are unfrozen.

Keep this file open for the next exercise.

Moving Between Worksheets in a Workbook

Storing related worksheet data in one workbook file has many organizational benefits. By using this method of organization, you can open all associated worksheets in a workbook at once, which saves time and ensures that all necessary data is available for a specific task. This also lets you quickly view related information and copy necessary data from one worksheet to the next without having to open and close various workbooks. You can navigate from worksheet to worksheet by using the sheet tabs at the bottom of the worksheet window.
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The chef at Adventure Works uses several worksheets in one workbook. He orders different types of foods from different suppliers: one supplier provides meat, such as beef and poultry; another provides dry goods, such as flour and sugar; and a third provides produce. The chef tracks all the food that he orders from each supplier on a separate worksheet in the same workbook. He can view each worksheet in the Food workbook by clicking the appropriate sheet tab.

In this exercise, you navigate between multiple worksheets in a workbook.

1
Click the Dry Goods tab.

The Dry Goods worksheet is displayed.

2
Click the Produce tab.

The Produce worksheet is displayed.

3
Click the Meats tab.

The Meats worksheet is displayed.

Keep this file open for the next exercise.

Adding and Deleting Worksheets in a Workbook

By default, each new workbook contains three blank worksheets. If you don’t need all three worksheets, you can easily delete the unnecessary ones. If you want more worksheets, you can insert as many new ones as you need. You can also insert and delete worksheets in your existing workbooks. For example, the chef at Adventure Works decides to add a new worksheet to the Food workbook. Because he wants this new worksheet to contain summaries of figures from the other three worksheets, he names this worksheet Summary.

In this exercise, you add and delete a worksheet.

1
Click the Produce tab.

Excel displays the Produce worksheet.

2
On the Insert menu, click Worksheet.

Excel inserts a new worksheet named Sheet1 to the left of Produce.

3
Select any cell, type Test, and press Enter.

4
On the Edit menu, click Delete Sheet.

Excel displays an alert.
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5
Click Delete.

Excel deletes the new worksheet and redisplays the Produce worksheet.

6
Click the Meats tab.

Excel displays the Meats worksheet.

7
On the Insert menu, click Worksheet.

Excel inserts a new worksheet named Sheet2 to the left of Meats.
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8
Double-click the Sheet2 tab.

Excel selects the tab.

9
Type Summary, and press Enter.

Excel changes the name of the worksheet.

Keep this file open for the next exercise.

Creating a Three-Dimensional Formula

When using a workbook with multiple worksheets, you can create a three-dimensional formula (also referred to as a 3-D reference) in which a cell in one worksheet refers to data in one or more other worksheets. When data is adjusted on a worksheet, any formula that references that data is also adjusted.

One use for three-dimensional formulas is creating a summary sheet that totals figures from different sheets in a workbook file. For example, the chef at Adventure Works wants to see how much the restaurant has paid for food in a year. To calculate the total amount spent, he uses a three-dimensional formula on the Summary worksheet. The formula refers to the cells in each worksheet that contain the amount spent in a particular food category and adds these amounts together.

As with any formula, you can specify a reference by typing the cell coordinates. The references in the formula, however, must begin with the name of the worksheet to which the formula is linking, followed by an exclamation point, and finally, the cell coordinates. Commas separate the references.

In this exercise, you create a formula in one worksheet that adds together data in other worksheets.

1
Click cell A3 on the Summary worksheet, type Total Cost of Food, and press the down arrow key.

Excel adds the text to cell A3 and moves the insertion point to cell A4.

2
Type =sum(Meats!P36,‘Dry Goods’!P26,Produce!P28) and press Enter.

Excel enters the formula in the cell and displays the sum of the figures that are in cells P36 in the Meats worksheet, P26 in the Dry Goods worksheet, and P28 in the Produce worksheet.
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Keep this file open for the next exercise.

Linking Workbooks

Another powerful feature in Excel is the ability to link data in two or more workbooks. This is useful when it would be impractical to have several large, complex worksheets in one workbook. It is also useful when you need to include the same data in more than one workbook. That way, if you want to update the data, you need to do so only in the original workbook. The data will be updated automatically in the rest of the workbooks.

To create a link between workbooks, you enter a formula in one workbook that refers to one or more cells in another workbook. The workbook that contains the formula is called the dependent workbook, and the workbook that contains the referenced information is called the source workbook.
Building a formula to link workbooks is similar to the process of building a formula to link worksheets within the same workbook. The references in the formula to link workbooks, however, must begin with the name of the source workbook to which the formula is linking, enclosed in square brackets, followed by the worksheet name and an exclamation point.

The accountant at Adventure Works links workbooks when he creates the yearly budget for the resort. He bases the budget on expenditures in each department for the previous year. To save himself the effort of typing all that information into the Budget workbook, he links his workbook to other workbooks that are kept by employees who track expenses for their departments.

In this exercise, you link data from two workbooks to a third workbook.

1
Open the Sports Income05 workbook in the Spreadsheet Fundamentals Practice folder on your hard disk.

2
Open the Budget workbook in the Spreadsheet Fundamentals Practice folder on your hard disk.

3
On the Window menu, click Arrange.

Excel displays the Arrange Windows dialog box.
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4
Click OK.

Excel displays the three workbooks.

5
Click cell A4 in the Budget workbook.

6
Type Food, and then press Tab.

Excel moves the insertion point to cell B4.

7
Type =[Food.xls]Summary!A4, and press Enter.

Excel enters the formula in the cell and displays the contents of cell A4 from the Summary worksheet in the Food workbook.
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8
Click cell A3 in the Budget workbook.

9
Type Activity Equipment, and press Tab.

Excel moves the insertion point to the A4 cell.

10
Type = to start a formula.

11
Click the Sheet1 tab in the Sports Income05 workbook if necessary, scroll and click cell P18.

In the formula you started in the Budget.xls workbook, Excel inserts a reference to the cell in the Sports Income05 workbook. In the Sports Income05 workbook a flashing marquee appears around cell P18.

12
Press Enter.

Excel enters the formula into the cell in the Budget workbook and displays the value.
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13
Hold down the Shift key while you open the File menu.

14
Click Close All on the File menu to close all the open worksheets. Do not save your changes.

Leave Excel open for the next exercise.

Limiting the Data That Appears on the Screen

Excel spreadsheets can hold as much data as you need them to, but you may not want to work with all of the data in a worksheet at the same time. For example, you might want to see the sales figures for your company during the first third, second third, and final third of a month. You can limit the data shown on a worksheet by creating a filter, which is a rule that selects rows to be shown in a worksheet.

To create a filter, you click the cell in the group you want to filter and use the Data menu to turn on AutoFilter. When you turn on AutoFilter, which is a built-in set of filtering capabilities, a down arrow button appears in the cell that Excel recognizes as the column’s label.

tip

When you turn on filtering, Excel treats the cells in the active cell’s column as a range. To ensure that the filtering works properly, you should always add a label to the column you want to filter.

Clicking the down arrow displays a list of values and options. The first few items in the list are filtering options, such as whether you want to display the top ten values in the column, create a custom filter, or display all values in the column (that is, remove the filter). The rest of the items on the list are the unique values in the column—clicking one of those values displays the row or rows containing that value.

Choosing the Top 10 option from the list doesn’t just limit the display to the top ten values. Instead, it opens the Top 10 AutoFilter dialog box. From within this dialog box, you can choose whether to show values from the top or bottom of the list, define the number of items you want to see, and choose whether the number in the middle box indicates the number of items or the percentage of items to be shown when the filter is applied. Using the Top 10 AutoFilter dialog box, you can find your top ten salespeople or identify the top five percent of your customers.

When you choose Custom from the AutoFilter list, you can define a rule that Excel uses to decide which rows to show after the filter is applied. For instance, you can create a rule that only days with total sales of less than $2,500 should be shown in your worksheet. With those results in front of you, you might be able to determine whether the weather or another factor resulted in slower business on those days.

In this exercise, you create a filter to show the top five sales days in January, show sales figures for Mondays during the same month, and display the days with sales of at least $3,000.

1
Open the Filter workbook in the Lesson05 folder of the Spreadsheet Fundamentals Practice folder on your hard disk.

2
If necessary, click the January sheet tab.

3
Click cell P5.

4
On the Data menu, point to Filter, and then click AutoFilter.

A down arrow appears in cell P5.

5
In cell P5, click the down arrow and click (Top 10...) from the list that appears.

The Top 10 AutoFilter dialog box appears.
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6
Click in the middle box, delete 10, type 5, and click OK.

Only the rows containing the five largest values in column P are shown.
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7
On the Data menu, point to Filter, and then click AutoFilter.

The filtered rows reappear.

8
Click cell B5.

9
On the Data menu, point to Filter, and then click AutoFilter.

A down arrow appears in cell B5.

10
In cell B5, click the down arrow and, from the list of unique column values that appears, click Mon.

Only rows with Mon in column B are shown in the worksheet.

11
On the Data menu, point to Filter, and then click AutoFilter.

The filtered rows reappear.

12
Close the workbook without saving your changes.

Lesson Wrap-Up

In this lesson, you learned how to work with view options, including how to magnify and shrink a worksheet, hide and unhide rows and columns, and freeze and unfreeze rows and columns. You learned how to work with multiple worksheets in a workbook, including how to move between worksheets in a workbook, add and delete worksheets, and create formulas that refer to cells in other worksheets and in other workbooks. You also learned how to limit the data that appears in your worksheets through filtering.
If you are continuing to other lessons:

· Save and close all open workbooks.

If you are not continuing to other lessons:

1
Save and close all open workbooks.

2
Click the Close button in the top-right corner of the Excel window.

Quick Quiz

1
How do you navigate between multiple worksheets in a workbook?

2
How can you create linked workbooks?

3
How can you display a worksheet on your screen at 60 percent of normal size?

4
How can you create a three-dimensional formula in a worksheet?

5
If your worksheet is so large that rows and columns with data labels disappear when you scroll down and to the right, what should you do?

6
If you want simultaneously to display certain columns or rows on your screen but columns or rows in the middle make it impossible, what should you do?

Putting It All Together

Exercise 1: Open the Sports Income05.xls workbook. Zoom in on Sheet1 by 50%, and zoom out by 100%. Hide and then unhide column B. Freeze column B and row 3, and then unfreeze them.

Exercise 2: Open the Food.xls workbook. In the Summary worksheet, write a formula that sums the total weight of meat, poultry, and seafood ordered. Open the Budget.xls workbook, and create a formula on the first worksheet that sums the cost of all the produce ordered.

Exercise 3: In the course of linking workbooks you used the Arrange Windows feature to tile multiple windows. What other options are available with this feature? In what circumstances, other than linking workbooks, might it be useful to arrange multiple windows? Other than closing the open workbooks, how do you return to a full screen of a specific workbook?

Exercise 4: In this lesson, you learned how to insert and delete worksheets. You know that the default number of worksheets in a workbook is three, but is there a limit to the number of worksheets that can be added? If there is a limit, what determines this limit? Is there a limit to the number of rows or columns in a workbook? Use the Ask A Question box to determine the answer to these questions.

Exercise 5: As you explored AutoFilter, you may have noticed the Custom option in the AutoFilter list. Use the Filter workbook to explore the Custom option. What could it be used for? If necessary, use Excel’s Help files to determine the filtering possibilities made available through the Custom option. Briefly describe your findings.

When a worksheet has a name consisting of two or more words, the name must be put in single quotation marks in the formula.





When a workbook containing an external reference formula is saved, the name of the source workbook is also saved. You should save all source workbook files first, and then you should save the dependent workbook.





You will probably have to scroll to the right to see cell P18.
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